SDS2 Parametric API
 All Classes Namespaces Functions Variables Pages
Functions
HoleMatch Namespace Reference

Functions

def Bolt
def BoltMaterialToMaterial
def BoltMemberToMember
def BoltToMember
def DontRememberParametric
def FindMembersConnectingFrom
def FindMembersConnectingTo
def FindMembersConnectingToEnd
def FindMembersConnectingToPoint
def GetMember
def GetMemberLink
def GetMemberPiecemark
def GroupMemberCreate
def Hole
def IsPlanView
def MarkMemberForProcess
def MatchHolesMaterialToMaterial
def MatchHolesMemberToMember
def MatchHolesToMember
def MaterialOnMember
def Member
def MemberAllocated
def MemberLocate
def MemberProperties
def MemberPropertySet
def MemberRequiresProcessing
def MembersSelected
def MultiMemberLocate
def PointIsNearMember
def ReaddUserBolts
def RegisteredClassDescription
def RegisterMemberType
def ReuseAllMaterialByCreator
def ReuseMaterial
def set_field_state
def set_widget_state
def SetMaterialXform
def SetMemberBoundingBox
def SetMemberPiecemark
def SetSystemGeneratedByUuids
def UseLastSavedMemberOnAdd

Function Documentation

def HoleMatch.Bolt (   args)
 Bolt object
def HoleMatch.BoltMaterialToMaterial (   args)
 BoltMaterialToMaterial(args)
def HoleMatch.BoltMemberToMember (   args)
 BoltMemberToMember(args)
def HoleMatch.BoltToMember (   args)
 BoltToMember(args)
def HoleMatch.DontRememberParametric (   args)
Returns
Instance of type None
     C++ signature :
         void DontRememberParametric()
def HoleMatch.FindMembersConnectingFrom (   arg1,
  arg2 
)
Returns
Instance of type list
     C++ signature :
         boost::python::list FindMembersConnectingFrom(int,double)
def HoleMatch.FindMembersConnectingTo (   arg1,
  arg2 
)
Returns
Instance of type list
     C++ signature :
         boost::python::list FindMembersConnectingTo(int,double)
def HoleMatch.FindMembersConnectingToEnd (   arg1,
  arg2,
  arg3 
)
Returns
Instance of type list
     C++ signature :
         boost::python::list FindMembersConnectingToEnd(int,bool,double)
def HoleMatch.FindMembersConnectingToPoint (   arg1,
  arg2,
  arg3 
)
Returns
Instance of type list
     C++ signature :
         boost::python::list FindMembersConnectingToPoint(int,Point3D,double)
def HoleMatch.GetMember (   arg1,
  arg2 
)
Returns
Instance of type MemberBase
     C++ signature :
         Alloy::Pointer::Pointer<MemberBase> GetMember(int,bool)
def HoleMatch.GetMemberLink (   arg1,
  arg2,
  arg3 
)
Returns
Instance of type MemberBase
     C++ signature :
         Alloy::Pointer::Pointer<MemberBase> GetMemberLink(int,bool [,bool])
def HoleMatch.GetMemberPiecemark (   arg1)
Returns
Instance of type str
     C++ signature :
         std::string GetMemberPiecemark(int)
def HoleMatch.GroupMemberCreate (   args)
 GroupMemberCreate() creates a member group
def HoleMatch.Hole (   args)
 Hole group object
def HoleMatch.IsPlanView (   args)
Returns
Instance of type bool
     C++ signature :
         bool IsPlanView()
def HoleMatch.MarkMemberForProcess (   args)
 MarkMemberForProcess() marks a member for processing.
def HoleMatch.MatchHolesMaterialToMaterial (   args)
 MatchHolesMaterialToMaterial(args)
def HoleMatch.MatchHolesMemberToMember (   args)
 MatchHolesMemberToMember(args)
def HoleMatch.MatchHolesToMember (   args)
 MatchHolesToMember(args)
def HoleMatch.MaterialOnMember (   args)
 MaterialOnMember(args)
def HoleMatch.Member (   args)
 Member( index ) returns the member by member number
def HoleMatch.MemberAllocated (   args)
 MemberAllocated() returns the allocated file size.
def HoleMatch.MemberLocate (   args)
 MemberLocate( "Prompt" ) returns the member by location
def HoleMatch.MemberProperties (   args)
 MemberProperties() return a dictionary of member properties.
def HoleMatch.MemberPropertySet (   args)
 MemberPropertySet() sets a specific member property.
def HoleMatch.MemberRequiresProcessing (   arg1)
Returns
Instance of type bool
     C++ signature :
         bool MemberRequiresProcessing(int)
def HoleMatch.MembersSelected (   args)
 MembersSelected() returns a list of member numbers currently selected without prompting.
def HoleMatch.MultiMemberLocate (   args)
 MultiMemberLocate() returns a list of member objects.
def HoleMatch.PointIsNearMember (   arg1,
  arg2,
  arg3 
)
Returns
Instance of type bool
     C++ signature :
         bool PointIsNearMember(Point3D,int,double)
def HoleMatch.ReaddUserBolts (   arg1)
Returns
Instance of type None
     C++ signature :
         void ReaddUserBolts(int)
def HoleMatch.RegisteredClassDescription (   class)
Returns
Instance of type str
     Return the registered description for the specified member class
     Example: 
     from CagedLadder import CagedLadder
     RegisteredClassDescription(CagedLadder)
 
     C++ signature :
         std::string RegisteredClassDescription(boost::python::api::object)
def HoleMatch.RegisterMemberType (   arg1,
  arg2,
  arg3 
)
Returns
Instance of type None
     C++ signature :
         void RegisterMemberType(boost::python::api::object,std::string,Alloy::Pointer::Pointer<Alloy::Commands::Icon>)
 
     Takes a reference to the class being registered, a short description of the member, and an optional icon object (Commands.Icon) to be displayed in the toolbar.
     
     Example:
     class ExampleMember( MemberBase.MemberBase ):
         ...
     RegisterMemberType( ExampleMember, "My Example Member" )
 
     C++ signature :
         void RegisterMemberType(boost::python::api::object,std::string)
Note
Additional signature: RegisterMemberType( (object)arg1, (str)arg2) -> None
def HoleMatch.ReuseAllMaterialByCreator (   arg1,
  arg2 
)
Returns
Instance of type list
     C++ signature :
         boost::python::list ReuseAllMaterialByCreator(int,boost::array<char, 16ul>)
def HoleMatch.ReuseMaterial (   arg1,
  arg2 
)
Returns
Instance of type Uuid
     C++ signature :
         boost::array<char, 16ul> ReuseMaterial(int,boost::array<char, 16ul>)
def HoleMatch.set_field_state (   arg1,
  arg2 
)
Returns
Instance of type None
     C++ signature :
         void set_field_state(std::string,bool)
def HoleMatch.set_widget_state (   arg1,
  arg2 
)
Returns
Instance of type None
     C++ signature :
         void set_widget_state(std::string,bool)
def HoleMatch.SetMaterialXform (   arg1,
  arg2,
  arg3,
  arg4,
  arg5,
  arg6,
  arg7,
  arg8,
  arg9,
  arg10,
  arg11,
  arg12,
  arg13,
  arg14 
)
Returns
Instance of type None
     C++ signature :
         void SetMaterialXform(int,int,double,double,double,double,double,double,double,double,double,double,double,double)
 
 
     C++ signature :
         void SetMaterialXform(int,int,Xform)
Note
Additional signature: SetMaterialXform( (int)arg1, (int)arg2, (Transform3D)arg3) -> None
def HoleMatch.SetMemberBoundingBox (   arg1)
Returns
Instance of type None
     C++ signature :
         void SetMemberBoundingBox(int)
def HoleMatch.SetMemberPiecemark (   arg1,
  arg2 
)
Returns
Instance of type None
     C++ signature :
         void SetMemberPiecemark(int,std::string)
def HoleMatch.SetSystemGeneratedByUuids (   arg1,
  arg2,
  arg3,
  arg4,
  arg5 
)
Returns
Instance of type None
     C++ signature :
         void SetSystemGeneratedByUuids(int,boost::python::list,boost::python::list,boost::python::list,bool)
def HoleMatch.UseLastSavedMemberOnAdd (   arg1,
  arg2 
)
Returns
Instance of type None
     C++ signature :
         void UseLastSavedMemberOnAdd(std::string,bool)