SDS2 Parametric API
 All Classes Namespaces Functions Variables Pages
List of all members
sds2.sub_mtrl.GratingSubMaterialReference Class Reference

No documentation available. More...

Methods defined here:

def __reduce__

Data descriptors defined here:

def bbar_spa
def bbar_thick
def bbar_width
def cbar_spa
def cbar_thick
def cbar_width
def end_cut
def end_thick
def left_btm_op_dim1
def left_btm_op_dim2
def left_btm_op_dim3
def left_btm_op_dim4
def left_btm_op_dim5
def left_btm_op_dim6
def left_btm_op_dim7
def left_btm_op_dim8
def left_btm_op_type
def left_top_op_dim1
def left_top_op_dim2
def left_top_op_dim3
def left_top_op_dim4
def left_top_op_dim5
def left_top_op_dim6
def left_top_op_dim7
def left_top_op_dim8
def left_top_op_type
def length
def num_bars
def right_btm_op_dim1
def right_btm_op_dim2
def right_btm_op_dim3
def right_btm_op_dim4
def right_btm_op_dim5
def right_btm_op_dim6
def right_btm_op_dim7
def right_btm_op_dim8
def right_btm_op_type
def right_top_op_dim1
def right_top_op_dim2
def right_top_op_dim3
def right_top_op_dim4
def right_top_op_dim5
def right_top_op_dim6
def right_top_op_dim7
def right_top_op_dim8
def right_top_op_type
def width

Data and other attributes defined here:

def __init__

Methods inherited from SubMaterialReference:

def BuiltinMaterial

Data descriptors inherited from SubMaterialReference:

def assm_mark
def cnc_dld
def control_file_entry_description
def dim_weight
def do_not_calc_poly_weight
def do_not_scribe
def dtl_quant
def dtl_rev_level
def dummy
def effective_index
def existing
def fitted
def graph_comp_date
def hash
def imp_desc
def info_type
def last_quant
def last_rev_level
def met_desc
def mtrl_idx
def mtrl_type
def needs_detail
def on_sheet
def pcmk_hash
def public_pcmk
def quant
def ref_x
def ref_y
def rev_date
def rev_level
def sec_hash
def srfc_area
def std_mark
def stretched
def sub_mtrl_idx
def usage
def user_description
def weight

Data descriptors inherited from Boost.Python.instance:

def __dict__
def __weakref__

Data and other attributes inherited from Boost.Python.instance:

def __new__

Detailed Description

No documentation available.

Method resolution order

GratingSubMaterialReference
SubMaterialReference
Boost.Python.instance
builtin.object

Constructor & Destructor Documentation

def sds2.sub_mtrl.GratingSubMaterialReference.__init__ (   args)
Raises an exception
This class cannot be instantiated from Python
 __init__ = <built-in function __init__>

Member Function Documentation

def sds2.sub_mtrl.GratingSubMaterialReference.__dict__ (   args)
def sds2.sub_mtrl.GratingSubMaterialReference.__new__ (   args)
T.__new__(S, ...) -> a new object with type S, a subtype of T
 __new__ = <built-in method __new__ of Boost.Python.class object>
def sds2.sub_mtrl.GratingSubMaterialReference.__reduce__ (   args)
 __reduce__ = <unnamed Boost.Python function>(args)
def sds2.sub_mtrl.GratingSubMaterialReference.__weakref__ (   args)
def sds2.sub_mtrl.GratingSubMaterialReference.assm_mark (   args)
def sds2.sub_mtrl.GratingSubMaterialReference.bbar_spa (   args)
def sds2.sub_mtrl.GratingSubMaterialReference.bbar_thick (   args)
def sds2.sub_mtrl.GratingSubMaterialReference.bbar_width (   args)
def sds2.sub_mtrl.GratingSubMaterialReference.BuiltinMaterial (   arg1)
Returns
Instance of type object
     Return a BuiltinMaterial with the same properties as the
     SubMaterialReference except with the color set to the job's
     default color for the material type
 
     C++ signature :
         Alloy::Pointer::Pointer<MaterialBase> BuiltinMaterial(Entry<17>)
 
     Return a BuiltinMaterial with the same properties as the
     SubMaterialReference except with the option to override the color
 
     C++ signature :
         Alloy::Pointer::Pointer<MaterialBase> BuiltinMaterial(Entry<17>,bool)
Note
Additional signature: BuiltinMaterial( (SubMaterialReference)self, (bool)set_default_color) -> object
def sds2.sub_mtrl.GratingSubMaterialReference.cbar_spa (   args)
def sds2.sub_mtrl.GratingSubMaterialReference.cbar_thick (   args)
def sds2.sub_mtrl.GratingSubMaterialReference.cbar_width (   args)
def sds2.sub_mtrl.GratingSubMaterialReference.cnc_dld (   args)
def sds2.sub_mtrl.GratingSubMaterialReference.control_file_entry_description (   args)
def sds2.sub_mtrl.GratingSubMaterialReference.dim_weight (   args)
def sds2.sub_mtrl.GratingSubMaterialReference.do_not_calc_poly_weight (   args)
def sds2.sub_mtrl.GratingSubMaterialReference.do_not_scribe (   args)
def sds2.sub_mtrl.GratingSubMaterialReference.dtl_quant (   args)
def sds2.sub_mtrl.GratingSubMaterialReference.dtl_rev_level (   args)
def sds2.sub_mtrl.GratingSubMaterialReference.dummy (   args)
def sds2.sub_mtrl.GratingSubMaterialReference.effective_index (   args)
def sds2.sub_mtrl.GratingSubMaterialReference.end_cut (   args)
def sds2.sub_mtrl.GratingSubMaterialReference.end_thick (   args)
def sds2.sub_mtrl.GratingSubMaterialReference.existing (   args)
def sds2.sub_mtrl.GratingSubMaterialReference.fitted (   args)
def sds2.sub_mtrl.GratingSubMaterialReference.graph_comp_date (   args)
def sds2.sub_mtrl.GratingSubMaterialReference.hash (   args)
def sds2.sub_mtrl.GratingSubMaterialReference.imp_desc (   args)
def sds2.sub_mtrl.GratingSubMaterialReference.info_type (   args)
def sds2.sub_mtrl.GratingSubMaterialReference.last_quant (   args)
def sds2.sub_mtrl.GratingSubMaterialReference.last_rev_level (   args)
def sds2.sub_mtrl.GratingSubMaterialReference.left_btm_op_dim1 (   args)
def sds2.sub_mtrl.GratingSubMaterialReference.left_btm_op_dim2 (   args)
def sds2.sub_mtrl.GratingSubMaterialReference.left_btm_op_dim3 (   args)
def sds2.sub_mtrl.GratingSubMaterialReference.left_btm_op_dim4 (   args)
def sds2.sub_mtrl.GratingSubMaterialReference.left_btm_op_dim5 (   args)
def sds2.sub_mtrl.GratingSubMaterialReference.left_btm_op_dim6 (   args)
def sds2.sub_mtrl.GratingSubMaterialReference.left_btm_op_dim7 (   args)
def sds2.sub_mtrl.GratingSubMaterialReference.left_btm_op_dim8 (   args)
def sds2.sub_mtrl.GratingSubMaterialReference.left_btm_op_type (   args)
def sds2.sub_mtrl.GratingSubMaterialReference.left_top_op_dim1 (   args)
def sds2.sub_mtrl.GratingSubMaterialReference.left_top_op_dim2 (   args)
def sds2.sub_mtrl.GratingSubMaterialReference.left_top_op_dim3 (   args)
def sds2.sub_mtrl.GratingSubMaterialReference.left_top_op_dim4 (   args)
def sds2.sub_mtrl.GratingSubMaterialReference.left_top_op_dim5 (   args)
def sds2.sub_mtrl.GratingSubMaterialReference.left_top_op_dim6 (   args)
def sds2.sub_mtrl.GratingSubMaterialReference.left_top_op_dim7 (   args)
def sds2.sub_mtrl.GratingSubMaterialReference.left_top_op_dim8 (   args)
def sds2.sub_mtrl.GratingSubMaterialReference.left_top_op_type (   args)
def sds2.sub_mtrl.GratingSubMaterialReference.length (   args)
def sds2.sub_mtrl.GratingSubMaterialReference.met_desc (   args)
def sds2.sub_mtrl.GratingSubMaterialReference.mtrl_idx (   args)
def sds2.sub_mtrl.GratingSubMaterialReference.mtrl_type (   args)
def sds2.sub_mtrl.GratingSubMaterialReference.needs_detail (   args)
def sds2.sub_mtrl.GratingSubMaterialReference.num_bars (   args)
def sds2.sub_mtrl.GratingSubMaterialReference.on_sheet (   args)
def sds2.sub_mtrl.GratingSubMaterialReference.pcmk_hash (   args)
def sds2.sub_mtrl.GratingSubMaterialReference.public_pcmk (   args)
def sds2.sub_mtrl.GratingSubMaterialReference.quant (   args)
def sds2.sub_mtrl.GratingSubMaterialReference.ref_x (   args)
def sds2.sub_mtrl.GratingSubMaterialReference.ref_y (   args)
def sds2.sub_mtrl.GratingSubMaterialReference.rev_date (   args)
def sds2.sub_mtrl.GratingSubMaterialReference.rev_level (   args)
def sds2.sub_mtrl.GratingSubMaterialReference.right_btm_op_dim1 (   args)
def sds2.sub_mtrl.GratingSubMaterialReference.right_btm_op_dim2 (   args)
def sds2.sub_mtrl.GratingSubMaterialReference.right_btm_op_dim3 (   args)
def sds2.sub_mtrl.GratingSubMaterialReference.right_btm_op_dim4 (   args)
def sds2.sub_mtrl.GratingSubMaterialReference.right_btm_op_dim5 (   args)
def sds2.sub_mtrl.GratingSubMaterialReference.right_btm_op_dim6 (   args)
def sds2.sub_mtrl.GratingSubMaterialReference.right_btm_op_dim7 (   args)
def sds2.sub_mtrl.GratingSubMaterialReference.right_btm_op_dim8 (   args)
def sds2.sub_mtrl.GratingSubMaterialReference.right_btm_op_type (   args)
def sds2.sub_mtrl.GratingSubMaterialReference.right_top_op_dim1 (   args)
def sds2.sub_mtrl.GratingSubMaterialReference.right_top_op_dim2 (   args)
def sds2.sub_mtrl.GratingSubMaterialReference.right_top_op_dim3 (   args)
def sds2.sub_mtrl.GratingSubMaterialReference.right_top_op_dim4 (   args)
def sds2.sub_mtrl.GratingSubMaterialReference.right_top_op_dim5 (   args)
def sds2.sub_mtrl.GratingSubMaterialReference.right_top_op_dim6 (   args)
def sds2.sub_mtrl.GratingSubMaterialReference.right_top_op_dim7 (   args)
def sds2.sub_mtrl.GratingSubMaterialReference.right_top_op_dim8 (   args)
def sds2.sub_mtrl.GratingSubMaterialReference.right_top_op_type (   args)
def sds2.sub_mtrl.GratingSubMaterialReference.sec_hash (   args)
def sds2.sub_mtrl.GratingSubMaterialReference.srfc_area (   args)
def sds2.sub_mtrl.GratingSubMaterialReference.std_mark (   args)
def sds2.sub_mtrl.GratingSubMaterialReference.stretched (   args)
def sds2.sub_mtrl.GratingSubMaterialReference.sub_mtrl_idx (   args)
def sds2.sub_mtrl.GratingSubMaterialReference.usage (   args)
def sds2.sub_mtrl.GratingSubMaterialReference.user_description (   args)
def sds2.sub_mtrl.GratingSubMaterialReference.weight (   args)
def sds2.sub_mtrl.GratingSubMaterialReference.width (   args)