lazy.all | No documentation available |
 lazy.any | No documentation available |
 dialog.assembly_quote.assembly_quote | Wrap certain API calls with this in order to facilitate SDS/2 Assembly dialog editor knowing which parts of each function call it needs to wrap in quotes in order to get the expression and not the result of the expression |
 dialog.rules.assign | This is like expr but you give an extra argument (at the beginning) to assign the result of the expression to |
 dialog.rules.AssignException | No documentation available |
 Commands.AvailableTools | No documentation available |
 CMU.AxisParallelPlane | No documentation available |
 Drawing.BillLine | No documentation available |
 u3de.Block | No documentation available |
 Designable.Existing.Bolt | No documentation available |
 Events.BoltEvent | No documentation available |
 Designable.Existing.BoltGroup | No documentation available |
 Kiss.BoltQuantityType | No documentation available |
 sds2.sub_mtrl.BoltSubMaterialReference | No documentation available |
 Drawing.BOM | No documentation available |
 sds2.status_display.BooleanOperation | No documentation available |
 dialog.builder.Builder | This is an abstract class |
  dialog.dialog.Dialog | No documentation available |
  dialog.field.Field | |
   dialog.checkbox.Checkbox | Provides a field with one checkbox which is either true or false |
   dialog.checkbox.CheckButtons | This is a compatibility class for old dialogs |
   dialog.combo_choose.ChooseColor | A widget that allows users to pick from a collection of named colors or choose a custom color using the Tkinter color dialog |
   dialog.combobox.BareCombobox | A bare combobox field |
    dialog.lockablefield.DeletableCombobox | No documentation available |
   dialog.entry.BareEntry | A bare entry field |
    dialog.lockablefield.DeletableEntry | No documentation available |
   dialog.hidden.Hidden | This is a field which is not visible within the gui, it has no attached Tkinter widgets |
   dialog.listbox.ContentListbox | This listbox displays values in mixed mode |
   dialog.listbox.Listbox | No documentation available |
   dialog.lockablefield.LockableCheckbox | Provides a field with a lockable button (essentially a checkbox) which is either true or false |
   dialog.radio.Radio | No documentation available |
   dialog.table.TableColumn | Add columns to your table |
   dialog.text.Text | This is a multi line text area |
   Layout3DEditor.Layout3DEditor | No documentation available |
  dialog.frame.Frame | A generic visual holder a la Tkinter.Frame |
   dialog.frame.Column | A frame that fills top to bottom and is intended to be placed like columns on a page |
   dialog.frame.LoadableFrame | This makes a Frame (a la Frame) that has copy, paste, save, and load buttons on it |
  dialog.page.Page | No documentation available |
  dialog.pmdialog.PMDialog | |
  dialog.scrollbar.ScrollableFrame | No documentation available |
  dialog.subdialog.Subdialog | No documentation available |
  dialog.tabset.Tab | No documentation available |
 dialog.builder.BuildException | No documentation available |
 Locator.Button | No documentation available |
 u3de.CachedSerialization | No documentation available |
  u3de.ClodMeshBaseContinuation | No documentation available |
  u3de.ClodMeshDeclaration | No documentation available |
  u3de.LightResource | No documentation available |
  u3de.LitTextureShader | No documentation available |
  u3de.Material | No documentation available |
  u3de.MetaData | No documentation available |
  u3de.ViewResource | No documentation available |
 Gadget.CallbackBanner | A python constructible GadgetBanner |
 Gadget.CallbackColumn | A python-constructible GadgetColumn |
 Gadget.CallbackLeaf | Python-constructible GadgetLeaf objects |
 Tkinter.CallWrapper | Internal class |
 StandAloneGadgetScreen.CancelException | No documentation available |
 u3de.Canned | No documentation available |
 dialog.combo_choose.ChooseColorKind | A 3-tuple of ints between 0 and 256 representing a single color |
 sds2.sub_mtrl.ClevisPinSubMaterialReference | No documentation available |
 sds2.sub_mtrl.ClevisSubMaterialReference | No documentation available |
 u3de.Clod | No documentation available |
 Commands.CmdArgs | No documentation available |
 CMU.CMUTemplate | No documentation available |
 sds2.color.Color | No documentation available |
 dialog.combobox.ComboboxError | No documentation available |
 dialog.attributecontrollers.ComboboxTransformer | This can be used with Attribute*Controllers rather than using
Combobox*Controllers.
|
 Commands.CommandType | No documentation available |
 sds2.status_display.ComparisonOperator | No documentation available |
 Component.Component | Components provide a way to extend the functionality of members using the Parametric API in a dynamic way that can't be recreated with a normal parametric |
  Designable.ProcessableComponent.ProcessableComponent | No documentation available |
   Designable.ProcessableComponent.EndComponent | No documentation available |
  HashingComponent.HashingComponent | A primer class that has a decorator for hashing the object during the edit method |
  UnreadableComponentProxy.UnreadableComponentProxy | No documentation available |
 ComponentState.ComponentState | This is a helper to make Component.GetState easy to implement |
 componentedit.ComponentUIHelper | A mixin class to help simple components adapt to member edit conventions |
  SortedComponentUIHelper.SortedComponentUIHelper | A mixin class to help simple components adapt to member edit conventions |
  UnreadableComponentProxy.MemberEditUI | No documentation available |
 Output.CompressionType | No documentation available |
 sds2.status_display.Condition | No documentation available |
  sds2.status_display.ConditionApprovalStatus | No documentation available |
  sds2.status_display.ConditionBoltCustomProperty | No documentation available |
  sds2.status_display.ConditionBoolean | No documentation available |
   sds2.status_display.ConditionAssignedMemberCritical | No documentation available |
   sds2.status_display.ConditionAssignedMemberLiftability | No documentation available |
   sds2.status_display.ConditionBeamWebDoublers | No documentation available |
   sds2.status_display.ConditionBoltDiameterChangedBySystem | No documentation available |
   sds2.status_display.ConditionBraceWithDifferentThickGussets | No documentation available |
   sds2.status_display.ConditionComposite | No documentation available |
   sds2.status_display.ConditionConnAutoStandard | No documentation available |
   sds2.status_display.ConditionConnBelowMin | No documentation available |
   sds2.status_display.ConditionConnBentPlate | No documentation available |
   sds2.status_display.ConditionConnBoltedPlate | No documentation available |
   sds2.status_display.ConditionConnChangedBySystem | No documentation available |
   sds2.status_display.ConditionConnClipAngle | No documentation available |
   sds2.status_display.ConditionConnColumnPlate | No documentation available |
   sds2.status_display.ConditionConnEndPlate | No documentation available |
   sds2.status_display.ConditionConnHorizontalBrace | No documentation available |
   sds2.status_display.ConditionConnPlainEnd | No documentation available |
   sds2.status_display.ConditionConnSeated | No documentation available |
   sds2.status_display.ConditionConnShear | No documentation available |
   sds2.status_display.ConditionConnSplice | No documentation available |
   sds2.status_display.ConditionConnUserDefined | No documentation available |
   sds2.status_display.ConditionConnVerticalBrace | No documentation available |
   sds2.status_display.ConditionEadFailedDesign | No documentation available |
   sds2.status_display.ConditionEadUnconnected | No documentation available |
   sds2.status_display.ConditionExistingMember | No documentation available |
   sds2.status_display.ConditionFabScheduleMet | No documentation available |
   sds2.status_display.ConditionFailedConn | No documentation available |
   sds2.status_display.ConditionFramesToModelComplete | No documentation available |
   sds2.status_display.ConditionFrozenDetail | No documentation available |
   sds2.status_display.ConditionFrozenPiecemark | No documentation available |
   sds2.status_display.ConditionGraphicalConn | No documentation available |
   sds2.status_display.ConditionGraphicAlteredMaterial | No documentation available |
   sds2.status_display.ConditionGraphicAlteredMember | No documentation available |
   sds2.status_display.ConditionHoldStatus | No documentation available |
   sds2.status_display.ConditionIndeterminateEnds | No documentation available |
   sds2.status_display.ConditionLoadsBeamMomentAuto | No documentation available |
   sds2.status_display.ConditionLoadsBeamShearAuto | No documentation available |
   sds2.status_display.ConditionLoadsColumnHorizontalShearAuto | No documentation available |
   sds2.status_display.ConditionLoadsColumnLoadAuto | No documentation available |
   sds2.status_display.ConditionLoadsColumnMomentAuto | No documentation available |
   sds2.status_display.ConditionLoadsColumnSpliceUpliftAuto | No documentation available |
   sds2.status_display.ConditionLoadsHorizontalBraceCompressionAuto | No documentation available |
   sds2.status_display.ConditionLoadsHorizontalBraceTensionAuto | No documentation available |
   sds2.status_display.ConditionLoadsVerticalBraceCompressionAuto | No documentation available |
   sds2.status_display.ConditionLoadsVerticalBraceTensionAuto | No documentation available |
   sds2.status_display.ConditionMaterialBent | No documentation available |
   sds2.status_display.ConditionMaterialFit | No documentation available |
   sds2.status_display.ConditionMaterialIsLLV | No documentation available |
   sds2.status_display.ConditionMaterialIsToeIn | No documentation available |
   sds2.status_display.ConditionMaterialNotes | No documentation available |
   sds2.status_display.ConditionMaterialStretched | No documentation available |
   sds2.status_display.ConditionMemberAnalyzed | No documentation available |
   sds2.status_display.ConditionMemberCamber | No documentation available |
   sds2.status_display.ConditionMemberCNCDownloaded | No documentation available |
   sds2.status_display.ConditionMemberEndLocked | No documentation available |
   sds2.status_display.ConditionMemberGalvanized | No documentation available |
   sds2.status_display.ConditionMemberHasFieldWeld | No documentation available |
   sds2.status_display.ConditionMemberHasInputSetback | No documentation available |
   sds2.status_display.ConditionMemberIsHSSLongSideVertical | No documentation available |
   sds2.status_display.ConditionMemberNotes | No documentation available |
   sds2.status_display.ConditionNeedsDetail | No documentation available |
   sds2.status_display.ConditionNeedsPiecemark | No documentation available |
   sds2.status_display.ConditionNeedsProcess | No documentation available |
   sds2.status_display.ConditionNeedsSolids | No documentation available |
   sds2.status_display.ConditionNonAISC_SingleShearPlateConn | No documentation available |
   sds2.status_display.ConditionNonGraphicalMainMaterialWithUserHoles | No documentation available |
   sds2.status_display.ConditionNonSquareCutEnds | No documentation available |
   sds2.status_display.ConditionOnSheet | No documentation available |
   sds2.status_display.ConditionPlotted | No documentation available |
   sds2.status_display.ConditionShearLoadBelowMin | No documentation available |
   sds2.status_display.ConditionShipScheduleMet | No documentation available |
   sds2.status_display.ConditionUserAssignedPiecemark | No documentation available |
   sds2.status_display.ConditionUserCreatedMaterial | No documentation available |
   sds2.status_display.ConditionUserDesignedConn | No documentation available |
   sds2.status_display.ConditionUserLockedConn | No documentation available |
  sds2.status_display.ConditionDimRange | No documentation available |
   sds2.status_display.ConditionBoltDiameter | No documentation available |
   sds2.status_display.ConditionMtrlPlateThickness | No documentation available |
  sds2.status_display.ConditionInt | No documentation available |
   sds2.status_display.ConditionConnSpecificUserDefined | No documentation available |
   sds2.status_display.ConditionMaterialRoute1 | No documentation available |
   sds2.status_display.ConditionMaterialRoute2 | No documentation available |
   sds2.status_display.ConditionMaterialRoute3 | No documentation available |
   sds2.status_display.ConditionMaterialRoute4 | No documentation available |
   sds2.status_display.ConditionMemberCategory | No documentation available |
   sds2.status_display.ConditionMemberLiftAssignment | No documentation available |
   sds2.status_display.ConditionMemberRoute1 | No documentation available |
   sds2.status_display.ConditionMemberRoute2 | No documentation available |
   sds2.status_display.ConditionMemberRoute3 | No documentation available |
   sds2.status_display.ConditionMemberRoute4 | No documentation available |
  sds2.status_display.ConditionIntRange | No documentation available |
   sds2.status_display.ConditionDateRange | No documentation available |
    sds2.status_display.ConditionAtJobSite | No documentation available |
    sds2.status_display.ConditionDetailComplete | No documentation available |
    sds2.status_display.ConditionErected | No documentation available |
    sds2.status_display.ConditionFabApproved | No documentation available |
    sds2.status_display.ConditionFabCompleted | No documentation available |
    sds2.status_display.ConditionFabProjected | No documentation available |
    sds2.status_display.ConditionFabReleased | No documentation available |
    sds2.status_display.ConditionMaterialDetailComplete | No documentation available |
    sds2.status_display.ConditionModelComplete | No documentation available |
    sds2.status_display.ConditionReceivedFromApproval | No documentation available |
    sds2.status_display.ConditionShipActual | No documentation available |
    sds2.status_display.ConditionShipProjected | No documentation available |
    sds2.status_display.ConditionSubmittedForApproval | No documentation available |
   sds2.status_display.ConditionEadGroup | No documentation available |
   sds2.status_display.ConditionRevision | No documentation available |
   sds2.status_display.ConditionSequence | No documentation available |
   sds2.status_display.ConditionZone | No documentation available |
  sds2.status_display.ConditionMaterialCustomProperty | No documentation available |
  sds2.status_display.ConditionMaterialFinish | No documentation available |
  sds2.status_display.ConditionMemberCustomProperty | No documentation available |
  sds2.status_display.ConditionMemberType | No documentation available |
  sds2.status_display.ConditionString | No documentation available |
   sds2.status_display.ConditionBoltMaterial | No documentation available |
   sds2.status_display.ConditionBoltType | No documentation available |
   sds2.status_display.ConditionCustomMemberType | No documentation available |
   sds2.status_display.ConditionMaterialDescription | No documentation available |
   sds2.status_display.ConditionMaterialSteelGrade | No documentation available |
   sds2.status_display.ConditionMaterialUsageDescription | No documentation available |
   sds2.status_display.ConditionMemberDescription | No documentation available |
   sds2.status_display.ConditionMemberSteelGrade | No documentation available |
   sds2.status_display.ConditionPiecemark | No documentation available |
   sds2.status_display.ConditionReasonForHold | No documentation available |
   sds2.status_display.ConditionSectionSize | No documentation available |
    sds2.status_display.ConditionMaterialSectionSize | No documentation available |
    sds2.status_display.ConditionMemberSectionSize | No documentation available |
 sds2.lockable.ConnectionLocks | Interface to connection design locks on a connection component on a member's end |
 cons_tests.ConsTestCases | No documentation available |
 dialog.controller.Controller | No documentation available |
  dialog.controller.DictController | This controller is like PropertyController but it works with dictionaries instead of object properties |
  dialog.controller.PropertyController | This is the default controller for dialogs |
  dialog.table.RowManagerController | This is an internal class |
 material_copy_tool.CopyDialogParameters | No documentation available |
 u3de.Corner | No documentation available |
 cod.CreationOrderedDict | No documentation available |
 Kiss.DataSource | No documentation available |
 dialog.date.Date | No documentation available |
 sds2.sub_mtrl.DeckSubMaterialReference | No documentation available |
 Output.Destination | No documentation available |
 Output.DestinationType | No documentation available |
 diagram.DiagramBuilder.DiagramBuilder | This class is a wrapper for Tkinter.Canvas that provides a few additional features: |
 diagram.DiagramBuilder.DiagramItem | Abstract parent class for items added to a diagram |
  diagram.DiagramBuilder.ArcItem | A diagram item that adds an arc to the canvas |
  diagram.DiagramBuilder.CompositeItem | An abstract diagram item that is composed of multiple other diagram items |
   diagram.DiagramBuilder.DimensionItem | A diagram item that adds a dimension to the canvas |
   diagram.DiagramBuilder.LabeledArrowItem | A diagram item that adds a labeled arrow to the canvas |
  diagram.DiagramBuilder.LineItem | A diagram item that adds a line to the canvas |
  diagram.DiagramBuilder.OvalItem | A diagram item that adds an oval to the canvas |
  diagram.DiagramBuilder.PolygonItem | A diagram item that adds a polygon to the canvas |
   diagram.DiagramBuilder.Layout3DPolygonItem | A diagram item that adds a polygon to the canvas in the shape of a projection on a Layout3D |
  diagram.DiagramBuilder.RectangleItem | A diagram item that adds a rectangle to the canvas |
  diagram.DiagramBuilder.TextItem | A diagram item that adds text to the canvas |
 dialog.displaymodel.DisplayModel | No documentation available |
 dialog.displaymodel.DisplayModelException | No documentation available |
 dialog.displaymodel.DisplayModelList | This should always be constructed by the dialog |
 dialog.table.DisplayRowManagerException | No documentation available |
 dialog.displaymodel.DisplayStorage | This is one implementation of storage for one field name |
 gadget_protocol.DoNotPickle | No documentation available |
  gadget_protocol.ReadOnlyHandler | No documentation available |
 Drawing.Drawing | No documentation available |
 Drawing.DrawingReference | No documentation available |
 Layout3DEditor.DrawObj | No documentation available |
 StateAccessor.DummyBase | No documentation available |
 EmbedPlateModule.EmbedPlateDefinition | A single entry from the Embed Plate Schedule |
 member_edit.End | No documentation available |
 Output.EndLineType | No documentation available |
 model.Enum | No documentation available |
 fab.error | No documentation available |
 flat_bar.error | No documentation available |
 grate_trd.error | No documentation available |
 grate.error | No documentation available |
 hole_add.error | No documentation available |
 job.error | No documentation available |
 shape.error | No documentation available |
 shr_stud.error | No documentation available |
 sqr_bar.error | No documentation available |
 member.error | No documentation available |
 turnbuckle.error | No documentation available |
 model.error | No documentation available |
 version.error | No documentation available |
 mtrl_cut.error | No documentation available |
 view.error | No documentation available |
 mtrl_list.error | No documentation available |
 weld_add.error | No documentation available |
 mtrl_fit.error | No documentation available |
 param.error | No documentation available |
 plate_layout.error | No documentation available |
 point.error | No documentation available |
 rect_plate.error | No documentation available |
 rnd_bar.error | No documentation available |
 rnd_plate.error | No documentation available |
 roll_plate.error | No documentation available |
 rolled_section.error | No documentation available |
 rotation.error | No documentation available |
 cons_circle.error | No documentation available |
 cons_line.error | No documentation available |
 deck.error | No documentation available |
 clevis.error | No documentation available |
 assembly.error | No documentation available |
 bnt_plate.error | No documentation available |
 bolt_add.error | No documentation available |
 Tkinter.Event | Container for the properties of an event |
 u3de.Face | No documentation available |
 Feedback.Feedback | No documentation available |
 dialog.filefacade.filefacade | This is for internal use |
 filewrapper.filewrapper | No documentation available |
 Gadget.GadgetBanner | An object that may be returned by some SDS/2 core APIs |
 Gadget.GadgetColumnAn | No documentation available |
 gadget_protocol.GadgetFactory | Instances of this class are passed to the callback functions that populate frames (Subdialogs) with the plugin specific information |
 Gadget.GadgetLeaf | An object that may be returned by some SDS2/2 core APIs |
 gadget_protocol_member.GadgetMember | Mix-in class for where derived class is expected to implement CreateCustomMultiEditableUI and optionally define StandAloneEditWindowID, UserStr, OnStandAloneEditHelp, and StandAloneComponentFilter |
 Gadget.GadgetScreen | GadgetScreen(screen_name, title, place_mode) |
  componentedit.StandaloneComponentEditView | No documentation available |
 CNC.GenerateFileForType | No documentation available |
 sds2.sub_mtrl.GenMaterialSubMaterialReference | No documentation available |
  sds2.sub_mtrl.AngleSubMaterialReference | No documentation available |
  sds2.sub_mtrl.BeadedFlatSteelSubMaterialReference | No documentation available |
  sds2.sub_mtrl.BentPlateLayoutSubMaterialReference | No documentation available |
  sds2.sub_mtrl.BentPlateSubMaterialReference | No documentation available |
  sds2.sub_mtrl.ChannelSubMaterialReference | No documentation available |
  sds2.sub_mtrl.CheckedPlateSubMaterialReference | No documentation available |
  sds2.sub_mtrl.ColdFormedChannelSubMaterialReference | No documentation available |
  sds2.sub_mtrl.ColdFormedZSubMaterialReference | No documentation available |
  sds2.sub_mtrl.ConcreteCurvedLayoutSubMaterialReference | No documentation available |
  sds2.sub_mtrl.ConcreteFlatLayoutSubMaterialReference | No documentation available |
  sds2.sub_mtrl.CraneRailSubMaterialReference | No documentation available |
  sds2.sub_mtrl.ExpandedMetalPlateSubMaterialReference | No documentation available |
  sds2.sub_mtrl.ExpPlateTreadSubMaterialReference | No documentation available |
  sds2.sub_mtrl.FlatBarSubMaterialReference | No documentation available |
  sds2.sub_mtrl.FlatPlateLayoutSubMaterialReference | No documentation available |
  sds2.sub_mtrl.JoistSubMaterialReference | No documentation available |
  sds2.sub_mtrl.PipeSubMaterialReference | No documentation available |
  sds2.sub_mtrl.PlateBoxSectionSubMaterialReference | No documentation available |
  sds2.sub_mtrl.PlateGirderSubMaterialReference | No documentation available |
  sds2.sub_mtrl.PlateSubMaterialReference | No documentation available |
  sds2.sub_mtrl.RolledPlateSubMaterialReference | No documentation available |
  sds2.sub_mtrl.RoundBarSubMaterialReference | No documentation available |
  sds2.sub_mtrl.RoundPlateSubMaterialReference | No documentation available |
  sds2.sub_mtrl.S_SectionSubMaterialReference | No documentation available |
  sds2.sub_mtrl.SquareBarSubMaterialReference | No documentation available |
  sds2.sub_mtrl.StandardPartSubMaterialReference | No documentation available |
  sds2.sub_mtrl.SteeSubMaterialReference | No documentation available |
  sds2.sub_mtrl.TubeSubMaterialReference | No documentation available |
  sds2.sub_mtrl.TurnedShellSubMaterialReference | No documentation available |
  sds2.sub_mtrl.TurnedSolidSubMaterialReference | No documentation available |
  sds2.sub_mtrl.WideFlangeSubMaterialReference | No documentation available |
  sds2.sub_mtrl.WteeSubMaterialReference | No documentation available |
 StandardDetail.GlobalStandard | No documentation available |
 sds2.sub_mtrl.GratingSubMaterialReference | No documentation available |
 sds2.sub_mtrl.GratingTreadSubMaterialReference | No documentation available |
 Tkinter.Grid | Geometry manager Grid |
  Tkinter.Widget | Internal class |
   dialog.combobox.TkCombobox | This is an internal class to expose our SDS/2's combobox to Python |
   dialog.scrollbar.TkScrollableFrame | No documentation available |
   dialog.scrollbar.TkScrolledWindow | No documentation available |
   dialog.table.TkTable | Internal class |
   dialog.tabset.TkTab | No documentation available |
   dialog.tabset.TkTabset | No documentation available |
   Tkinter.Button | Button widget |
    componentedit.GadgetCopyButton | No documentation available |
    componentedit.GadgetLoadButton | No documentation available |
    componentedit.GadgetPasteButton | No documentation available |
    componentedit.GadgetSaveButton | No documentation available |
    dialog.frame.CopyButton | No documentation available |
    dialog.frame.LoadButton | No documentation available |
    dialog.frame.PasteButton | No documentation available |
    dialog.frame.SaveButton | No documentation available |
    Tkinter.Studbutton | No documentation available |
    Tkinter.Tributton | No documentation available |
   Tkinter.Canvas | Canvas widget to display graphical elements like lines or text |
    dialog.combo_choose.CanvasButton | A canvas that will act as a button |
    Layout3DEditor.CanvasObj | No documentation available |
   Tkinter.Checkbutton | Checkbutton widget which is either in on- or off-state |
   Tkinter.Entry | Entry widget which allows to display simple text |
   Tkinter.Frame | Frame widget which may contain other widgets and can have a 3D border |
    Layout3DEditor.TableObj | No documentation available |
   Tkinter.Label | Label widget which can display text and bitmaps |
   Tkinter.LabelFrame | Labelframe widget |
   Tkinter.Listbox | Listbox widget which can display a list of strings |
   Tkinter.Menu | Menu widget which allows to display menu bars, pull-down menus and pop-up menus |
   Tkinter.Menubutton | Menubutton widget, obsolete since Tk8.0 |
    Tkinter.OptionMenu | OptionMenu which allows the user to select a value from a menu |
   Tkinter.Message | Message widget to display multiline text |
   Tkinter.PanedWindow | Panedwindow widget |
   Tkinter.Radiobutton | Radiobutton widget which shows only one of several buttons in on-state |
   Tkinter.Scale | Scale widget which can display a numerical scale |
   Tkinter.Scrollbar | Scrollbar widget which displays a slider at a certain position |
   Tkinter.Spinbox | Spinbox widget |
   Tkinter.Text | Text widget which can display text in various forms |
 dialog.widget.GridException | No documentation available |
 Layout3DEditor.GripObj | No documentation available |
 GroupMember.Group | No documentation available |
 Commands.GroupNode | No documentation available |
  Commands.Command | No documentation available |
   component_tools.ComponentAddCommand | No documentation available |
   PluginSetupTools.PluginSetupCommand | No documentation available |
  Commands.Group | No documentation available |
  Commands.WidgetCommand | No documentation available |
 dismissal_guard.Guarded | No documentation available |
 Hash.Hash | No documentation available |
 Designable.Existing.Hole | No documentation available |
 EmbedPlateModule.HoleAttachment | Data representing a single hole attachment to an embed plate |
  EmbedPlateModule.StudAttachment | Data representing a single stud attachment to an embed plate |
 EmbedPlateModule.HoleAttachmentList | List of hole attachments to embed plates |
 Designable.Existing.HoleGroup | No documentation available |
 Commands.Icon | No documentation available |
 Commands.IconSet | No documentation available |
 MainMaterial.id | No documentation available |
 Tkinter.Image | Base class for images |
  Tkinter.BitmapImage | Widget which can display a bitmap |
  Tkinter.PhotoImage | Widget which can display colored images in GIF, PPM/PGM format |
 IncorrectMemberTypeException.IncorrectMemberTypeException | No documentation available |
 gadget_protocol.InStandAloneEdit | No documentation available |
 dialog.item.Item | |
  dialog.button.Button | No documentation available |
  dialog.field.Field | |
  dialog.image.Image | No documentation available |
  dialog.label.Label | No documentation available |
  dialog.labeledfield.Labeled | This class handles using fixed width fonts to keep a column of entries lined up |
   dialog.combo_choose.ChooseColor | A widget that allows users to pick from a collection of named colors or choose a custom color using the Tkinter color dialog |
   dialog.combobox.Combobox | Formerly known as menu, this is a drop down box |
    MaterialBaseWidgets.MaterialFinishCombobox | No documentation available |
    MaterialBaseWidgets.MaterialGradeCombobox | No documentation available |
   dialog.entry.Entry | No documentation available |
    dialog.choose_file.Choose | Base class for entry paired with a button that launches an interactive dialog |
     dialog.choose_file.ChooseDirectory | A field which allows a user to pick a directory in the filesystem |
     dialog.choose_file.ChooseFile | A field which allows a user to pick a file in the filesystem |
     dialog.choose_file.ChooseMtrl | A field that allows a user to pick a section size from the list of available section sizes |
    dialog.date.DateEntry | An entry field formatted for entering dates |
    dialog.dimension.DimensionEntry | An entry field formatted for entering dimensions |
    dialog.entry.FloatEntry | An entry field formatted for entering floating point numbers |
    dialog.entry.IntEntry | An entry field formatted for entering integer numbers |
    dialog.entry.MaterialPiecemarkEntry | An entry field with rules added for material piecemarks |
    dialog.entry.ReadOnlyEntry | This entry field acts like the entry.label from 7.1 |
    dialog.entry.StrEntry | An entry field formatted for entering free format strings |
    gadget_protocol_member.ChooseSequence | A field which allows a user to pick a job sequence |
   dialog.lockablefield.LockableCombobox | No documentation available |
   dialog.lockablefield.LockableEntry | No documentation available |
   dialog.radio.Radio | No documentation available |
   gadget_protocol_member.Rotation0_90 | This entry mimics the 0/90 rotation fields |
  dialog.modelroot.ModelRoot | A ModelRoot is an item in the dialog which can have .model assigned to it and will use that list of models, with a controller, to load and save from the dialog items under it |
   dialog.dialog.DialogBase | No documentation available |
    dialog.dialog.Dialog | No documentation available |
    dialog.dialog.Wizard | This is a special kind of dialog |
    dialog.pmdialog.PMDialog | |
   dialog.frame.Frame | A generic visual holder a la Tkinter.Frame |
   dialog.page.Page | No documentation available |
   dialog.subdialog.Subdialog | No documentation available |
   dialog.table.RowManager | No documentation available |
   dialog.tabset.Tab | No documentation available |
  dialog.scrollbar.ScrollableFrame | No documentation available |
  dialog.scrollbar.ScrollableFrame_Impl | Implementation detail of ScrollableFrame |
  dialog.scrollbar.Scrollbar | This is really a scrolled window |
  dialog.table.Table | A table is a tk table widget on screen |
  dialog.tabset.Tabset | No documentation available |
 dialog.controller.ItemController | Override this abstract class's get/set methods to have a per field controller |
  dialog.attributecontrollers.AttributeController | No documentation available |
  dialog.attributecontrollers.AttributeIndexController | No documentation available |
  dialog.attributecontrollers.AttributeListController | No documentation available |
  dialog.attributecontrollers.EndElevationController | No documentation available |
  dialog.attributecontrollers.ObjectController | No documentation available |
  dialog.attributecontrollers.ObjectIndexController | No documentation available |
  dialog.attributecontrollers.ObjectListController | No documentation available |
  gadget_protocol_member.MemberAttrController | Entry's using this ItemController will coalesce all member.Member changes under one Update call for each member being edited |
  gadget_protocol_member.MemberDateController | Member.Member date attributes have a different string value than what user's expect to see |
 job.JobSetupLock | Opaque class representing the lock status of job options |
 StandardDetail.JobStandard | No documentation available |
 dialog.field.KindException | No documentation available |
 dialog.kind.KindException | No documentation available |
 Designable.Proxies.Layout3D | No documentation available |
 Layout3D.Layout3D | No documentation available |
 Layout3D.Layout3DNode | No documentation available |
 Layout3DEditor.Layout3DWrapper | No documentation available |
 componentedit.LeafMaker | No documentation available |
 LegacyGraphical.LegacyGraphical | The default behavior for custom members changed after 7.3 |
 Commands.Licensing | No documentation available |
 u3de.LightNode | No documentation available |
 dialog.listindex.LIndexBase | No documentation available |
 Line3D.Line3D | No documentation available |
 LinearRange.LinearRange | Represents a range on a continuous one-dimensional number line which can be split up into mutiple smaller ranges by cutting the original range |
 concrete.LineSegment.LineSegment | Class to represent a line segment |
 Commands.Listing | No documentation available |
 MaterialBase.LocateResult | No documentation available |
 Locator.Locator3D | No documentation available |
 sds2.lockable.LockableValue | A picklable class that simulates the behavior of connection design locks visible on the member edit screen |
 u3d_export.Maker | No documentation available |
 Designable.Existing.Material | No documentation available |
 MaterialBase.MaterialBase | No documentation available |
  DummyMaterial.DummyMaterial | No documentation available |
  MaterialBase.BuiltinMaterial | No documentation available |
  Rebar.ShapedRebarMaterial | No documentation available |
 MaterialBase.MaterialBaseException | No documentation available |
 boltmtrl.MaterialBolt | No documentation available |
 Designable.Existing.MaterialByIDOrUse | No documentation available |
 Designable.Processable.MaterialCreationPhases | Class that exists soley to define enumerated values for the material creation phases of process without polluting the the module namespace |
 Events.MaterialEvent | No documentation available |
 materialfile.MaterialFile | No documentation available |
 MaterialBase.MaterialHandle | No documentation available |
 Designable.Existing.Member | No documentation available |
 MemberBase.MemberBase | No documentation available |
  Designable.ProcessableMember.ProcessableMember | A base class for processable custom members |
  DummyMember.DummyMember | No documentation available |
  MemberBase.BuiltinMember | No documentation available |
  ReferenceModel.ReferenceModel | No documentation available |
 member_edit.MemberEditController | No documentation available |
 componentedit.MemberEditMethods | A mixin class that manages a ComponentUIHelper object, and delegates the functions required by the member edit screen to that object |
  ComponentSetupScreen.ComponentSetupScreen | No documentation available |
  HashingComponent.HashingComponent | A primer class that has a decorator for hashing the object during the edit method |
  StandAloneGadgetScreen.StandAloneGadgetScreen | A class to manage a Gadget screen object for selection edit |
  UnreadableComponentProxy.UnreadableComponentProxy | No documentation available |
 gadget_protocol.MemberEditMultiCreateUI | No documentation available |
 member_edit.MemberEditScreen | No documentation available |
 Events.MemberEvent | No documentation available |
 view.MemberProjectionViewUse | No documentation available |
 job.MemberRevisionTuple | MemberRevisionTuple(short_description, long_description) |
 view.MemberViewTuple | MemberViewTuple(global_to_view, max_clip_in_view_coords, min_clip_in_view_coords, type, cut_from, cut_from_type, scale, offset, use, projection_use, is_user, excludes_clip_region, is_projection_view, is_forced) |
 view.MemberViewType | No documentation available |
 view.MemberViewUse | No documentation available |
 default_ComponentState.MemoryStream | No documentation available |
 dialog.item.MenuFacade | This object looks like a Tkinter.Menu in that you can add the same sorts of items to it |
 Tkinter.Misc | Internal class |
  Tkinter.BaseWidget | Internal class |
   Tkinter.Toplevel | Toplevel widget, e.g |
   Tkinter.Widget | Internal class |
  Tkinter.Tk | Toplevel widget of Tk which represents mostly the main window of an application |
 u3de.Model | No documentation available |
 dialog.subdialog_test.Model | No documentation available |
 gadget_protocol.MultiEditable | Mix-in class where a derived class is expected to implement CreateCustomMultiEditableUI to customize a GadgetScreen |
  gadget_protocol.GadgetComponent | Mix-in class for where derived class is expected to implement CreateCustomMultiEditableUI and optionally define StandAloneEditWindowID, and OnStandAloneEditHelp |
  gadget_protocol.GadgetMaterial | Mix-in class for where derived class is expected to implement CreateCustomMultiEditableUI and optionally define StandAloneEditWindowID, and OnStandAloneEditHelp |
  gadget_protocol.GadgetSetup | No documentation available |
 u3de.NewPriority | No documentation available |
 u3de.Node | No documentation available |
 lazy.none | No documentation available |
 PluginSetupTools.NoSetup | No documentation available |
 component_tools.NotAllowedOnAnyMember | No documentation available |
 sds2.sub_mtrl.NutSubMaterialReference | No documentation available |
 Feedback.OneMomentPlease | No documentation available |
 Commands.OperationClass | No documentation available |
 Tkinter.Pack | Geometry manager Pack |
  Tkinter.Widget | Internal class |
 param.ParametricIndexRange | Range of used parametric indices |
 param.ParametricReference | No documentation available |
 dialog.kind.ParseException | No documentation available |
 PartLibrary.Part | No documentation available |
 default_ComponentState.pickle_ComponentState | This just simply uses the hash of individual items in the object |
 sds2.piecemark.PiecemarkIndexRange | Range of used piecemark indices |
 sds2.piecemark.PiecemarkReference | No documentation available |
 Tkinter.Place | Geometry manager Place |
  Tkinter.Widget | Internal class |
 Gadget.PlaceMode | No documentation available |
 Plane3D.Plane3D | No documentation available |
 registry.plugin_finder | Internal class |
 model.point3 | No documentation available |
 Point3D.Point3D | No documentation available |
 model.PolygonFaceType | No documentation available |
 sds2.status_display.Priority | No documentation available |
 Designable.Processable.Processable | Processables, when combined with Proxies that are added during Design, can generically implement most of the custom member and component protocols for graphical and process |
  Designable.ProcessableComponent.ProcessableComponent | No documentation available |
  Designable.ProcessableMember.ProcessableMember | A base class for processable custom members |
 Feedback.ProgressDialog | No documentation available |
 dialog.controller.PropertyException | No documentation available |
 Designable.Proxies.Proxy | Base class for all Proxy classes |
  Designable.Proxies.BoltAddProxy | No documentation available |
  Designable.Proxies.BreakApartMaterialsProxy | No documentation available |
  Designable.Proxies.ChangeSeveralMaterialsProxy | No documentation available |
  Designable.Proxies.CopyMaterialProxy | No documentation available |
  Designable.Proxies.HoleAddProxy | No documentation available |
  Designable.Proxies.MaterialAddProxy | No documentation available |
   Designable.Proxies.MaterialSansWkptSlopeAddProxy | No documentation available |
  Designable.Proxies.MaterialEraseExistingProxy | No documentation available |
   Designable.Proxies.MaterialEraseDesignableProxy | No documentation available |
  Designable.Proxies.MemberBaseAddMaterialProxy | No documentation available |
  Designable.Proxies.MemberBaseAddMaterialsProxy | No documentation available |
  Designable.Proxies.MemberViewTupleProxy | No documentation available |
  Designable.Proxies.MergeMaterialProxy | No documentation available |
  Designable.Proxies.MirrorMaterialProxy | No documentation available |
  Designable.Proxies.MirrorMaterialsProxy | No documentation available |
  Designable.Proxies.MtrlCutProxy | No documentation available |
  Designable.Proxies.MtrlFitProxy | No documentation available |
  Designable.Proxies.WeldAddProxy | No documentation available |
 dialog.pusher.Pusher | This can connect a property across multiple subdialogs in a safe way that gets multi-edit right |
 dialog.queueable.queueable | This decorator is to mark a function as able to be added to the idle queue, done later and done only once! def foo( .. |
 RCE.RCETemplate | No documentation available |
 RCE.RCEType | No documentation available |
 componentedit.ReadOnlyHandler | No documentation available |
 dialog.labeledfield.Reasoned | No documentation available |
  dialog.labeledfield.ReasonedAndMixed | No documentation available |
   dialog.combobox.BareCombobox | A bare combobox field |
   dialog.entry.BareEntry | A bare entry field |
 concrete.RebarAttMixin.RebarAttMixin | No documentation available |
 RCE.RebarCageTemplate | No documentation available |
 Rebar.RebarCoating | No documentation available |
 Rebar.RebarGrade | No documentation available |
 Rebar.RebarShapeTemplate | No documentation available |
 Rebar.RebarStandard | No documentation available |
 RebarWidgets.RebarWidgetManager | No documentation available |
 Rebar.ReferencePoint | No documentation available |
 MemberBase.RegisterMemberTypeDeprecationException | No documentation available |
 dialog.dialog.ResponseNotOK | No documentation available |
 Kiss.RoutingType | No documentation available |
 dialog.table.RowAssertion | No documentation available |
 dialog.rule.Rule | No documentation available |
  dialog.field.Modified | This is a field level rule |
  dialog.item.ChildWatch | No documentation available |
  dialog.item.Context | No documentation available |
   dialog.table.TableContext | No documentation available |
  dialog.item.OnLoad | Use the OnLoad rule to find out when a load event occurs |
  dialog.item.OnStore | Like the OnLoad rule, for storing |
  dialog.rule.ValueRule | Some of this API is as it is for efficiency |
   dialog.rules.Always | Anytime rules are run, go ahead and run this rule |
   dialog.rules.Changed | Calls its function whenever the value is changed on screen |
   dialog.rules.Disable | Disable another field triggered off of this field |
   dialog.rules.MarkIf | If a Rule applies, then mark our value to a certain value |
   dialog.rules.Original | No documentation available |
    dialog.rules.NotOriginal | No documentation available |
   dialog.rules.Validate | This rule should be used to indicate if a value, in the display model, is valid or invalid |
  dialog.rules.State | The last State added wins |
  dialog.widget.FocusRule | Allows you to attach a callback to focus in and focusout |
   dialog.widget.ValidatePopup | This is a FocusRule implemented to display a popup if your passed in function 'do' returns false |
 dialog.field.RuleException | No documentation available |
 dialog.rule.RuleException | No documentation available |
 dialog.rules.RulesException | No documentation available |
 dialog.dialog.SaveError | No documentation available |
 component_tools.ScopedLocksUI | No documentation available |
 gadget_protocol.SetReadOnlyCallable | No documentation available |
 Kiss.Setup | No documentation available |
 CNC.Setup | No documentation available |
 u3de.Shading | No documentation available |
 sds2.sub_mtrl.ShearStudSubMaterialReference | No documentation available |
 Drawing.SheetRevision | No documentation available |
 signal_repeater.SignalRepeater | No documentation available |
 dialog.subdialog_test.simulation | No documentation available |
 dialog.simulate.Simulator | No documentation available |
 concrete.RebarSegment.SmartRebarLayout | Object for transporting all data necesssary to add a rebar segment that respects cover, cage and length restrictions |
 dialog.variablespacing.SpacingKind | No documentation available |
 EmbedPlateModule.SpacingList | List of floating point values representing plate attachment spacings |
 componentedit.StandaloneComponentEditController | No documentation available |
 gadget_protocol.StandAloneEditController | No documentation available |
 StandardDetail.StandardDetailType | No documentation available |
 dialog.dialog.StartupException | No documentation available |
 StateAccessor.StateAccessor | This is a helper class for custom members |
  HashingComponent.HashingComponent | A primer class that has a decorator for hashing the object during the edit method |
  UnreadableComponentProxy.UnreadableComponentProxy | No documentation available |
 Commands.Station | No documentation available |
 param.StationError | No documentation available |
 sds2.status_display.StatusDisplay | No documentation available |
 Storage.StorageException | No documentation available |
 StoredObject.StoredObject | No documentation available |
 Rebar.StringVec | No documentation available |
 EmbedPlateModule.StudAttachmentList | List of stud attachments to embed plates |
 gadget_protocol.SubdialogController | The most common controller used when creating banners, columns, and leaves |
  gadget_protocol.MemberEditMethodsWrapper | No documentation available |
  gadget_protocol.ModelCompleteSubdialogController | Use this controller when the UI has a model complete item |
 dialog.subdialog_test.SubdialogTestCases | No documentation available |
 sds2.sub_mtrl.SubMaterialIndexRange | No documentation available |
 dialog.table.TableException | No documentation available |
 dialog.table.TableMedium | Internal logic |
 shape.tabulated_properties | No documentation available |
 lazy.total | No documentation available |
 Transform3D.Transform3D | No documentation available |
 transmittal.transmittal_full_status | No documentation available |
 sds2.sub_mtrl.TurnbuckleSubMaterialReference | No documentation available |
 dialog.controller.TypeHandler | Use this to modify a type as it comes in or goes out |
 Plugins.UnavailableLicenseException | No documentation available |
 dialog.updateable.UpdateAble | No documentation available |
 UserDefinedConnection.UserDefinedConnection | No documentation available |
 Uuid.Uuid | No documentation available |
 dialog.value.ValueException | No documentation available |
 dialog.value.ValueImpl | No documentation available |
  dialog.value.UnmanagedValue | No documentation available |
  dialog.value.Value | A Value exists for every name on every ModelRoot |
 Tkinter.Variable | Class to define value holders for e.g |
  Tkinter.BooleanVar | Value holder for boolean variables |
  Tkinter.DoubleVar | Value holder for float variables |
  Tkinter.IntVar | Value holder for integer variables |
  Tkinter.StringVar | Value holder for strings variables |
 Kiss.VersionType | No documentation available |
 Layout3DEditor.Vertice3DObj | No documentation available |
 u3de.ViewNode | No documentation available |
 evu.ViewType | No documentation available |
 CMU.VoidDef | No documentation available |
 member.warning | No documentation available |
 boltmtrl.Washer | No documentation available |
 Designable.Proxies.WasherProxy | No documentation available |
 sds2.sub_mtrl.WasherSubMaterialReference | No documentation available |
 Designable.Existing.Weld | No documentation available |
 Events.WeldEvent | No documentation available |
 dialog.widget.Widget | This is a mixin class |
  dialog.button.Button | No documentation available |
  dialog.checkbox.Checkbox | Provides a field with one checkbox which is either true or false |
  dialog.checkbox.CheckButtons | This is a compatibility class for old dialogs |
  dialog.combobox.BareCombobox | A bare combobox field |
  dialog.dialog.DialogBase | No documentation available |
  dialog.entry.BareEntry | A bare entry field |
  dialog.frame.Frame | A generic visual holder a la Tkinter.Frame |
  dialog.image.Image | No documentation available |
  dialog.label.Label | No documentation available |
  dialog.labeledfield.Labeled | This class handles using fixed width fonts to keep a column of entries lined up |
  dialog.listbox.ContentListbox | This listbox displays values in mixed mode |
  dialog.listbox.Listbox | No documentation available |
  dialog.lockablefield.LockableCheckbox | Provides a field with a lockable button (essentially a checkbox) which is either true or false |
  dialog.page.Page | No documentation available |
  dialog.scrollbar.ScrollableFrame | No documentation available |
  dialog.scrollbar.ScrollableFrame_Impl | Implementation detail of ScrollableFrame |
  dialog.scrollbar.Scrollbar | This is really a scrolled window |
  dialog.subdialog.Subdialog | No documentation available |
  dialog.table.RowManager | No documentation available |
  dialog.table.Table | A table is a tk table widget on screen |
  dialog.table.TableColumn | Add columns to your table |
  dialog.tabset.Tab | No documentation available |
  dialog.tabset.Tabset | No documentation available |
  dialog.text.Text | This is a multi line text area |
  Layout3DEditor.Layout3DEditor | No documentation available |
 dialog.dialog.WindowDestroyedException | No documentation available |
 dialog.dialog.WindowExists | No documentation available |
 Tkinter.Wm | Provides functions for the communication with the window manager |
  Tkinter.Tk | Toplevel widget of Tk which represents mostly the main window of an application |
  Tkinter.Toplevel | Toplevel widget, e.g |
 Tkinter.XView | Mix-in class for querying and changing the horizontal position of a widget's window |
  Tkinter.Canvas | Canvas widget to display graphical elements like lines or text |
  Tkinter.Entry | Entry widget which allows to display simple text |
  Tkinter.Listbox | Listbox widget which can display a list of strings |
  Tkinter.Spinbox | Spinbox widget |
  Tkinter.Text | Text widget which can display text in various forms |
 Tkinter.YView | Mix-in class for querying and changing the vertical position of a widget's window |
  Tkinter.Canvas | Canvas widget to display graphical elements like lines or text |
  Tkinter.Listbox | Listbox widget which can display a list of strings |
  Tkinter.Text | Text widget which can display text in various forms |