No documentation available.
More...
Methods inherited from Condition: |
def | matches |
Data and other attributes inherited from Boost.Python.instance: |
def | __new__ |
Additional Inherited Members |
def | __init__ |
Detailed Description
No documentation available.
Method resolution order
ConditionApprovalStatus
Condition
Boost.Python.instance
builtin.object
Constructor & Destructor Documentation
def sds2.status_display.ConditionApprovalStatus.__init__ |
( |
|
arg1, |
|
|
|
approved = True , |
|
|
|
as_noted = True , |
|
|
|
resubmit = False , |
|
|
|
rejected = False , |
|
|
|
not_reviewed = False |
|
) |
| |
- Returns
- Instance of type None
Member Function Documentation
def sds2.status_display.ConditionApprovalStatus.__copy__ |
( |
|
arg1 | ) |
|
- Returns
- Instance of type object
def sds2.status_display.ConditionApprovalStatus.__deepcopy__ |
( |
|
arg1, |
|
|
|
arg2 |
|
) |
| |
- Returns
- Instance of type object
def sds2.status_display.ConditionApprovalStatus.__dict__ |
( |
|
args | ) |
|
def sds2.status_display.ConditionApprovalStatus.__eq__ |
( |
|
arg1, |
|
|
|
arg2 |
|
) |
| |
def sds2.status_display.ConditionApprovalStatus.__getinitargs__ |
( |
|
arg1 | ) |
|
- Returns
- Instance of type tuple
def sds2.status_display.ConditionApprovalStatus.__getstate__ |
( |
|
arg1 | ) |
|
- Returns
- Instance of type tuple
def sds2.status_display.ConditionApprovalStatus.__ne__ |
( |
|
arg1, |
|
|
|
arg2 |
|
) |
| |
def sds2.status_display.ConditionApprovalStatus.__new__ |
( |
|
args | ) |
|
T.__new__(S, ...) -> a new object with type S, a subtype of T
__new__ = <built-in method __new__ of Boost.Python.class object>
Reimplemented from sds2.status_display.Condition.
def sds2.status_display.ConditionApprovalStatus.__reduce__ |
( |
|
args | ) |
|
def sds2.status_display.ConditionApprovalStatus.__repr__ |
( |
|
arg1 | ) |
|
- Returns
- Instance of type object
def sds2.status_display.ConditionApprovalStatus.__setstate__ |
( |
|
arg1, |
|
|
|
arg2 |
|
) |
| |
- Returns
- Instance of type None
def sds2.status_display.ConditionApprovalStatus.__str__ |
( |
|
arg1 | ) |
|
- Returns
- Instance of type object
def sds2.status_display.ConditionApprovalStatus.__weakref__ |
( |
|
args | ) |
|
def sds2.status_display.ConditionApprovalStatus.approved |
( |
|
args | ) |
|
def sds2.status_display.ConditionApprovalStatus.as_noted |
( |
|
args | ) |
|
def sds2.status_display.ConditionApprovalStatus.matches |
( |
|
arg1, |
|
|
|
arg2 |
|
) |
| |
def sds2.status_display.ConditionApprovalStatus.not_reviewed |
( |
|
args | ) |
|
def sds2.status_display.ConditionApprovalStatus.rejected |
( |
|
args | ) |
|
def sds2.status_display.ConditionApprovalStatus.resubmit |
( |
|
args | ) |
|
Member Data Documentation
sds2.status_display.ConditionApprovalStatus.__getstate_manages_dict__ = True |
|
staticprivate |
int sds2.status_display.ConditionApprovalStatus.__instance_size__ = 56 |
|
staticprivate |
sds2.status_display.ConditionApprovalStatus.__safe_for_unpickling__ = True |
|
staticprivate |