AdvancedSelection | |
AllOrNoneGraphical | Helper routines for the default 'all or nothing' graphical behavior for plugins |
assembly | |
error | No documentation available |
blowfish | |
bnt_plate | |
error | No documentation available |
bolt_add | |
error | No documentation available |
boltmtrl | |
MaterialBolt | No documentation available |
Washer | No documentation available |
C_DiagramBuilder | |
DiagramBinding | No documentation available |
clevis | |
error | No documentation available |
CMU | |
AxisParallelPlane | No documentation available |
CMUTemplate | No documentation available |
VoidDef | No documentation available |
CNC | |
GenerateFileForType | No documentation available |
Setup | No documentation available |
cod | |
CreationOrderedDict | No documentation available |
Commands | |
AvailableTools | No documentation available |
CmdArgs | No documentation available |
Command | No documentation available |
CommandType | No documentation available |
Flyout | No documentation available |
Group | No documentation available |
GroupNode | No documentation available |
Icon | No documentation available |
IconSet | No documentation available |
Licensing | No documentation available |
Listing | No documentation available |
OperationClass | No documentation available |
Station | No documentation available |
WidgetCommand | No documentation available |
Component | Functions to add, read, edit, and delete components |
Component | Components provide a way to extend the functionality of members using the Parametric API in a dynamic way that can't be recreated with a normal parametric |
component_tools | |
ComponentAddCommand | No documentation available |
NotAllowedOnAnyMember | No documentation available |
ScopedLocksUI | No documentation available |
componentedit | |
ComponentUIHelper | A mixin class to help simple components adapt to member edit conventions |
GadgetCopyButton | No documentation available |
GadgetLoadButton | No documentation available |
GadgetPasteButton | No documentation available |
GadgetSaveButton | No documentation available |
LeafMaker | No documentation available |
MemberEditMethods | A mixin class that manages a ComponentUIHelper object, and delegates the functions required by the member edit screen to that object |
ReadOnlyHandler | No documentation available |
StandaloneComponentEditController | No documentation available |
StandaloneComponentEditView | No documentation available |
ComponentSetupScreen | |
ComponentSetupScreen | No documentation available |
ComponentState | |
ComponentState | This is a helper to make Component.GetState easy to implement |
concrete | |
LineSegment | |
LineSegment | Class to represent a line segment |
OverlapRebarGenerator | |
RebarAttMixin | |
RebarAttMixin | No documentation available |
RebarSegment | A class representing a rebar segment |
SmartRebarLayout | A rebar utility for respecting max length |
SweepLine | A module for running the Sweep-Line algorithm |
concrete_utilities | |
CornerInformation | No documentation available |
FootingMatInformation | No documentation available |
MatAdjustments | No documentation available |
SlabMatInformation | No documentation available |
WallMatInformation | No documentation available |
cons_circle | This module provides an interface to construction circles |
error | No documentation available |
cons_line | This module provides an interface to construction lines |
error | No documentation available |
cons_tests | |
ConsTestCases | No documentation available |
CustomMemberEditHelp | |
CustomProperties | |
date_routines | |
deck | |
error | No documentation available |
default_ComponentState | |
MemoryStream | No documentation available |
pickle_ComponentState | This just simply uses the hash of individual items in the object |
Designable | |
Existing | |
Bolt | No documentation available |
BoltGroup | No documentation available |
Hole | No documentation available |
HoleGroup | No documentation available |
Material | No documentation available |
MaterialByIDOrUse | No documentation available |
Member | No documentation available |
NextMainMaterialOfMember | No documentation available |
Weld | No documentation available |
Processable | |
MaterialCreationPhases | Class that exists soley to define enumerated values for the material creation phases of process without polluting the the module namespace |
Processable | Processables, when combined with Proxies that are added during Design, can generically implement most of the custom member and component protocols for graphical and process |
ProcessableComponent | |
EndComponent | No documentation available |
ProcessableComponent | No documentation available |
ProcessableMember | This module provides a base class for processable custom members |
ProcessableMember | A base class for processable custom members |
Proxies | |
BoltAddProxy | No documentation available |
BreakApartMaterialsProxy | No documentation available |
ChangeSeveralMaterialsProxy | No documentation available |
CopyMaterialProxy | No documentation available |
HoleAddProxy | No documentation available |
Layout3D | No documentation available |
MaterialAddProxy | No documentation available |
MaterialEraseDesignableProxy | No documentation available |
MaterialEraseExistingProxy | No documentation available |
MaterialSansWkptSlopeAddProxy | No documentation available |
MemberBaseAddMaterialProxy | No documentation available |
MemberBaseAddMaterialsProxy | No documentation available |
MemberViewTupleProxy | No documentation available |
MergeMaterialProxy | No documentation available |
MirrorMaterialProxy | No documentation available |
MirrorMaterialsProxy | No documentation available |
MtrlCutProxy | No documentation available |
MtrlFitProxy | No documentation available |
Proxy | Base class for all Proxy classes |
RebarMaterialAddProxy | No documentation available |
RebarMaterialBatchAddProxy | No documentation available |
RebarMaterialFitToDowelsProxy | No documentation available |
WasherProxy | No documentation available |
WeldAddProxy | No documentation available |
DesignCalcs | |
diagram | |
DiagramBuilder | |
ArcItem | A diagram item that adds an arc to the canvas |
CompositeItem | An abstract diagram item that is composed of multiple other diagram items |
DiagramBuilder | This class is a wrapper for Tkinter.Canvas that provides a few additional features: |
DiagramItem | Abstract parent class for items added to a diagram |
DimensionItem | A diagram item that adds a dimension to the canvas |
LabeledArrowItem | A diagram item that adds a labeled arrow to the canvas |
Layout3DPolygonItem | A diagram item that adds a polygon to the canvas in the shape of a projection on a Layout3D |
LineItem | A diagram item that adds a line to the canvas |
OvalItem | A diagram item that adds an oval to the canvas |
PolygonItem | A diagram item that adds a polygon to the canvas |
RectangleItem | A diagram item that adds a rectangle to the canvas |
TextItem | A diagram item that adds text to the canvas |
dialog | |
abstract | |
assembly_quote | |
assembly_quote | Wrap certain API calls with this in order to facilitate SDS/2 Assembly dialog editor knowing which parts of each function call it needs to wrap in quotes in order to get the expression and not the result of the expression |
attributecontrollers | |
AttributeController | No documentation available |
AttributeIndexController | No documentation available |
AttributeListController | No documentation available |
ComboboxTransformer | This can be used with Attribute*Controllers rather than using
Combobox*Controllers.
|
EndElevationController | No documentation available |
ObjectController | No documentation available |
ObjectIndexController | No documentation available |
ObjectListController | No documentation available |
ReadOnly | No documentation available |
ReadOnlyAttributeController | No documentation available |
ReadOnlyAttributeIndexController | No documentation available |
ReadOnlyAttributeListController | No documentation available |
ReadOnlyObjectController | No documentation available |
ReadOnlyObjectIndexController | No documentation available |
ReadOnlyObjectListController | No documentation available |
builder | |
Builder | This is an abstract class |
BuildException | No documentation available |
button | |
Button | No documentation available |
checkbox | |
Checkbox | Provides a field with one checkbox which is either true or false |
CheckButtons | This is a compatibility class for old dialogs |
choose_file | |
Choose | Base class for entry paired with a button that launches an interactive dialog |
ChooseDirectory | A field which allows a user to pick a directory in the filesystem |
ChooseFile | A field which allows a user to pick a file in the filesystem |
ChooseMtrl | A field that allows a user to pick a section size from the list of available section sizes |
ChooseStr | A field that allows a user to pick from a list of string options |
color | |
combo_choose | |
CanvasButton | A canvas that will act as a button |
ChooseColor | A widget that allows users to pick from a collection of named colors or choose a custom color using the Tkinter color dialog |
ChooseColorKind | A 3-tuple of ints between 0 and 256 representing a single color |
combobox | |
BareCombobox | A bare combobox field |
Combobox | Formerly known as menu, this is a drop down box |
ComboboxError | No documentation available |
TkCombobox | This is an internal class to expose our SDS/2's combobox to Python |
controller | |
Controller | No documentation available |
DictController | This controller is like PropertyController but it works with dictionaries instead of object properties |
ItemController | Override this abstract class's get/set methods to have a per field controller |
PropertyController | This is the default controller for dialogs |
PropertyException | No documentation available |
TypeHandler | Use this to modify a type as it comes in or goes out |
date | |
Date | No documentation available |
DateEntry | An entry field formatted for entering dates |
decorators | |
dialog | |
Dialog | No documentation available |
DialogBase | No documentation available |
ResponseNotOK | No documentation available |
SaveError | No documentation available |
StartupException | No documentation available |
WindowDestroyedException | No documentation available |
WindowExists | No documentation available |
Wizard | This is a special kind of dialog |
dimension | |
DimensionEntry | An entry field formatted for entering dimensions |
displaymodel | |
DisplayModel | No documentation available |
DisplayModelException | No documentation available |
DisplayModelList | This should always be constructed by the dialog |
DisplayStorage | This is one implementation of storage for one field name |
entry | |
BareEntry | A bare entry field |
Entry | No documentation available |
FloatEntry | An entry field formatted for entering floating point numbers |
IntEntry | An entry field formatted for entering integer numbers |
MaterialPiecemarkEntry | An entry field with rules added for material piecemarks |
ReadOnlyEntry | This entry field acts like the entry.label from 7.1 |
StrEntry | An entry field formatted for entering free format strings |
field | |
Field | |
KindException | No documentation available |
Modified | This is a field level rule |
RuleException | No documentation available |
filefacade | |
filefacade | This is for internal use |
frame | |
Column | A frame that fills top to bottom and is intended to be placed like columns on a page |
CopyButton | No documentation available |
Frame | A generic visual holder a la Tkinter.Frame |
LoadableFrame | This makes a Frame (a la Frame) that has copy, paste, save, and load buttons on it |
LoadButton | No documentation available |
PasteButton | No documentation available |
SaveButton | No documentation available |
hidden | |
Hidden | This is a field which is not visible within the gui, it has no attached Tkinter widgets |
image | |
Image | No documentation available |
item | |
ChildWatch | No documentation available |
Context | No documentation available |
Item | |
MenuFacade | This object looks like a Tkinter.Menu in that you can add the same sorts of items to it |
OnLoad | Use the OnLoad rule to find out when a load event occurs |
OnStore | Like the OnLoad rule, for storing |
kind | |
KindException | No documentation available |
ParseException | No documentation available |
label | |
Label | No documentation available |
labeledfield | |
Labeled | This class handles using fixed width fonts to keep a column of entries lined up |
Reasoned | No documentation available |
ReasonedAndMixed | No documentation available |
listbox | |
ContentListbox | This listbox displays values in mixed mode |
Listbox | No documentation available |
listindex | |
LIndexBase | No documentation available |
listof | |
lockablefield | |
DeletableCombobox | No documentation available |
DeletableEntry | No documentation available |
LockableCheckbox | Provides a field with a lockable button (essentially a checkbox) which is either true or false |
LockableCombobox | No documentation available |
LockableEntry | No documentation available |
modelroot | |
ModelRoot | A ModelRoot is an item in the dialog which can have .model assigned to it and will use that list of models, with a controller, to load and save from the dialog items under it |
overlaytabs | #!! this file us unused |
page | |
Page | No documentation available |
pmdialog | |
PMDialog | |
pusher | |
Pusher | This can connect a property across multiple subdialogs in a safe way that gets multi-edit right |
queueable | |
queueable | This decorator is to mark a function as able to be added to the idle queue, done later and done only once! def foo( .. |
radio | |
Radio | No documentation available |
rule | |
Rule | No documentation available |
RuleException | No documentation available |
ValueRule | Some of this API is as it is for efficiency |
rules | |
Always | Anytime rules are run, go ahead and run this rule |
assign | This is like expr but you give an extra argument (at the beginning) to assign the result of the expression to |
AssignException | No documentation available |
Changed | Calls its function whenever the value is changed on screen |
Disable | Disable another field triggered off of this field |
MarkIf | If a Rule applies, then mark our value to a certain value |
NotOriginal | No documentation available |
Original | No documentation available |
RulesException | No documentation available |
State | The last State added wins |
Validate | This rule should be used to indicate if a value, in the display model, is valid or invalid |
scrollbar | |
ScrollableFrame | No documentation available |
ScrollableFrame_Impl | Implementation detail of ScrollableFrame |
Scrollbar | This is really a scrolled window |
TkScrollableFrame | No documentation available |
TkScrolledWindow | No documentation available |
see | |
simulate | |
Simulator | No documentation available |
singletable | module no longer supported.
|
subdialog | |
Subdialog | No documentation available |
subdialog_test | |
Model | No documentation available |
simulation | No documentation available |
SubdialogTestCases | No documentation available |
table | |
DisplayRowManagerException | No documentation available |
RowAssertion | No documentation available |
RowManager | No documentation available |
RowManagerController | This is an internal class |
Table | A table is a tk table widget on screen |
TableColumn | Add columns to your table |
TableContext | No documentation available |
TableException | No documentation available |
TableMedium | Internal logic |
TkTable | Internal class |
tabset | |
Tab | No documentation available |
Tabset | No documentation available |
TkTab | No documentation available |
TkTabset | No documentation available |
text | |
Text | This is a multi line text area |
updateable | |
UpdateAble | No documentation available |
value | |
UnmanagedValue | No documentation available |
Value | A Value exists for every name on every ModelRoot |
ValueException | No documentation available |
ValueImpl | No documentation available |
variablespacing | |
SpacingKind | No documentation available |
weak | |
widget | |
FocusRule | Allows you to attach a callback to focus in and focusout |
GridException | No documentation available |
ValidatePopup | This is a FocusRule implemented to display a popup if your passed in function 'do' returns false |
Widget | This is a mixin class |
dimension_routines | |
dismissal_guard | |
Guarded | No documentation available |
Drawing | |
BillLine | No documentation available |
BOM | No documentation available |
Drawing | No documentation available |
DrawingReference | No documentation available |
FileReference | No documentation available |
SheetItem | No documentation available |
SheetRevision | No documentation available |
DummyMaterial | |
DummyMaterial | No documentation available |
DummyMember | |
DummyMember | No documentation available |
EmbedPlateModule | |
DeformedBarAttachment | Data representing a deformed bar attachment to an embed plate |
DeformedBarAttachmentList | List of deformed bar attachments to embed plates |
EmbedPlateDefinition | A single entry from the Embed Plate Schedule |
HoleAttachment | Data representing a single hole attachment to an embed plate |
HoleAttachmentList | List of hole attachments to embed plates |
StudAttachment | Data representing a single stud attachment to an embed plate |
StudAttachmentList | List of stud attachments to embed plates |
enum_copy_reg | |
Events | |
BoltEvent | No documentation available |
MaterialEvent | No documentation available |
MemberEvent | No documentation available |
WeldEvent | No documentation available |
evu | |
ViewType | No documentation available |
Exceptions | |
fab | This module provides an interface to fab setup information |
error | No documentation available |
Feedback | |
feedback | This decorator is provided to mark a method as possibly slow running |
Feedback | No documentation available |
OneMomentPlease | No documentation available |
progress | This decorator is provided to create a ProgressDialog |
ProgressDialog | No documentation available |
ProgressException | No documentation available |
filewrapper | |
filewrapper | No documentation available |
flat_bar | |
error | No documentation available |
FloatComparison | |
Gadget | |
CallbackBanner | A python constructible GadgetBanner |
CallbackColumn | A python-constructible GadgetColumn |
CallbackLeaf | Python-constructible GadgetLeaf objects |
GadgetBanner | An object that may be returned by some SDS/2 core APIs |
GadgetColumnAn | No documentation available |
GadgetLeaf | An object that may be returned by some SDS2/2 core APIs |
GadgetScreen | GadgetScreen(screen_name, title, place_mode) |
MemberEditScreen | No documentation available |
PlaceMode | No documentation available |
gadget_protocol | |
DoNotPickle | No documentation available |
GadgetComponent | Mix-in class for where derived class is expected to implement CreateCustomMultiEditableUI and optionally define StandAloneEditWindowID, and OnStandAloneEditHelp |
GadgetFactory | Instances of this class are passed to the callback functions that populate frames (Subdialogs) with the plugin specific information |
GadgetMaterial | Mix-in class for where derived class is expected to implement CreateCustomMultiEditableUI and optionally define StandAloneEditWindowID, and OnStandAloneEditHelp |
GadgetSetup | No documentation available |
InStandAloneEdit | No documentation available |
MemberEditMethodsWrapper | No documentation available |
MemberEditMultiCreateUI | No documentation available |
ModelCompleteSubdialogController | Use this controller when the UI has a model complete item |
MultiEditable | Mix-in class where a derived class is expected to implement CreateCustomMultiEditableUI to customize a GadgetScreen |
ReadOnlyHandler | No documentation available |
SetReadOnlyCallable | No documentation available |
StandAloneEditController | No documentation available |
SubdialogController | The most common controller used when creating banners, columns, and leaves |
gadget_protocol_member | |
ChooseSequence | A field which allows a user to pick a job sequence |
GadgetMember | Mix-in class for where derived class is expected to implement CreateCustomMultiEditableUI and optionally define StandAloneEditWindowID, UserStr, OnStandAloneEditHelp, and StandAloneComponentFilter |
MemberAttrController | Entry's using this ItemController will coalesce all member.Member changes under one Update call for each member being edited |
MemberDateController | Member.Member date attributes have a different string value than what user's expect to see |
Rotation0_90 | This entry mimics the 0/90 rotation fields |
gadget_support | |
grate | |
error | No documentation available |
grate_trd | |
error | No documentation available |
GroupMember | |
Group | No documentation available |
Hash | |
Hash | No documentation available |
HashingComponent | |
HashingComponent | A primer class that has a decorator for hashing the object during the edit method |
hole_add | |
error | No documentation available |
HoleMatch | |
Import | |
IncorrectMemberTypeException | |
IncorrectMemberTypeException | No documentation available |
iterators | |
job | This module provides an interface to job setup information |
error | No documentation available |
JobSetupLock | Opaque class representing the lock status of job options |
MemberRevisionTuple | MemberRevisionTuple(short_description, long_description) |
Joist | |
Joist | No documentation available |
JoistMemberCore | |
JoistManufacturer | |
JoistBIMBase | Mote of a manufacturer's BIM data, stored on Joist.manufacturer_bim with each member |
JoistManufacturer | Base class for joist manufacturers |
JoistSetupBase | No documentation available |
Setup | |
Choose | Base class for entry paired with a button that launches an interactive dialog |
Setup | No documentation available |
SetupEdit | No documentation available |
Kiss | |
BoltQuantityType | No documentation available |
DataSource | No documentation available |
RoutingType | No documentation available |
Setup | No documentation available |
VersionType | No documentation available |
Layout3D | |
Layout3D | No documentation available |
Layout3DNode | No documentation available |
RebarLayout3D | No documentation available |
RebarLayout3DNode | No documentation available |
Layout3DEditor | |
CanvasObj | No documentation available |
DrawObj | No documentation available |
GripObj | No documentation available |
Layout3DEditor | No documentation available |
Layout3DWrapper | No documentation available |
TableObj | No documentation available |
Vertice3DObj | No documentation available |
layout_offset | |
lazy | |
all | No documentation available |
any | No documentation available |
none | No documentation available |
total | No documentation available |
LegacyGraphical | |
LegacyGraphical | The default behavior for custom members changed after 7.3 |
Line3D | |
Line3D | No documentation available |
LinearRange | |
LinearRange | Represents a range on a continuous one-dimensional number line which can be split up into mutiple smaller ranges by cutting the original range |
Locator | |
Button | No documentation available |
Locator3D | No documentation available |
StairLocator3D | No documentation available |
MainMaterial | |
id | No documentation available |
mainpage | |
matches | |
material_copy_tool | |
CopyDialogParameters | No documentation available |
MaterialBase | |
BuiltinMaterial | No documentation available |
LocateResult | No documentation available |
MaterialBase | No documentation available |
MaterialBaseException | No documentation available |
MaterialHandle | No documentation available |
MaterialBaseWidgets | |
MaterialFinishCombobox | No documentation available |
MaterialGradeCombobox | No documentation available |
materialfile | |
MaterialFile | No documentation available |
Math3D | |
member | This module provides an interface to the member database |
error | No documentation available |
warning | No documentation available |
member_edit | |
End | No documentation available |
MemberEditController | No documentation available |
MemberBase | |
BuiltinMember | No documentation available |
JoistMemberBase | No documentation available |
MemberBase | No documentation available |
RegisterMemberTypeDeprecationException | No documentation available |
MergeMaterial | |
model | This module allows access to the objects in the SDS/2 model |
Enum | No documentation available |
error | No documentation available |
point3 | No documentation available |
PolygonFaceType | No documentation available |
ModelPins | ModelPins gives access to investigate, create, add, and remove pins from the model in the same ways users can interactively |
AutoAdd | Use this with a python 'with' statement like this: with AutoAdd() as add: add.Add(1,1) add.FindNearbyMembers() |
DynamicOffset | Base class for complex offsets |
EditAndApply | Use this to add, remove, and edit pins and apply them when you're finished, like this: with EditAndApply() as edit: edit.Remove(mypin) #remove it before modifying it mypin.SetSomeProperty() #modify the pin edit.Add(mypin) #add the modified pin back Your changes are applied when the with block exits |
EvenSpacing | No documentation available |
ExactLocation | No documentation available |
GridToMember | Pins a member end to an erection view plane |
MemberToMember | Pins a member to the line of another member |
MemberToMemberEndPlane | No documentation available |
MemberToMemberPlane | Pins members to another member's flange or web plane |
MemberToSelf | Pins a member end to a plane based on its web or flange |
ModelPin | The base class for pins in the model |
StaticOffset | A static variant of a complex offset |
WebMidPointOffset | An offset to half the nominal depth below the member line |
mtrl_cut | |
error | No documentation available |
mtrl_fit | |
error | No documentation available |
mtrl_list | |
error | No documentation available |
Object | |
Output | |
CompressionType | No documentation available |
Destination | No documentation available |
DestinationType | No documentation available |
EndLineType | No documentation available |
PackDirectory | |
PackJobData | |
param | |
error | No documentation available |
ParametricIndexRange | Range of used parametric indices |
ParametricReference | No documentation available |
StationError | No documentation available |
PartLibrary | |
Part | No documentation available |
Plane3D | |
Plane3D | No documentation available |
plate_layout | |
error | No documentation available |
Plugins | |
UnavailableLicenseException | No documentation available |
PluginSetupTools | |
NoSetup | No documentation available |
PluginSetupCommand | No documentation available |
point | This module provides an interface to 3 dimensional points |
error | No documentation available |
Point3D | |
Point3D | No documentation available |
poly_shape_utils | |
RCE | |
ContBarPlacement | No documentation available |
DowelPattern | No documentation available |
DowelPatternPlacement | No documentation available |
DowelPatternPlacementMap | No documentation available |
map_indexing_suite_DowelPatternPlacementMap_entry | No documentation available |
map_indexing_suite_RebarVecMap_entry | No documentation available |
RCETemplate | No documentation available |
RCEType | No documentation available |
RebarCageTemplate | No documentation available |
RebarVecMap | No documentation available |
ReadOnly | |
Rebar | |
DeformedEndOp | No documentation available |
EndOperation | No documentation available |
EndOperationType | No documentation available |
HookType | No documentation available |
map_indexing_suite_ParameterMap_entry | No documentation available |
ParameterLockType | No documentation available |
ParameterMap | No documentation available |
ParameterUseType | No documentation available |
ParameterVarType | No documentation available |
PlainEndOp | No documentation available |
RebarCoating | No documentation available |
RebarDefinition | No documentation available |
RebarGrade | No documentation available |
RebarParameter | No documentation available |
RebarReferencePoint | No documentation available |
RebarShapeTemplate | No documentation available |
RebarShapeTransform | No documentation available |
RebarStandard | No documentation available |
RebarUsageType | No documentation available |
ReferencePoint | No documentation available |
ShapedRebarMaterial | No documentation available |
StringVec | No documentation available |
TerminatorEndOp | No documentation available |
TerminatorType | No documentation available |
ThreadedEndOp | No documentation available |
ThreadType | No documentation available |
RebarSets | |
RebarWidgets | |
RebarWidgetManager | No documentation available |
rect_plate | |
error | No documentation available |
ReferenceModel | |
ReferenceModel | No documentation available |
registry | |
plugin_finder | Internal class |
ReportWriter | |
RFI | |
rnd_bar | |
error | No documentation available |
rnd_plate | |
error | No documentation available |
roll_plate | |
error | No documentation available |
rolled_section | |
error | No documentation available |
rotation | This module provides an interface to 3 dimensional rotations |
error | No documentation available |
run_parametric | |
sds2 | |
breakapart | |
color | |
Color | No documentation available |
iterators | Iterators for job objects |
lists | |
lockable | |
ConnectionLocks | Interface to connection design locks on a connection component on a member's end |
LockableValue | A picklable class that simulates the behavior of connection design locks visible on the member edit screen |
model_dimension | Manipulate SDS/2 Model Dimensions |
LinearDimension | No documentation available |
obj | |
piecemark | |
PiecemarkIndexRange | Range of used piecemark indices |
PiecemarkReference | No documentation available |
status_display | |
BooleanOperation | No documentation available |
ComparisonOperator | No documentation available |
Condition | No documentation available |
ConditionApprovalStatus | No documentation available |
ConditionAssignedMemberCritical | No documentation available |
ConditionAssignedMemberLiftability | No documentation available |
ConditionAtJobSite | No documentation available |
ConditionAutoMaterialSetback | No documentation available |
ConditionAutoMinusDimension | No documentation available |
ConditionBeamWebDoublers | No documentation available |
ConditionBoltCustomProperty | No documentation available |
ConditionBoltDiameter | No documentation available |
ConditionBoltDiameterChangedBySystem | No documentation available |
ConditionBoltField | No documentation available |
ConditionBoltFinish | No documentation available |
ConditionBoltGrip | No documentation available |
ConditionBoltLength | No documentation available |
ConditionBoltMaterial | No documentation available |
ConditionBoltPrimaryNutGrade | No documentation available |
ConditionBoltPrimaryNutType | No documentation available |
ConditionBoltPrimaryWasherUnderNut | No documentation available |
ConditionBoltSecondaryNutGrade | No documentation available |
ConditionBoltSecondaryNutType | No documentation available |
ConditionBoltSecondaryWasherUnderNut | No documentation available |
ConditionBoltTC | No documentation available |
ConditionBoltTertiaryWasherUnderNut | No documentation available |
ConditionBoltType | No documentation available |
ConditionBoolean | No documentation available |
ConditionBraceWithDifferentThickGussets | No documentation available |
ConditionCMUMaterial | No documentation available |
ConditionCMUTemplate | No documentation available |
ConditionComposite | No documentation available |
ConditionConcreteBeamTemplate | No documentation available |
ConditionConcreteColumnTemplate | No documentation available |
ConditionConcreteContinuousFootingTemplate | No documentation available |
ConditionConcreteCover | No documentation available |
ConditionConcreteGradeBeamTemplate | No documentation available |
ConditionConcreteMaterialFinish | No documentation available |
ConditionConcreteMaterialStrength | No documentation available |
ConditionConcreteMaterialVolumeFeet | No documentation available |
ConditionConcreteMaterialVolumeYards | No documentation available |
ConditionConcreteMemberDepth | No documentation available |
ConditionConcreteMemberFinish | No documentation available |
ConditionConcreteMemberHeight | No documentation available |
ConditionConcreteMemberLength | No documentation available |
ConditionConcreteMemberPerimeterLength | No documentation available |
ConditionConcreteMemberReference | No documentation available |
ConditionConcreteMemberRotation | No documentation available |
ConditionConcreteMemberStrength | No documentation available |
ConditionConcreteMemberSurfaceArea | No documentation available |
ConditionConcreteMemberThickness | No documentation available |
ConditionConcreteMemberTotalLength | No documentation available |
ConditionConcreteMemberTotalWallLength | No documentation available |
ConditionConcreteMemberVolumeFeet | No documentation available |
ConditionConcreteMemberVolumeYards | No documentation available |
ConditionConcreteMemberWidth | No documentation available |
ConditionConcreteTroughTemplate | No documentation available |
ConditionConnAutoStandard | No documentation available |
ConditionConnBelowMin | No documentation available |
ConditionConnBentPlate | No documentation available |
ConditionConnBoltedPlate | No documentation available |
ConditionConnChangedBySystem | No documentation available |
ConditionConnClipAngle | No documentation available |
ConditionConnColumnPlate | No documentation available |
ConditionConnEndPlate | No documentation available |
ConditionConnHorizontalBrace | No documentation available |
ConditionConnPlainEnd | No documentation available |
ConditionConnSeated | No documentation available |
ConditionConnShear | No documentation available |
ConditionConnSpecificUserDefined | No documentation available |
ConditionConnSplice | No documentation available |
ConditionConnUserDefined | No documentation available |
ConditionConnVerticalBrace | No documentation available |
ConditionDateRange | No documentation available |
ConditionDetailComplete | No documentation available |
ConditionDimequality | No documentation available |
ConditionDimRange | No documentation available |
ConditionEadFailedDesign | No documentation available |
ConditionEadGroup | No documentation available |
ConditionEadUnconnected | No documentation available |
ConditionErected | No documentation available |
ConditionExistingMember | No documentation available |
ConditionFabApproved | No documentation available |
ConditionFabCompleted | No documentation available |
ConditionFabProjected | No documentation available |
ConditionFabReleased | No documentation available |
ConditionFabScheduleMet | No documentation available |
ConditionFailedConn | No documentation available |
ConditionFinish | No documentation available |
ConditionFloatequality | No documentation available |
ConditionFloatRange | No documentation available |
ConditionFramesToModelComplete | No documentation available |
ConditionFrozenDetail | No documentation available |
ConditionFrozenPiecemark | No documentation available |
ConditionGraphicalConn | No documentation available |
ConditionGraphicAlteredMaterial | No documentation available |
ConditionGraphicAlteredMember | No documentation available |
ConditionHoldStatus | No documentation available |
ConditionHoleBlind | No documentation available |
ConditionHoleBlindDepth | No documentation available |
ConditionHoleBoltType | No documentation available |
ConditionHoleCBDepth | No documentation available |
ConditionHoleCBDia | No documentation available |
ConditionHoleCounterbore | No documentation available |
ConditionHoleCountersink | No documentation available |
ConditionHoleCountersinkAngle | No documentation available |
ConditionHoleCSDia | No documentation available |
ConditionHoleDiameter | No documentation available |
ConditionHoleLeftHandThreadDirection | No documentation available |
ConditionHoleMatchable | No documentation available |
ConditionHolePlugType | No documentation available |
ConditionHoleRightHandThreadDirection | No documentation available |
ConditionHoleSlotLength | No documentation available |
ConditionHoleSlotRotation | No documentation available |
ConditionHoleThreadDepth | No documentation available |
ConditionHoleThreads | No documentation available |
ConditionHoleThreadSeries | No documentation available |
ConditionHoleThreadSize | No documentation available |
ConditionHoleThreadsPerUnit | No documentation available |
ConditionHoleThreadThru | No documentation available |
ConditionHoleThru | No documentation available |
ConditionHoleType | No documentation available |
ConditionIndeterminateEnds | No documentation available |
ConditionInt | No documentation available |
ConditionIntegerList | No documentation available |
ConditionIntRange | No documentation available |
ConditionLoadsBeamMomentAuto | No documentation available |
ConditionLoadsBeamShearAuto | No documentation available |
ConditionLoadsColumnHorizontalShearAuto | No documentation available |
ConditionLoadsColumnLoadAuto | No documentation available |
ConditionLoadsColumnMomentAuto | No documentation available |
ConditionLoadsColumnSpliceUpliftAuto | No documentation available |
ConditionLoadsHorizontalBraceCompressionAuto | No documentation available |
ConditionLoadsHorizontalBraceTensionAuto | No documentation available |
ConditionLoadsVerticalBraceCompressionAuto | No documentation available |
ConditionLoadsVerticalBraceTensionAuto | No documentation available |
ConditionMaterialBent | No documentation available |
ConditionMaterialCustomProperty | No documentation available |
ConditionMaterialDescription | No documentation available |
ConditionMaterialDetailComplete | No documentation available |
ConditionMaterialFinish | No documentation available |
ConditionMaterialFit | No documentation available |
ConditionMaterialIsLLV | No documentation available |
ConditionMaterialIsToeIn | No documentation available |
ConditionMaterialNotes | No documentation available |
ConditionMaterialRoute1 | No documentation available |
ConditionMaterialRoute2 | No documentation available |
ConditionMaterialRoute3 | No documentation available |
ConditionMaterialRoute4 | No documentation available |
ConditionMaterialSectionSize | No documentation available |
ConditionMaterialSteelGrade | No documentation available |
ConditionMaterialStretched | No documentation available |
ConditionMaterialType | No documentation available |
ConditionMaterialUsageDescription | No documentation available |
ConditionMemberAnalyzed | No documentation available |
ConditionMemberCategory | No documentation available |
ConditionMemberCNCDownloaded | No documentation available |
ConditionMemberCustomProperty | No documentation available |
ConditionMemberDescription | No documentation available |
ConditionMemberGalvanized | No documentation available |
ConditionMemberHasFieldWeld | No documentation available |
ConditionMemberHasInputSetback | No documentation available |
ConditionMemberIncludedAngle | No documentation available |
ConditionMemberIsHSSLongSideVertical | No documentation available |
ConditionMemberLeftCompressionLoad | No documentation available |
ConditionMemberLeftConnectionSetback | No documentation available |
ConditionMemberLeftEndLocked | No documentation available |
ConditionMemberLeftEndMomentType | No documentation available |
ConditionMemberLeftFieldClear | No documentation available |
ConditionMemberLeftMaterialSetback | No documentation available |
ConditionMemberLeftMinusDim | No documentation available |
ConditionMemberLeftMomentLoad | No documentation available |
ConditionMemberLeftShearLoad | No documentation available |
ConditionMemberLeftStoryShear | No documentation available |
ConditionMemberLeftTensionLoad | No documentation available |
ConditionMemberLiftAssignment | No documentation available |
ConditionMemberMidordinate | No documentation available |
ConditionMemberNotes | No documentation available |
ConditionMemberNumber | No documentation available |
ConditionMemberPiecemark | No documentation available |
ConditionMemberRightCompressionLoad | No documentation available |
ConditionMemberRightConnectionSetback | No documentation available |
ConditionMemberRightEndLocked | No documentation available |
ConditionMemberRightEndMomentType | No documentation available |
ConditionMemberRightFieldClear | No documentation available |
ConditionMemberRightMaterialSetback | No documentation available |
ConditionMemberRightMinusDim | No documentation available |
ConditionMemberRightMomentLoad | No documentation available |
ConditionMemberRightShearLoad | No documentation available |
ConditionMemberRightStoryShear | No documentation available |
ConditionMemberRightTensionLoad | No documentation available |
ConditionMemberRoll | No documentation available |
ConditionMemberRollingRadius | No documentation available |
ConditionMemberRoute1 | No documentation available |
ConditionMemberRoute2 | No documentation available |
ConditionMemberRoute3 | No documentation available |
ConditionMemberRoute4 | No documentation available |
ConditionMemberSectionSize | No documentation available |
ConditionMemberSpiralOffset | No documentation available |
ConditionMemberSteelGrade | No documentation available |
ConditionMemberType | No documentation available |
ConditionModelComplete | No documentation available |
ConditionMtrlPlateThickness | No documentation available |
ConditionNeedsDetail | No documentation available |
ConditionNeedsPiecemark | No documentation available |
ConditionNeedsProcess | No documentation available |
ConditionNeedsSolids | No documentation available |
ConditionNonAISC_SingleShearPlateConn | No documentation available |
ConditionNonGraphicalMainMaterialWithUserHoles | No documentation available |
ConditionNonSquareCutEnds | No documentation available |
ConditionOnSheet | No documentation available |
ConditionPiecemark | No documentation available |
ConditionPlotted | No documentation available |
ConditionReasonForHold | No documentation available |
ConditionRebarCoating | No documentation available |
ConditionRebarDefinition | No documentation available |
ConditionRebarShape | No documentation available |
ConditionRebarSpecification | No documentation available |
ConditionReceivedFromApproval | No documentation available |
ConditionRevision | No documentation available |
ConditionSectionSize | No documentation available |
ConditionSequence | No documentation available |
ConditionShearLoadBelowMin | No documentation available |
ConditionShipActual | No documentation available |
ConditionShipProjected | No documentation available |
ConditionShipScheduleMet | No documentation available |
ConditionString | No documentation available |
ConditionSubmittedForApproval | No documentation available |
ConditionSwapMaterialMain | No documentation available |
ConditionSwapMemberEnds | No documentation available |
ConditionUserAssignedPiecemark | No documentation available |
ConditionUserCreatedMaterial | No documentation available |
ConditionUserDesignedConn | No documentation available |
ConditionUserLockedConn | No documentation available |
ConditionWeldContour | No documentation available |
ConditionWeldEffectiveThroat | No documentation available |
ConditionWeldField | No documentation available |
ConditionWeldFilletBackup | No documentation available |
ConditionWeldFinishSymbol | No documentation available |
ConditionWeldGrooveAngle | No documentation available |
ConditionWeldJoint | No documentation available |
ConditionWeldJointDesignation | No documentation available |
ConditionWeldLeftSetback | No documentation available |
ConditionWeldLeftTermination | No documentation available |
ConditionWeldLength | No documentation available |
ConditionWeldPenetration | No documentation available |
ConditionWeldPosition | No documentation available |
ConditionWeldPrequalifiedTailText | No documentation available |
ConditionWeldProcess | No documentation available |
ConditionWeldRightSetback | No documentation available |
ConditionWeldRightTermination | No documentation available |
ConditionWeldRootFace | No documentation available |
ConditionWeldRootOpen | No documentation available |
ConditionWeldShop | No documentation available |
ConditionWeldSize | No documentation available |
ConditionWeldSpacerBar | No documentation available |
ConditionWeldStitch | No documentation available |
ConditionWeldStitchLength | No documentation available |
ConditionWeldStitchSpacing | No documentation available |
ConditionWeldType | No documentation available |
ConditionZone | No documentation available |
Priority | No documentation available |
StatusDisplay | No documentation available |
sub_mtrl | |
AngleSubMaterialReference | No documentation available |
BeadedFlatSteelSubMaterialReference | No documentation available |
BentPlateLayoutSubMaterialReference | No documentation available |
BentPlateSubMaterialReference | No documentation available |
BoltSubMaterialReference | No documentation available |
ChannelSubMaterialReference | No documentation available |
CheckedPlateSubMaterialReference | No documentation available |
ClevisPinSubMaterialReference | No documentation available |
ClevisSubMaterialReference | No documentation available |
ColdFormedChannelSubMaterialReference | No documentation available |
ColdFormedZSubMaterialReference | No documentation available |
ConcreteCurvedLayoutSubMaterialReference | No documentation available |
ConcreteFlatLayoutSubMaterialReference | No documentation available |
CraneRailSubMaterialReference | No documentation available |
DeckSubMaterialReference | No documentation available |
ExpandedMetalPlateSubMaterialReference | No documentation available |
ExpPlateTreadSubMaterialReference | No documentation available |
FlatBarSubMaterialReference | No documentation available |
FlatPlateLayoutSubMaterialReference | No documentation available |
GenMaterialSubMaterialReference | No documentation available |
GratingSubMaterialReference | No documentation available |
GratingTreadSubMaterialReference | No documentation available |
JoistSubMaterialReference | No documentation available |
NutSubMaterialReference | No documentation available |
PipeSubMaterialReference | No documentation available |
PlateBoxSectionSubMaterialReference | No documentation available |
PlateGirderSubMaterialReference | No documentation available |
PlateSubMaterialReference | No documentation available |
RolledPlateSubMaterialReference | No documentation available |
RoundBarSubMaterialReference | No documentation available |
RoundPlateSubMaterialReference | No documentation available |
S_SectionSubMaterialReference | No documentation available |
ShearStudSubMaterialReference | No documentation available |
SquareBarSubMaterialReference | No documentation available |
StandardPartSubMaterialReference | No documentation available |
SteeSubMaterialReference | No documentation available |
SubMaterialIndexRange | No documentation available |
TubeSubMaterialReference | No documentation available |
TurnbuckleSubMaterialReference | No documentation available |
TurnedShellSubMaterialReference | No documentation available |
TurnedSolidSubMaterialReference | No documentation available |
WasherSubMaterialReference | No documentation available |
WideFlangeSubMaterialReference | No documentation available |
WteeSubMaterialReference | No documentation available |
utility | |
sds2.utility | |
SelectionDialog | |
shape | This module provides an interface to the material database (see job setup) |
error | No documentation available |
tabulated_properties | No documentation available |
shr_stud | |
error | No documentation available |
signal_repeater | |
SignalRepeater | No documentation available |
SortedComponentUIHelper | |
SortedComponentUIHelper | A mixin class to help simple components adapt to member edit conventions |
Spacing | |
SpacingList | List of floating point values representing spacings |
sqr_bar | |
error | No documentation available |
StairTread | |
MemberStairTread | No documentation available |
PlateTreadShape | No documentation available |
StairTreadId | No documentation available |
TreadType | No documentation available |
StandAloneGadgetScreen | |
CancelException | No documentation available |
StandAloneGadgetScreen | A class to manage a Gadget screen object for selection edit |
StandardDetail | |
GlobalStandard | No documentation available |
JobStandard | No documentation available |
StandardDetailType | No documentation available |
StateAccessor | |
DummyBase | No documentation available |
StateAccessor | This is a helper class for custom members |
Status | |
Storage | |
StorageException | No documentation available |
StoredObject | |
StoredObject | No documentation available |
Tkinter | Wrapper functions for Tcl/Tk |
BaseWidget | Internal class |
BitmapImage | Widget which can display a bitmap |
BooleanVar | Value holder for boolean variables |
Button | Button widget |
CallWrapper | Internal class |
Canvas | Canvas widget to display graphical elements like lines or text |
Checkbutton | Checkbutton widget which is either in on- or off-state |
DoubleVar | Value holder for float variables |
Entry | Entry widget which allows to display simple text |
Event | Container for the properties of an event |
Frame | Frame widget which may contain other widgets and can have a 3D border |
Grid | Geometry manager Grid |
Image | Base class for images |
IntVar | Value holder for integer variables |
Label | Label widget which can display text and bitmaps |
LabelFrame | Labelframe widget |
Listbox | Listbox widget which can display a list of strings |
Menu | Menu widget which allows to display menu bars, pull-down menus and pop-up menus |
Menubutton | Menubutton widget, obsolete since Tk8.0 |
Message | Message widget to display multiline text |
Misc | Internal class |
OptionMenu | OptionMenu which allows the user to select a value from a menu |
Pack | Geometry manager Pack |
PanedWindow | Panedwindow widget |
PhotoImage | Widget which can display colored images in GIF, PPM/PGM format |
Place | Geometry manager Place |
Radiobutton | Radiobutton widget which shows only one of several buttons in on-state |
Scale | Scale widget which can display a numerical scale |
Scrollbar | Scrollbar widget which displays a slider at a certain position |
Spinbox | Spinbox widget |
StringVar | Value holder for strings variables |
Studbutton | No documentation available |
Text | Text widget which can display text in various forms |
Tk | Toplevel widget of Tk which represents mostly the main window of an application |
Toplevel | Toplevel widget, e.g |
Tributton | No documentation available |
Variable | Class to define value holders for e.g |
Widget | Internal class |
Wm | Provides functions for the communication with the window manager |
XView | Mix-in class for querying and changing the horizontal position of a widget's window |
YView | Mix-in class for querying and changing the vertical position of a widget's window |
tokenized | |
tool_selection | |
tools | |
Tools | |
Transform3D | |
Transform3D | No documentation available |
transmittal | |
transmittal_full_status | No documentation available |
turnbuckle | |
error | No documentation available |
u3d_export | |
Maker | No documentation available |
u3de | |
Block | No documentation available |
CachedSerialization | No documentation available |
Canned | No documentation available |
Clod | No documentation available |
ClodMeshBaseContinuation | No documentation available |
ClodMeshDeclaration | No documentation available |
Corner | No documentation available |
Face | No documentation available |
LightNode | No documentation available |
LightResource | No documentation available |
LitTextureShader | No documentation available |
Material | No documentation available |
MetaData | No documentation available |
Model | No documentation available |
NewPriority | No documentation available |
Node | No documentation available |
Shading | No documentation available |
ViewNode | No documentation available |
ViewResource | No documentation available |
UnreadableComponentProxy | |
MemberEditUI | No documentation available |
UnreadableComponentProxy | No documentation available |
UpdateDescription | |
UserDefinedConnection | |
UserDefinedConnection | No documentation available |
Uuid | |
Uuid | No documentation available |
version | |
error | No documentation available |
view | |
error | No documentation available |
MemberProjectionViewUse | No documentation available |
MemberViewTuple | MemberViewTuple(global_to_view, max_clip_in_view_coords, min_clip_in_view_coords, type, cut_from, cut_from_type, scale, offset, use, projection_use, is_user, excludes_clip_region, is_projection_view, is_forced) |
MemberViewType | No documentation available |
MemberViewUse | No documentation available |
WebBrowser | |
weld_add | |
error | No documentation available |