No documentation available.
More...
Data and other attributes defined here: |
def | __init__ |
Data and other attributes inherited from Boost.Python.instance: |
def | __new__ |
Additional Inherited Members |
Detailed Description
No documentation available.
Method resolution order
BeadedFlatSteelSubMaterialReference
GenMaterialSubMaterialReference
SubMaterialReference
Boost.Python.instance
builtin.object
Constructor & Destructor Documentation
def sds2.sub_mtrl.BeadedFlatSteelSubMaterialReference.__init__ |
( |
|
args | ) |
|
Member Function Documentation
def sds2.sub_mtrl.BeadedFlatSteelSubMaterialReference.__dict__ |
( |
|
args | ) |
|
def sds2.sub_mtrl.BeadedFlatSteelSubMaterialReference.__new__ |
( |
|
args | ) |
|
def sds2.sub_mtrl.BeadedFlatSteelSubMaterialReference.__reduce__ |
( |
|
args | ) |
|
def sds2.sub_mtrl.BeadedFlatSteelSubMaterialReference.__weakref__ |
( |
|
args | ) |
|
def sds2.sub_mtrl.BeadedFlatSteelSubMaterialReference.assm_mark |
( |
|
args | ) |
|
def sds2.sub_mtrl.BeadedFlatSteelSubMaterialReference.bar_stock |
( |
|
args | ) |
|
def sds2.sub_mtrl.BeadedFlatSteelSubMaterialReference.bend_angle |
( |
|
args | ) |
|
def sds2.sub_mtrl.BeadedFlatSteelSubMaterialReference.bend_rad |
( |
|
args | ) |
|
def sds2.sub_mtrl.BeadedFlatSteelSubMaterialReference.BuiltinMaterial |
( |
|
arg1 | ) |
|
- Returns
- Instance of type object
Return a BuiltinMaterial with the same properties as the
SubMaterialReference except with the color set to the job's
default color for the material type
C++ signature :
Alloy::Pointer::Pointer<MaterialBase> BuiltinMaterial(Entry<17>)
Return a BuiltinMaterial with the same properties as the
SubMaterialReference except with the option to override the color
C++ signature :
Alloy::Pointer::Pointer<MaterialBase> BuiltinMaterial(Entry<17>,bool)
- Note
- Additional signature: BuiltinMaterial( (SubMaterialReference)self, (bool)set_default_color) -> object
Reimplemented from sds2.sub_mtrl.GenMaterialSubMaterialReference.
def sds2.sub_mtrl.BeadedFlatSteelSubMaterialReference.camber |
( |
|
args | ) |
|
def sds2.sub_mtrl.BeadedFlatSteelSubMaterialReference.checkered |
( |
|
args | ) |
|
def sds2.sub_mtrl.BeadedFlatSteelSubMaterialReference.cnc_dld |
( |
|
args | ) |
|
def sds2.sub_mtrl.BeadedFlatSteelSubMaterialReference.control_file_entry_description |
( |
|
args | ) |
|
def sds2.sub_mtrl.BeadedFlatSteelSubMaterialReference.dim_weight |
( |
|
args | ) |
|
def sds2.sub_mtrl.BeadedFlatSteelSubMaterialReference.do_not_calc_poly_weight |
( |
|
args | ) |
|
def sds2.sub_mtrl.BeadedFlatSteelSubMaterialReference.do_not_scribe |
( |
|
args | ) |
|
def sds2.sub_mtrl.BeadedFlatSteelSubMaterialReference.dtl_quant |
( |
|
args | ) |
|
def sds2.sub_mtrl.BeadedFlatSteelSubMaterialReference.dtl_rev_level |
( |
|
args | ) |
|
def sds2.sub_mtrl.BeadedFlatSteelSubMaterialReference.dummy |
( |
|
args | ) |
|
def sds2.sub_mtrl.BeadedFlatSteelSubMaterialReference.effective_index |
( |
|
args | ) |
|
def sds2.sub_mtrl.BeadedFlatSteelSubMaterialReference.end_prep |
( |
|
args | ) |
|
def sds2.sub_mtrl.BeadedFlatSteelSubMaterialReference.existing |
( |
|
args | ) |
|
def sds2.sub_mtrl.BeadedFlatSteelSubMaterialReference.f_weld |
( |
|
args | ) |
|
def sds2.sub_mtrl.BeadedFlatSteelSubMaterialReference.fitted |
( |
|
args | ) |
|
def sds2.sub_mtrl.BeadedFlatSteelSubMaterialReference.flg_cut |
( |
|
args | ) |
|
def sds2.sub_mtrl.BeadedFlatSteelSubMaterialReference.flip |
( |
|
args | ) |
|
def sds2.sub_mtrl.BeadedFlatSteelSubMaterialReference.graph_comp_date |
( |
|
args | ) |
|
def sds2.sub_mtrl.BeadedFlatSteelSubMaterialReference.hash |
( |
|
args | ) |
|
def sds2.sub_mtrl.BeadedFlatSteelSubMaterialReference.imp_desc |
( |
|
args | ) |
|
def sds2.sub_mtrl.BeadedFlatSteelSubMaterialReference.info_type |
( |
|
args | ) |
|
def sds2.sub_mtrl.BeadedFlatSteelSubMaterialReference.last_quant |
( |
|
args | ) |
|
def sds2.sub_mtrl.BeadedFlatSteelSubMaterialReference.last_rev_level |
( |
|
args | ) |
|
def sds2.sub_mtrl.BeadedFlatSteelSubMaterialReference.left_btm_op_dim1 |
( |
|
args | ) |
|
def sds2.sub_mtrl.BeadedFlatSteelSubMaterialReference.left_btm_op_dim2 |
( |
|
args | ) |
|
def sds2.sub_mtrl.BeadedFlatSteelSubMaterialReference.left_btm_op_dim3 |
( |
|
args | ) |
|
def sds2.sub_mtrl.BeadedFlatSteelSubMaterialReference.left_btm_op_dim4 |
( |
|
args | ) |
|
def sds2.sub_mtrl.BeadedFlatSteelSubMaterialReference.left_btm_op_dim5 |
( |
|
args | ) |
|
def sds2.sub_mtrl.BeadedFlatSteelSubMaterialReference.left_btm_op_dim6 |
( |
|
args | ) |
|
def sds2.sub_mtrl.BeadedFlatSteelSubMaterialReference.left_btm_op_dim7 |
( |
|
args | ) |
|
def sds2.sub_mtrl.BeadedFlatSteelSubMaterialReference.left_btm_op_dim8 |
( |
|
args | ) |
|
def sds2.sub_mtrl.BeadedFlatSteelSubMaterialReference.left_btm_op_type |
( |
|
args | ) |
|
def sds2.sub_mtrl.BeadedFlatSteelSubMaterialReference.left_top_op_dim1 |
( |
|
args | ) |
|
def sds2.sub_mtrl.BeadedFlatSteelSubMaterialReference.left_top_op_dim2 |
( |
|
args | ) |
|
def sds2.sub_mtrl.BeadedFlatSteelSubMaterialReference.left_top_op_dim3 |
( |
|
args | ) |
|
def sds2.sub_mtrl.BeadedFlatSteelSubMaterialReference.left_top_op_dim4 |
( |
|
args | ) |
|
def sds2.sub_mtrl.BeadedFlatSteelSubMaterialReference.left_top_op_dim5 |
( |
|
args | ) |
|
def sds2.sub_mtrl.BeadedFlatSteelSubMaterialReference.left_top_op_dim6 |
( |
|
args | ) |
|
def sds2.sub_mtrl.BeadedFlatSteelSubMaterialReference.left_top_op_dim7 |
( |
|
args | ) |
|
def sds2.sub_mtrl.BeadedFlatSteelSubMaterialReference.left_top_op_dim8 |
( |
|
args | ) |
|
def sds2.sub_mtrl.BeadedFlatSteelSubMaterialReference.left_top_op_type |
( |
|
args | ) |
|
def sds2.sub_mtrl.BeadedFlatSteelSubMaterialReference.leg |
( |
|
args | ) |
|
def sds2.sub_mtrl.BeadedFlatSteelSubMaterialReference.length |
( |
|
args | ) |
|
def sds2.sub_mtrl.BeadedFlatSteelSubMaterialReference.llv |
( |
|
args | ) |
|
def sds2.sub_mtrl.BeadedFlatSteelSubMaterialReference.met_desc |
( |
|
args | ) |
|
def sds2.sub_mtrl.BeadedFlatSteelSubMaterialReference.mtrl_idx |
( |
|
args | ) |
|
def sds2.sub_mtrl.BeadedFlatSteelSubMaterialReference.mtrl_stbk |
( |
|
args | ) |
|
def sds2.sub_mtrl.BeadedFlatSteelSubMaterialReference.mtrl_type |
( |
|
args | ) |
|
def sds2.sub_mtrl.BeadedFlatSteelSubMaterialReference.mtrl_use |
( |
|
args | ) |
|
def sds2.sub_mtrl.BeadedFlatSteelSubMaterialReference.needs_detail |
( |
|
args | ) |
|
def sds2.sub_mtrl.BeadedFlatSteelSubMaterialReference.on_sheet |
( |
|
args | ) |
|
def sds2.sub_mtrl.BeadedFlatSteelSubMaterialReference.origin |
( |
|
args | ) |
|
def sds2.sub_mtrl.BeadedFlatSteelSubMaterialReference.osl |
( |
|
args | ) |
|
def sds2.sub_mtrl.BeadedFlatSteelSubMaterialReference.part_length |
( |
|
args | ) |
|
def sds2.sub_mtrl.BeadedFlatSteelSubMaterialReference.pcmk_hash |
( |
|
args | ) |
|
def sds2.sub_mtrl.BeadedFlatSteelSubMaterialReference.pl_area |
( |
|
args | ) |
|
def sds2.sub_mtrl.BeadedFlatSteelSubMaterialReference.public_pcmk |
( |
|
args | ) |
|
def sds2.sub_mtrl.BeadedFlatSteelSubMaterialReference.quant |
( |
|
args | ) |
|
def sds2.sub_mtrl.BeadedFlatSteelSubMaterialReference.rad |
( |
|
args | ) |
|
def sds2.sub_mtrl.BeadedFlatSteelSubMaterialReference.reent_hole_dist |
( |
|
args | ) |
|
def sds2.sub_mtrl.BeadedFlatSteelSubMaterialReference.ref_x |
( |
|
args | ) |
|
def sds2.sub_mtrl.BeadedFlatSteelSubMaterialReference.ref_y |
( |
|
args | ) |
|
def sds2.sub_mtrl.BeadedFlatSteelSubMaterialReference.rev_date |
( |
|
args | ) |
|
def sds2.sub_mtrl.BeadedFlatSteelSubMaterialReference.rev_level |
( |
|
args | ) |
|
def sds2.sub_mtrl.BeadedFlatSteelSubMaterialReference.right_btm_op_dim1 |
( |
|
args | ) |
|
def sds2.sub_mtrl.BeadedFlatSteelSubMaterialReference.right_btm_op_dim2 |
( |
|
args | ) |
|
def sds2.sub_mtrl.BeadedFlatSteelSubMaterialReference.right_btm_op_dim3 |
( |
|
args | ) |
|
def sds2.sub_mtrl.BeadedFlatSteelSubMaterialReference.right_btm_op_dim4 |
( |
|
args | ) |
|
def sds2.sub_mtrl.BeadedFlatSteelSubMaterialReference.right_btm_op_dim5 |
( |
|
args | ) |
|
def sds2.sub_mtrl.BeadedFlatSteelSubMaterialReference.right_btm_op_dim6 |
( |
|
args | ) |
|
def sds2.sub_mtrl.BeadedFlatSteelSubMaterialReference.right_btm_op_dim7 |
( |
|
args | ) |
|
def sds2.sub_mtrl.BeadedFlatSteelSubMaterialReference.right_btm_op_dim8 |
( |
|
args | ) |
|
def sds2.sub_mtrl.BeadedFlatSteelSubMaterialReference.right_btm_op_type |
( |
|
args | ) |
|
def sds2.sub_mtrl.BeadedFlatSteelSubMaterialReference.right_top_op_dim1 |
( |
|
args | ) |
|
def sds2.sub_mtrl.BeadedFlatSteelSubMaterialReference.right_top_op_dim2 |
( |
|
args | ) |
|
def sds2.sub_mtrl.BeadedFlatSteelSubMaterialReference.right_top_op_dim3 |
( |
|
args | ) |
|
def sds2.sub_mtrl.BeadedFlatSteelSubMaterialReference.right_top_op_dim4 |
( |
|
args | ) |
|
def sds2.sub_mtrl.BeadedFlatSteelSubMaterialReference.right_top_op_dim5 |
( |
|
args | ) |
|
def sds2.sub_mtrl.BeadedFlatSteelSubMaterialReference.right_top_op_dim6 |
( |
|
args | ) |
|
def sds2.sub_mtrl.BeadedFlatSteelSubMaterialReference.right_top_op_dim7 |
( |
|
args | ) |
|
def sds2.sub_mtrl.BeadedFlatSteelSubMaterialReference.right_top_op_dim8 |
( |
|
args | ) |
|
def sds2.sub_mtrl.BeadedFlatSteelSubMaterialReference.right_top_op_type |
( |
|
args | ) |
|
def sds2.sub_mtrl.BeadedFlatSteelSubMaterialReference.roll_type |
( |
|
args | ) |
|
def sds2.sub_mtrl.BeadedFlatSteelSubMaterialReference.rolled_mtrl_ref_pt |
( |
|
args | ) |
|
def sds2.sub_mtrl.BeadedFlatSteelSubMaterialReference.rolled_offset |
( |
|
args | ) |
|
def sds2.sub_mtrl.BeadedFlatSteelSubMaterialReference.sec_hash |
( |
|
args | ) |
|
def sds2.sub_mtrl.BeadedFlatSteelSubMaterialReference.srfc_area |
( |
|
args | ) |
|
def sds2.sub_mtrl.BeadedFlatSteelSubMaterialReference.stair_mtrl_use |
( |
|
args | ) |
|
def sds2.sub_mtrl.BeadedFlatSteelSubMaterialReference.std_mark |
( |
|
args | ) |
|
def sds2.sub_mtrl.BeadedFlatSteelSubMaterialReference.stretched |
( |
|
args | ) |
|
def sds2.sub_mtrl.BeadedFlatSteelSubMaterialReference.sub_mtrl_idx |
( |
|
args | ) |
|
def sds2.sub_mtrl.BeadedFlatSteelSubMaterialReference.taper_rad |
( |
|
args | ) |
|
def sds2.sub_mtrl.BeadedFlatSteelSubMaterialReference.thick |
( |
|
args | ) |
|
def sds2.sub_mtrl.BeadedFlatSteelSubMaterialReference.thread_length |
( |
|
args | ) |
|
def sds2.sub_mtrl.BeadedFlatSteelSubMaterialReference.thread_type |
( |
|
args | ) |
|
def sds2.sub_mtrl.BeadedFlatSteelSubMaterialReference.toe_io |
( |
|
args | ) |
|
def sds2.sub_mtrl.BeadedFlatSteelSubMaterialReference.trans_width |
( |
|
args | ) |
|
def sds2.sub_mtrl.BeadedFlatSteelSubMaterialReference.twist |
( |
|
args | ) |
|
def sds2.sub_mtrl.BeadedFlatSteelSubMaterialReference.usage |
( |
|
args | ) |
|
def sds2.sub_mtrl.BeadedFlatSteelSubMaterialReference.user_description |
( |
|
args | ) |
|
def sds2.sub_mtrl.BeadedFlatSteelSubMaterialReference.web_cut |
( |
|
args | ) |
|
def sds2.sub_mtrl.BeadedFlatSteelSubMaterialReference.web_stbk |
( |
|
args | ) |
|
def sds2.sub_mtrl.BeadedFlatSteelSubMaterialReference.weight |
( |
|
args | ) |
|
def sds2.sub_mtrl.BeadedFlatSteelSubMaterialReference.width |
( |
|
args | ) |
|
def sds2.sub_mtrl.BeadedFlatSteelSubMaterialReference.wkpt_slope |
( |
|
args | ) |
|