No documentation available.
More...
Data and other attributes defined here: |
def | __init__ |
Data and other attributes inherited from Boost.Python.instance: |
def | __new__ |
Additional Inherited Members |
Detailed Description
No documentation available.
Method resolution order
BentPlateLayoutSubMaterialReference
GenMaterialSubMaterialReference
SubMaterialReference
Boost.Python.instance
builtin.object
Constructor & Destructor Documentation
def sds2.sub_mtrl.BentPlateLayoutSubMaterialReference.__init__ |
( |
|
args | ) |
|
Member Function Documentation
def sds2.sub_mtrl.BentPlateLayoutSubMaterialReference.__dict__ |
( |
|
args | ) |
|
def sds2.sub_mtrl.BentPlateLayoutSubMaterialReference.__new__ |
( |
|
args | ) |
|
def sds2.sub_mtrl.BentPlateLayoutSubMaterialReference.__reduce__ |
( |
|
args | ) |
|
def sds2.sub_mtrl.BentPlateLayoutSubMaterialReference.__weakref__ |
( |
|
args | ) |
|
def sds2.sub_mtrl.BentPlateLayoutSubMaterialReference.assm_mark |
( |
|
args | ) |
|
def sds2.sub_mtrl.BentPlateLayoutSubMaterialReference.bar_stock |
( |
|
args | ) |
|
def sds2.sub_mtrl.BentPlateLayoutSubMaterialReference.bend_angle |
( |
|
args | ) |
|
def sds2.sub_mtrl.BentPlateLayoutSubMaterialReference.bend_rad |
( |
|
args | ) |
|
def sds2.sub_mtrl.BentPlateLayoutSubMaterialReference.BuiltinMaterial |
( |
|
arg1 | ) |
|
- Returns
- Instance of type object
Return a BuiltinMaterial with the same properties as the
SubMaterialReference except with the color set to the job's
default color for the material type
C++ signature :
Alloy::Pointer::Pointer<MaterialBase> BuiltinMaterial(Entry<17>)
Return a BuiltinMaterial with the same properties as the
SubMaterialReference except with the option to override the color
C++ signature :
Alloy::Pointer::Pointer<MaterialBase> BuiltinMaterial(Entry<17>,bool)
- Note
- Additional signature: BuiltinMaterial( (SubMaterialReference)self, (bool)set_default_color) -> object
Reimplemented from sds2.sub_mtrl.GenMaterialSubMaterialReference.
def sds2.sub_mtrl.BentPlateLayoutSubMaterialReference.camber |
( |
|
args | ) |
|
def sds2.sub_mtrl.BentPlateLayoutSubMaterialReference.checkered |
( |
|
args | ) |
|
def sds2.sub_mtrl.BentPlateLayoutSubMaterialReference.cnc_dld |
( |
|
args | ) |
|
def sds2.sub_mtrl.BentPlateLayoutSubMaterialReference.control_file_entry_description |
( |
|
args | ) |
|
def sds2.sub_mtrl.BentPlateLayoutSubMaterialReference.dim_weight |
( |
|
args | ) |
|
def sds2.sub_mtrl.BentPlateLayoutSubMaterialReference.do_not_calc_poly_weight |
( |
|
args | ) |
|
def sds2.sub_mtrl.BentPlateLayoutSubMaterialReference.do_not_scribe |
( |
|
args | ) |
|
def sds2.sub_mtrl.BentPlateLayoutSubMaterialReference.dtl_quant |
( |
|
args | ) |
|
def sds2.sub_mtrl.BentPlateLayoutSubMaterialReference.dtl_rev_level |
( |
|
args | ) |
|
def sds2.sub_mtrl.BentPlateLayoutSubMaterialReference.dummy |
( |
|
args | ) |
|
def sds2.sub_mtrl.BentPlateLayoutSubMaterialReference.effective_index |
( |
|
args | ) |
|
def sds2.sub_mtrl.BentPlateLayoutSubMaterialReference.end_prep |
( |
|
args | ) |
|
def sds2.sub_mtrl.BentPlateLayoutSubMaterialReference.existing |
( |
|
args | ) |
|
def sds2.sub_mtrl.BentPlateLayoutSubMaterialReference.f_weld |
( |
|
args | ) |
|
def sds2.sub_mtrl.BentPlateLayoutSubMaterialReference.fitted |
( |
|
args | ) |
|
def sds2.sub_mtrl.BentPlateLayoutSubMaterialReference.flg_cut |
( |
|
args | ) |
|
def sds2.sub_mtrl.BentPlateLayoutSubMaterialReference.flip |
( |
|
args | ) |
|
def sds2.sub_mtrl.BentPlateLayoutSubMaterialReference.graph_comp_date |
( |
|
args | ) |
|
def sds2.sub_mtrl.BentPlateLayoutSubMaterialReference.hash |
( |
|
args | ) |
|
def sds2.sub_mtrl.BentPlateLayoutSubMaterialReference.imp_desc |
( |
|
args | ) |
|
def sds2.sub_mtrl.BentPlateLayoutSubMaterialReference.info_type |
( |
|
args | ) |
|
def sds2.sub_mtrl.BentPlateLayoutSubMaterialReference.last_quant |
( |
|
args | ) |
|
def sds2.sub_mtrl.BentPlateLayoutSubMaterialReference.last_rev_level |
( |
|
args | ) |
|
def sds2.sub_mtrl.BentPlateLayoutSubMaterialReference.left_btm_op_dim1 |
( |
|
args | ) |
|
def sds2.sub_mtrl.BentPlateLayoutSubMaterialReference.left_btm_op_dim2 |
( |
|
args | ) |
|
def sds2.sub_mtrl.BentPlateLayoutSubMaterialReference.left_btm_op_dim3 |
( |
|
args | ) |
|
def sds2.sub_mtrl.BentPlateLayoutSubMaterialReference.left_btm_op_dim4 |
( |
|
args | ) |
|
def sds2.sub_mtrl.BentPlateLayoutSubMaterialReference.left_btm_op_dim5 |
( |
|
args | ) |
|
def sds2.sub_mtrl.BentPlateLayoutSubMaterialReference.left_btm_op_dim6 |
( |
|
args | ) |
|
def sds2.sub_mtrl.BentPlateLayoutSubMaterialReference.left_btm_op_dim7 |
( |
|
args | ) |
|
def sds2.sub_mtrl.BentPlateLayoutSubMaterialReference.left_btm_op_dim8 |
( |
|
args | ) |
|
def sds2.sub_mtrl.BentPlateLayoutSubMaterialReference.left_btm_op_type |
( |
|
args | ) |
|
def sds2.sub_mtrl.BentPlateLayoutSubMaterialReference.left_top_op_dim1 |
( |
|
args | ) |
|
def sds2.sub_mtrl.BentPlateLayoutSubMaterialReference.left_top_op_dim2 |
( |
|
args | ) |
|
def sds2.sub_mtrl.BentPlateLayoutSubMaterialReference.left_top_op_dim3 |
( |
|
args | ) |
|
def sds2.sub_mtrl.BentPlateLayoutSubMaterialReference.left_top_op_dim4 |
( |
|
args | ) |
|
def sds2.sub_mtrl.BentPlateLayoutSubMaterialReference.left_top_op_dim5 |
( |
|
args | ) |
|
def sds2.sub_mtrl.BentPlateLayoutSubMaterialReference.left_top_op_dim6 |
( |
|
args | ) |
|
def sds2.sub_mtrl.BentPlateLayoutSubMaterialReference.left_top_op_dim7 |
( |
|
args | ) |
|
def sds2.sub_mtrl.BentPlateLayoutSubMaterialReference.left_top_op_dim8 |
( |
|
args | ) |
|
def sds2.sub_mtrl.BentPlateLayoutSubMaterialReference.left_top_op_type |
( |
|
args | ) |
|
def sds2.sub_mtrl.BentPlateLayoutSubMaterialReference.leg |
( |
|
args | ) |
|
def sds2.sub_mtrl.BentPlateLayoutSubMaterialReference.length |
( |
|
args | ) |
|
def sds2.sub_mtrl.BentPlateLayoutSubMaterialReference.llv |
( |
|
args | ) |
|
def sds2.sub_mtrl.BentPlateLayoutSubMaterialReference.met_desc |
( |
|
args | ) |
|
def sds2.sub_mtrl.BentPlateLayoutSubMaterialReference.mtrl_idx |
( |
|
args | ) |
|
def sds2.sub_mtrl.BentPlateLayoutSubMaterialReference.mtrl_stbk |
( |
|
args | ) |
|
def sds2.sub_mtrl.BentPlateLayoutSubMaterialReference.mtrl_type |
( |
|
args | ) |
|
def sds2.sub_mtrl.BentPlateLayoutSubMaterialReference.mtrl_use |
( |
|
args | ) |
|
def sds2.sub_mtrl.BentPlateLayoutSubMaterialReference.needs_detail |
( |
|
args | ) |
|
def sds2.sub_mtrl.BentPlateLayoutSubMaterialReference.on_sheet |
( |
|
args | ) |
|
def sds2.sub_mtrl.BentPlateLayoutSubMaterialReference.origin |
( |
|
args | ) |
|
def sds2.sub_mtrl.BentPlateLayoutSubMaterialReference.osl |
( |
|
args | ) |
|
def sds2.sub_mtrl.BentPlateLayoutSubMaterialReference.part_length |
( |
|
args | ) |
|
def sds2.sub_mtrl.BentPlateLayoutSubMaterialReference.pcmk_hash |
( |
|
args | ) |
|
def sds2.sub_mtrl.BentPlateLayoutSubMaterialReference.pl_area |
( |
|
args | ) |
|
def sds2.sub_mtrl.BentPlateLayoutSubMaterialReference.public_pcmk |
( |
|
args | ) |
|
def sds2.sub_mtrl.BentPlateLayoutSubMaterialReference.quant |
( |
|
args | ) |
|
def sds2.sub_mtrl.BentPlateLayoutSubMaterialReference.rad |
( |
|
args | ) |
|
def sds2.sub_mtrl.BentPlateLayoutSubMaterialReference.reent_hole_dist |
( |
|
args | ) |
|
def sds2.sub_mtrl.BentPlateLayoutSubMaterialReference.ref_x |
( |
|
args | ) |
|
def sds2.sub_mtrl.BentPlateLayoutSubMaterialReference.ref_y |
( |
|
args | ) |
|
def sds2.sub_mtrl.BentPlateLayoutSubMaterialReference.rev_date |
( |
|
args | ) |
|
def sds2.sub_mtrl.BentPlateLayoutSubMaterialReference.rev_level |
( |
|
args | ) |
|
def sds2.sub_mtrl.BentPlateLayoutSubMaterialReference.right_btm_op_dim1 |
( |
|
args | ) |
|
def sds2.sub_mtrl.BentPlateLayoutSubMaterialReference.right_btm_op_dim2 |
( |
|
args | ) |
|
def sds2.sub_mtrl.BentPlateLayoutSubMaterialReference.right_btm_op_dim3 |
( |
|
args | ) |
|
def sds2.sub_mtrl.BentPlateLayoutSubMaterialReference.right_btm_op_dim4 |
( |
|
args | ) |
|
def sds2.sub_mtrl.BentPlateLayoutSubMaterialReference.right_btm_op_dim5 |
( |
|
args | ) |
|
def sds2.sub_mtrl.BentPlateLayoutSubMaterialReference.right_btm_op_dim6 |
( |
|
args | ) |
|
def sds2.sub_mtrl.BentPlateLayoutSubMaterialReference.right_btm_op_dim7 |
( |
|
args | ) |
|
def sds2.sub_mtrl.BentPlateLayoutSubMaterialReference.right_btm_op_dim8 |
( |
|
args | ) |
|
def sds2.sub_mtrl.BentPlateLayoutSubMaterialReference.right_btm_op_type |
( |
|
args | ) |
|
def sds2.sub_mtrl.BentPlateLayoutSubMaterialReference.right_top_op_dim1 |
( |
|
args | ) |
|
def sds2.sub_mtrl.BentPlateLayoutSubMaterialReference.right_top_op_dim2 |
( |
|
args | ) |
|
def sds2.sub_mtrl.BentPlateLayoutSubMaterialReference.right_top_op_dim3 |
( |
|
args | ) |
|
def sds2.sub_mtrl.BentPlateLayoutSubMaterialReference.right_top_op_dim4 |
( |
|
args | ) |
|
def sds2.sub_mtrl.BentPlateLayoutSubMaterialReference.right_top_op_dim5 |
( |
|
args | ) |
|
def sds2.sub_mtrl.BentPlateLayoutSubMaterialReference.right_top_op_dim6 |
( |
|
args | ) |
|
def sds2.sub_mtrl.BentPlateLayoutSubMaterialReference.right_top_op_dim7 |
( |
|
args | ) |
|
def sds2.sub_mtrl.BentPlateLayoutSubMaterialReference.right_top_op_dim8 |
( |
|
args | ) |
|
def sds2.sub_mtrl.BentPlateLayoutSubMaterialReference.right_top_op_type |
( |
|
args | ) |
|
def sds2.sub_mtrl.BentPlateLayoutSubMaterialReference.roll_type |
( |
|
args | ) |
|
def sds2.sub_mtrl.BentPlateLayoutSubMaterialReference.rolled_mtrl_ref_pt |
( |
|
args | ) |
|
def sds2.sub_mtrl.BentPlateLayoutSubMaterialReference.rolled_offset |
( |
|
args | ) |
|
def sds2.sub_mtrl.BentPlateLayoutSubMaterialReference.sec_hash |
( |
|
args | ) |
|
def sds2.sub_mtrl.BentPlateLayoutSubMaterialReference.srfc_area |
( |
|
args | ) |
|
def sds2.sub_mtrl.BentPlateLayoutSubMaterialReference.stair_mtrl_use |
( |
|
args | ) |
|
def sds2.sub_mtrl.BentPlateLayoutSubMaterialReference.std_mark |
( |
|
args | ) |
|
def sds2.sub_mtrl.BentPlateLayoutSubMaterialReference.stretched |
( |
|
args | ) |
|
def sds2.sub_mtrl.BentPlateLayoutSubMaterialReference.sub_mtrl_idx |
( |
|
args | ) |
|
def sds2.sub_mtrl.BentPlateLayoutSubMaterialReference.taper_rad |
( |
|
args | ) |
|
def sds2.sub_mtrl.BentPlateLayoutSubMaterialReference.thick |
( |
|
args | ) |
|
def sds2.sub_mtrl.BentPlateLayoutSubMaterialReference.thread_length |
( |
|
args | ) |
|
def sds2.sub_mtrl.BentPlateLayoutSubMaterialReference.thread_type |
( |
|
args | ) |
|
def sds2.sub_mtrl.BentPlateLayoutSubMaterialReference.toe_io |
( |
|
args | ) |
|
def sds2.sub_mtrl.BentPlateLayoutSubMaterialReference.trans_width |
( |
|
args | ) |
|
def sds2.sub_mtrl.BentPlateLayoutSubMaterialReference.twist |
( |
|
args | ) |
|
def sds2.sub_mtrl.BentPlateLayoutSubMaterialReference.usage |
( |
|
args | ) |
|
def sds2.sub_mtrl.BentPlateLayoutSubMaterialReference.user_description |
( |
|
args | ) |
|
def sds2.sub_mtrl.BentPlateLayoutSubMaterialReference.web_cut |
( |
|
args | ) |
|
def sds2.sub_mtrl.BentPlateLayoutSubMaterialReference.web_stbk |
( |
|
args | ) |
|
def sds2.sub_mtrl.BentPlateLayoutSubMaterialReference.weight |
( |
|
args | ) |
|
def sds2.sub_mtrl.BentPlateLayoutSubMaterialReference.width |
( |
|
args | ) |
|
def sds2.sub_mtrl.BentPlateLayoutSubMaterialReference.wkpt_slope |
( |
|
args | ) |
|