No documentation available.
More...
Data and other attributes defined here: |
def | __init__ |
Data and other attributes inherited from Boost.Python.instance: |
def | __new__ |
Detailed Description
No documentation available.
Method resolution order
BoltSubMaterialReference
SubMaterialReference
Boost.Python.instance
builtin.object
Constructor & Destructor Documentation
def sds2.sub_mtrl.BoltSubMaterialReference.__init__ |
( |
|
args | ) |
|
Raises an exception
This class cannot be instantiated from Python
__init__ = <built-in function __init__>
Member Function Documentation
def sds2.sub_mtrl.BoltSubMaterialReference.__dict__ |
( |
|
args | ) |
|
def sds2.sub_mtrl.BoltSubMaterialReference.__new__ |
( |
|
args | ) |
|
T.__new__(S, ...) -> a new object with type S, a subtype of T
__new__ = <built-in method __new__ of Boost.Python.class object>
def sds2.sub_mtrl.BoltSubMaterialReference.__reduce__ |
( |
|
args | ) |
|
__reduce__ = <unnamed Boost.Python function>(args)
def sds2.sub_mtrl.BoltSubMaterialReference.__weakref__ |
( |
|
args | ) |
|
def sds2.sub_mtrl.BoltSubMaterialReference.assm_mark |
( |
|
args | ) |
|
def sds2.sub_mtrl.BoltSubMaterialReference.bolt_type |
( |
|
args | ) |
|
def sds2.sub_mtrl.BoltSubMaterialReference.boltless |
( |
|
args | ) |
|
def sds2.sub_mtrl.BoltSubMaterialReference.BuiltinMaterial |
( |
|
arg1 | ) |
|
- Returns
- Instance of type object
Return a BuiltinMaterial with the same properties as the
SubMaterialReference except with the color set to the job's
default color for the material type
C++ signature :
Alloy::Pointer::Pointer<MaterialBase> BuiltinMaterial(Entry<17>)
Return a BuiltinMaterial with the same properties as the
SubMaterialReference except with the option to override the color
C++ signature :
Alloy::Pointer::Pointer<MaterialBase> BuiltinMaterial(Entry<17>,bool)
- Note
- Additional signature: BuiltinMaterial( (SubMaterialReference)self, (bool)set_default_color) -> object
def sds2.sub_mtrl.BoltSubMaterialReference.cnc_dld |
( |
|
args | ) |
|
def sds2.sub_mtrl.BoltSubMaterialReference.control_file_entry_description |
( |
|
args | ) |
|
def sds2.sub_mtrl.BoltSubMaterialReference.dia |
( |
|
args | ) |
|
def sds2.sub_mtrl.BoltSubMaterialReference.dim_weight |
( |
|
args | ) |
|
def sds2.sub_mtrl.BoltSubMaterialReference.do_not_calc_poly_weight |
( |
|
args | ) |
|
def sds2.sub_mtrl.BoltSubMaterialReference.do_not_scribe |
( |
|
args | ) |
|
def sds2.sub_mtrl.BoltSubMaterialReference.dtl_quant |
( |
|
args | ) |
|
def sds2.sub_mtrl.BoltSubMaterialReference.dtl_rev_level |
( |
|
args | ) |
|
def sds2.sub_mtrl.BoltSubMaterialReference.dummy |
( |
|
args | ) |
|
def sds2.sub_mtrl.BoltSubMaterialReference.effective_index |
( |
|
args | ) |
|
def sds2.sub_mtrl.BoltSubMaterialReference.existing |
( |
|
args | ) |
|
def sds2.sub_mtrl.BoltSubMaterialReference.field_bolt |
( |
|
args | ) |
|
def sds2.sub_mtrl.BoltSubMaterialReference.finish |
( |
|
args | ) |
|
def sds2.sub_mtrl.BoltSubMaterialReference.fitted |
( |
|
args | ) |
|
def sds2.sub_mtrl.BoltSubMaterialReference.graph_comp_date |
( |
|
args | ) |
|
def sds2.sub_mtrl.BoltSubMaterialReference.grip |
( |
|
args | ) |
|
def sds2.sub_mtrl.BoltSubMaterialReference.hash |
( |
|
args | ) |
|
def sds2.sub_mtrl.BoltSubMaterialReference.headless |
( |
|
args | ) |
|
def sds2.sub_mtrl.BoltSubMaterialReference.hillside_washer_angle |
( |
|
args | ) |
|
def sds2.sub_mtrl.BoltSubMaterialReference.imp_desc |
( |
|
args | ) |
|
def sds2.sub_mtrl.BoltSubMaterialReference.info_type |
( |
|
args | ) |
|
def sds2.sub_mtrl.BoltSubMaterialReference.last_quant |
( |
|
args | ) |
|
def sds2.sub_mtrl.BoltSubMaterialReference.last_rev_level |
( |
|
args | ) |
|
def sds2.sub_mtrl.BoltSubMaterialReference.len |
( |
|
args | ) |
|
def sds2.sub_mtrl.BoltSubMaterialReference.met_desc |
( |
|
args | ) |
|
def sds2.sub_mtrl.BoltSubMaterialReference.mtrl_idx |
( |
|
args | ) |
|
def sds2.sub_mtrl.BoltSubMaterialReference.mtrl_type |
( |
|
args | ) |
|
def sds2.sub_mtrl.BoltSubMaterialReference.needs_detail |
( |
|
args | ) |
|
def sds2.sub_mtrl.BoltSubMaterialReference.nut_grade1 |
( |
|
args | ) |
|
def sds2.sub_mtrl.BoltSubMaterialReference.nut_grade2 |
( |
|
args | ) |
|
def sds2.sub_mtrl.BoltSubMaterialReference.nut_type1 |
( |
|
args | ) |
|
def sds2.sub_mtrl.BoltSubMaterialReference.nut_type2 |
( |
|
args | ) |
|
def sds2.sub_mtrl.BoltSubMaterialReference.on_sheet |
( |
|
args | ) |
|
def sds2.sub_mtrl.BoltSubMaterialReference.pcmk_hash |
( |
|
args | ) |
|
def sds2.sub_mtrl.BoltSubMaterialReference.public_pcmk |
( |
|
args | ) |
|
def sds2.sub_mtrl.BoltSubMaterialReference.quant |
( |
|
args | ) |
|
def sds2.sub_mtrl.BoltSubMaterialReference.ref_x |
( |
|
args | ) |
|
def sds2.sub_mtrl.BoltSubMaterialReference.ref_y |
( |
|
args | ) |
|
def sds2.sub_mtrl.BoltSubMaterialReference.rev_date |
( |
|
args | ) |
|
def sds2.sub_mtrl.BoltSubMaterialReference.rev_level |
( |
|
args | ) |
|
def sds2.sub_mtrl.BoltSubMaterialReference.rot |
( |
|
args | ) |
|
def sds2.sub_mtrl.BoltSubMaterialReference.sec_hash |
( |
|
args | ) |
|
def sds2.sub_mtrl.BoltSubMaterialReference.srfc_area |
( |
|
args | ) |
|
def sds2.sub_mtrl.BoltSubMaterialReference.std_mark |
( |
|
args | ) |
|
def sds2.sub_mtrl.BoltSubMaterialReference.stretched |
( |
|
args | ) |
|
def sds2.sub_mtrl.BoltSubMaterialReference.sub_mtrl_idx |
( |
|
args | ) |
|
def sds2.sub_mtrl.BoltSubMaterialReference.tc |
( |
|
args | ) |
|
def sds2.sub_mtrl.BoltSubMaterialReference.usage |
( |
|
args | ) |
|
def sds2.sub_mtrl.BoltSubMaterialReference.user_description |
( |
|
args | ) |
|
def sds2.sub_mtrl.BoltSubMaterialReference.washer_hd1 |
( |
|
args | ) |
|
def sds2.sub_mtrl.BoltSubMaterialReference.washer_hd2 |
( |
|
args | ) |
|
def sds2.sub_mtrl.BoltSubMaterialReference.washer_hd3 |
( |
|
args | ) |
|
def sds2.sub_mtrl.BoltSubMaterialReference.washer_nt1 |
( |
|
args | ) |
|
def sds2.sub_mtrl.BoltSubMaterialReference.washer_nt2 |
( |
|
args | ) |
|
def sds2.sub_mtrl.BoltSubMaterialReference.washer_nt3 |
( |
|
args | ) |
|
def sds2.sub_mtrl.BoltSubMaterialReference.weight |
( |
|
args | ) |
|