No documentation available.
More...
Data and other attributes defined here: |
def | __init__ |
Data and other attributes inherited from Boost.Python.instance: |
def | __new__ |
Detailed Description
No documentation available.
Method resolution order
ClevisPinSubMaterialReference
SubMaterialReference
Boost.Python.instance
builtin.object
Constructor & Destructor Documentation
def sds2.sub_mtrl.ClevisPinSubMaterialReference.__init__ |
( |
|
args | ) |
|
Raises an exception
This class cannot be instantiated from Python
__init__ = <built-in function __init__>
Member Function Documentation
def sds2.sub_mtrl.ClevisPinSubMaterialReference.__dict__ |
( |
|
args | ) |
|
def sds2.sub_mtrl.ClevisPinSubMaterialReference.__new__ |
( |
|
args | ) |
|
T.__new__(S, ...) -> a new object with type S, a subtype of T
__new__ = <built-in method __new__ of Boost.Python.class object>
def sds2.sub_mtrl.ClevisPinSubMaterialReference.__reduce__ |
( |
|
args | ) |
|
__reduce__ = <unnamed Boost.Python function>(args)
def sds2.sub_mtrl.ClevisPinSubMaterialReference.__weakref__ |
( |
|
args | ) |
|
def sds2.sub_mtrl.ClevisPinSubMaterialReference.assm_mark |
( |
|
args | ) |
|
def sds2.sub_mtrl.ClevisPinSubMaterialReference.BuiltinMaterial |
( |
|
arg1 | ) |
|
- Returns
- Instance of type object
Return a BuiltinMaterial with the same properties as the
SubMaterialReference except with the color set to the job's
default color for the material type
C++ signature :
Alloy::Pointer::Pointer<MaterialBase> BuiltinMaterial(Entry<17>)
Return a BuiltinMaterial with the same properties as the
SubMaterialReference except with the option to override the color
C++ signature :
Alloy::Pointer::Pointer<MaterialBase> BuiltinMaterial(Entry<17>,bool)
- Note
- Additional signature: BuiltinMaterial( (SubMaterialReference)self, (bool)set_default_color) -> object
def sds2.sub_mtrl.ClevisPinSubMaterialReference.cnc_dld |
( |
|
args | ) |
|
def sds2.sub_mtrl.ClevisPinSubMaterialReference.control_file_entry_description |
( |
|
args | ) |
|
def sds2.sub_mtrl.ClevisPinSubMaterialReference.dim_weight |
( |
|
args | ) |
|
def sds2.sub_mtrl.ClevisPinSubMaterialReference.do_not_calc_poly_weight |
( |
|
args | ) |
|
def sds2.sub_mtrl.ClevisPinSubMaterialReference.do_not_scribe |
( |
|
args | ) |
|
def sds2.sub_mtrl.ClevisPinSubMaterialReference.dtl_quant |
( |
|
args | ) |
|
def sds2.sub_mtrl.ClevisPinSubMaterialReference.dtl_rev_level |
( |
|
args | ) |
|
def sds2.sub_mtrl.ClevisPinSubMaterialReference.dummy |
( |
|
args | ) |
|
def sds2.sub_mtrl.ClevisPinSubMaterialReference.effective_index |
( |
|
args | ) |
|
def sds2.sub_mtrl.ClevisPinSubMaterialReference.existing |
( |
|
args | ) |
|
def sds2.sub_mtrl.ClevisPinSubMaterialReference.fitted |
( |
|
args | ) |
|
def sds2.sub_mtrl.ClevisPinSubMaterialReference.graph_comp_date |
( |
|
args | ) |
|
def sds2.sub_mtrl.ClevisPinSubMaterialReference.hash |
( |
|
args | ) |
|
def sds2.sub_mtrl.ClevisPinSubMaterialReference.imp_desc |
( |
|
args | ) |
|
def sds2.sub_mtrl.ClevisPinSubMaterialReference.info_type |
( |
|
args | ) |
|
def sds2.sub_mtrl.ClevisPinSubMaterialReference.last_quant |
( |
|
args | ) |
|
def sds2.sub_mtrl.ClevisPinSubMaterialReference.last_rev_level |
( |
|
args | ) |
|
def sds2.sub_mtrl.ClevisPinSubMaterialReference.met_desc |
( |
|
args | ) |
|
def sds2.sub_mtrl.ClevisPinSubMaterialReference.mtrl_idx |
( |
|
args | ) |
|
def sds2.sub_mtrl.ClevisPinSubMaterialReference.mtrl_type |
( |
|
args | ) |
|
def sds2.sub_mtrl.ClevisPinSubMaterialReference.needs_detail |
( |
|
args | ) |
|
def sds2.sub_mtrl.ClevisPinSubMaterialReference.on_sheet |
( |
|
args | ) |
|
def sds2.sub_mtrl.ClevisPinSubMaterialReference.pcmk_hash |
( |
|
args | ) |
|
def sds2.sub_mtrl.ClevisPinSubMaterialReference.pin_dia |
( |
|
args | ) |
|
def sds2.sub_mtrl.ClevisPinSubMaterialReference.pin_head_dia |
( |
|
args | ) |
|
def sds2.sub_mtrl.ClevisPinSubMaterialReference.pin_head_thick |
( |
|
args | ) |
|
def sds2.sub_mtrl.ClevisPinSubMaterialReference.pin_length |
( |
|
args | ) |
|
def sds2.sub_mtrl.ClevisPinSubMaterialReference.pin_type |
( |
|
args | ) |
|
def sds2.sub_mtrl.ClevisPinSubMaterialReference.public_pcmk |
( |
|
args | ) |
|
def sds2.sub_mtrl.ClevisPinSubMaterialReference.quant |
( |
|
args | ) |
|
def sds2.sub_mtrl.ClevisPinSubMaterialReference.ref_x |
( |
|
args | ) |
|
def sds2.sub_mtrl.ClevisPinSubMaterialReference.ref_y |
( |
|
args | ) |
|
def sds2.sub_mtrl.ClevisPinSubMaterialReference.rev_date |
( |
|
args | ) |
|
def sds2.sub_mtrl.ClevisPinSubMaterialReference.rev_level |
( |
|
args | ) |
|
def sds2.sub_mtrl.ClevisPinSubMaterialReference.sec_hash |
( |
|
args | ) |
|
def sds2.sub_mtrl.ClevisPinSubMaterialReference.srfc_area |
( |
|
args | ) |
|
def sds2.sub_mtrl.ClevisPinSubMaterialReference.std_mark |
( |
|
args | ) |
|
def sds2.sub_mtrl.ClevisPinSubMaterialReference.stretched |
( |
|
args | ) |
|
def sds2.sub_mtrl.ClevisPinSubMaterialReference.sub_mtrl_idx |
( |
|
args | ) |
|
def sds2.sub_mtrl.ClevisPinSubMaterialReference.usage |
( |
|
args | ) |
|
def sds2.sub_mtrl.ClevisPinSubMaterialReference.user_description |
( |
|
args | ) |
|
def sds2.sub_mtrl.ClevisPinSubMaterialReference.weight |
( |
|
args | ) |
|