No documentation available.
More...
Data and other attributes defined here: |
def | __init__ |
Data and other attributes inherited from Boost.Python.instance: |
def | __new__ |
Detailed Description
No documentation available.
Method resolution order
ClevisSubMaterialReference
SubMaterialReference
Boost.Python.instance
builtin.object
Constructor & Destructor Documentation
def sds2.sub_mtrl.ClevisSubMaterialReference.__init__ |
( |
|
args | ) |
|
Raises an exception
This class cannot be instantiated from Python
__init__ = <built-in function __init__>
Member Function Documentation
def sds2.sub_mtrl.ClevisSubMaterialReference.__dict__ |
( |
|
args | ) |
|
def sds2.sub_mtrl.ClevisSubMaterialReference.__new__ |
( |
|
args | ) |
|
T.__new__(S, ...) -> a new object with type S, a subtype of T
__new__ = <built-in method __new__ of Boost.Python.class object>
def sds2.sub_mtrl.ClevisSubMaterialReference.__reduce__ |
( |
|
args | ) |
|
__reduce__ = <unnamed Boost.Python function>(args)
def sds2.sub_mtrl.ClevisSubMaterialReference.__weakref__ |
( |
|
args | ) |
|
def sds2.sub_mtrl.ClevisSubMaterialReference.assm_mark |
( |
|
args | ) |
|
def sds2.sub_mtrl.ClevisSubMaterialReference.BuiltinMaterial |
( |
|
arg1 | ) |
|
- Returns
- Instance of type object
Return a BuiltinMaterial with the same properties as the
SubMaterialReference except with the color set to the job's
default color for the material type
C++ signature :
Alloy::Pointer::Pointer<MaterialBase> BuiltinMaterial(Entry<17>)
Return a BuiltinMaterial with the same properties as the
SubMaterialReference except with the option to override the color
C++ signature :
Alloy::Pointer::Pointer<MaterialBase> BuiltinMaterial(Entry<17>,bool)
- Note
- Additional signature: BuiltinMaterial( (SubMaterialReference)self, (bool)set_default_color) -> object
def sds2.sub_mtrl.ClevisSubMaterialReference.cnc_dld |
( |
|
args | ) |
|
def sds2.sub_mtrl.ClevisSubMaterialReference.control_file_entry_description |
( |
|
args | ) |
|
def sds2.sub_mtrl.ClevisSubMaterialReference.dia |
( |
|
args | ) |
|
def sds2.sub_mtrl.ClevisSubMaterialReference.dim_weight |
( |
|
args | ) |
|
def sds2.sub_mtrl.ClevisSubMaterialReference.do_not_calc_poly_weight |
( |
|
args | ) |
|
def sds2.sub_mtrl.ClevisSubMaterialReference.do_not_scribe |
( |
|
args | ) |
|
def sds2.sub_mtrl.ClevisSubMaterialReference.dtl_quant |
( |
|
args | ) |
|
def sds2.sub_mtrl.ClevisSubMaterialReference.dtl_rev_level |
( |
|
args | ) |
|
def sds2.sub_mtrl.ClevisSubMaterialReference.dummy |
( |
|
args | ) |
|
def sds2.sub_mtrl.ClevisSubMaterialReference.effective_index |
( |
|
args | ) |
|
def sds2.sub_mtrl.ClevisSubMaterialReference.existing |
( |
|
args | ) |
|
def sds2.sub_mtrl.ClevisSubMaterialReference.fitted |
( |
|
args | ) |
|
def sds2.sub_mtrl.ClevisSubMaterialReference.graph_comp_date |
( |
|
args | ) |
|
def sds2.sub_mtrl.ClevisSubMaterialReference.grip |
( |
|
args | ) |
|
def sds2.sub_mtrl.ClevisSubMaterialReference.hash |
( |
|
args | ) |
|
def sds2.sub_mtrl.ClevisSubMaterialReference.imp_desc |
( |
|
args | ) |
|
def sds2.sub_mtrl.ClevisSubMaterialReference.info_type |
( |
|
args | ) |
|
def sds2.sub_mtrl.ClevisSubMaterialReference.last_quant |
( |
|
args | ) |
|
def sds2.sub_mtrl.ClevisSubMaterialReference.last_rev_level |
( |
|
args | ) |
|
def sds2.sub_mtrl.ClevisSubMaterialReference.met_desc |
( |
|
args | ) |
|
def sds2.sub_mtrl.ClevisSubMaterialReference.mtrl_idx |
( |
|
args | ) |
|
def sds2.sub_mtrl.ClevisSubMaterialReference.mtrl_type |
( |
|
args | ) |
|
def sds2.sub_mtrl.ClevisSubMaterialReference.needs_detail |
( |
|
args | ) |
|
def sds2.sub_mtrl.ClevisSubMaterialReference.on_sheet |
( |
|
args | ) |
|
def sds2.sub_mtrl.ClevisSubMaterialReference.pcmk_hash |
( |
|
args | ) |
|
def sds2.sub_mtrl.ClevisSubMaterialReference.pin_dia |
( |
|
args | ) |
|
def sds2.sub_mtrl.ClevisSubMaterialReference.public_pcmk |
( |
|
args | ) |
|
def sds2.sub_mtrl.ClevisSubMaterialReference.quant |
( |
|
args | ) |
|
def sds2.sub_mtrl.ClevisSubMaterialReference.ref_x |
( |
|
args | ) |
|
def sds2.sub_mtrl.ClevisSubMaterialReference.ref_y |
( |
|
args | ) |
|
def sds2.sub_mtrl.ClevisSubMaterialReference.rev_date |
( |
|
args | ) |
|
def sds2.sub_mtrl.ClevisSubMaterialReference.rev_level |
( |
|
args | ) |
|
def sds2.sub_mtrl.ClevisSubMaterialReference.sec_hash |
( |
|
args | ) |
|
def sds2.sub_mtrl.ClevisSubMaterialReference.srfc_area |
( |
|
args | ) |
|
def sds2.sub_mtrl.ClevisSubMaterialReference.std_mark |
( |
|
args | ) |
|
def sds2.sub_mtrl.ClevisSubMaterialReference.stretched |
( |
|
args | ) |
|
def sds2.sub_mtrl.ClevisSubMaterialReference.sub_mtrl_idx |
( |
|
args | ) |
|
def sds2.sub_mtrl.ClevisSubMaterialReference.thread_type |
( |
|
args | ) |
|
def sds2.sub_mtrl.ClevisSubMaterialReference.usage |
( |
|
args | ) |
|
def sds2.sub_mtrl.ClevisSubMaterialReference.user_description |
( |
|
args | ) |
|
def sds2.sub_mtrl.ClevisSubMaterialReference.weight |
( |
|
args | ) |
|