No documentation available.
More...
Data and other attributes defined here: |
def | __init__ |
Data and other attributes inherited from Boost.Python.instance: |
def | __new__ |
Additional Inherited Members |
Detailed Description
No documentation available.
Method resolution order
ColdFormedZSubMaterialReference
GenMaterialSubMaterialReference
SubMaterialReference
Boost.Python.instance
builtin.object
Constructor & Destructor Documentation
def sds2.sub_mtrl.ColdFormedZSubMaterialReference.__init__ |
( |
|
args | ) |
|
Member Function Documentation
def sds2.sub_mtrl.ColdFormedZSubMaterialReference.__dict__ |
( |
|
args | ) |
|
def sds2.sub_mtrl.ColdFormedZSubMaterialReference.__new__ |
( |
|
args | ) |
|
def sds2.sub_mtrl.ColdFormedZSubMaterialReference.__reduce__ |
( |
|
args | ) |
|
def sds2.sub_mtrl.ColdFormedZSubMaterialReference.__weakref__ |
( |
|
args | ) |
|
def sds2.sub_mtrl.ColdFormedZSubMaterialReference.assm_mark |
( |
|
args | ) |
|
def sds2.sub_mtrl.ColdFormedZSubMaterialReference.bar_stock |
( |
|
args | ) |
|
def sds2.sub_mtrl.ColdFormedZSubMaterialReference.bend_angle |
( |
|
args | ) |
|
def sds2.sub_mtrl.ColdFormedZSubMaterialReference.bend_rad |
( |
|
args | ) |
|
def sds2.sub_mtrl.ColdFormedZSubMaterialReference.BuiltinMaterial |
( |
|
arg1 | ) |
|
- Returns
- Instance of type object
Return a BuiltinMaterial with the same properties as the
SubMaterialReference except with the color set to the job's
default color for the material type
C++ signature :
Alloy::Pointer::Pointer<MaterialBase> BuiltinMaterial(Entry<17>)
Return a BuiltinMaterial with the same properties as the
SubMaterialReference except with the option to override the color
C++ signature :
Alloy::Pointer::Pointer<MaterialBase> BuiltinMaterial(Entry<17>,bool)
- Note
- Additional signature: BuiltinMaterial( (SubMaterialReference)self, (bool)set_default_color) -> object
Reimplemented from sds2.sub_mtrl.GenMaterialSubMaterialReference.
def sds2.sub_mtrl.ColdFormedZSubMaterialReference.camber |
( |
|
args | ) |
|
def sds2.sub_mtrl.ColdFormedZSubMaterialReference.checkered |
( |
|
args | ) |
|
def sds2.sub_mtrl.ColdFormedZSubMaterialReference.cnc_dld |
( |
|
args | ) |
|
def sds2.sub_mtrl.ColdFormedZSubMaterialReference.control_file_entry_description |
( |
|
args | ) |
|
def sds2.sub_mtrl.ColdFormedZSubMaterialReference.dim_weight |
( |
|
args | ) |
|
def sds2.sub_mtrl.ColdFormedZSubMaterialReference.do_not_calc_poly_weight |
( |
|
args | ) |
|
def sds2.sub_mtrl.ColdFormedZSubMaterialReference.do_not_scribe |
( |
|
args | ) |
|
def sds2.sub_mtrl.ColdFormedZSubMaterialReference.dtl_quant |
( |
|
args | ) |
|
def sds2.sub_mtrl.ColdFormedZSubMaterialReference.dtl_rev_level |
( |
|
args | ) |
|
def sds2.sub_mtrl.ColdFormedZSubMaterialReference.dummy |
( |
|
args | ) |
|
def sds2.sub_mtrl.ColdFormedZSubMaterialReference.effective_index |
( |
|
args | ) |
|
def sds2.sub_mtrl.ColdFormedZSubMaterialReference.end_prep |
( |
|
args | ) |
|
def sds2.sub_mtrl.ColdFormedZSubMaterialReference.existing |
( |
|
args | ) |
|
def sds2.sub_mtrl.ColdFormedZSubMaterialReference.f_weld |
( |
|
args | ) |
|
def sds2.sub_mtrl.ColdFormedZSubMaterialReference.fitted |
( |
|
args | ) |
|
def sds2.sub_mtrl.ColdFormedZSubMaterialReference.flg_cut |
( |
|
args | ) |
|
def sds2.sub_mtrl.ColdFormedZSubMaterialReference.flip |
( |
|
args | ) |
|
def sds2.sub_mtrl.ColdFormedZSubMaterialReference.graph_comp_date |
( |
|
args | ) |
|
def sds2.sub_mtrl.ColdFormedZSubMaterialReference.hash |
( |
|
args | ) |
|
def sds2.sub_mtrl.ColdFormedZSubMaterialReference.imp_desc |
( |
|
args | ) |
|
def sds2.sub_mtrl.ColdFormedZSubMaterialReference.info_type |
( |
|
args | ) |
|
def sds2.sub_mtrl.ColdFormedZSubMaterialReference.last_quant |
( |
|
args | ) |
|
def sds2.sub_mtrl.ColdFormedZSubMaterialReference.last_rev_level |
( |
|
args | ) |
|
def sds2.sub_mtrl.ColdFormedZSubMaterialReference.left_btm_op_dim1 |
( |
|
args | ) |
|
def sds2.sub_mtrl.ColdFormedZSubMaterialReference.left_btm_op_dim2 |
( |
|
args | ) |
|
def sds2.sub_mtrl.ColdFormedZSubMaterialReference.left_btm_op_dim3 |
( |
|
args | ) |
|
def sds2.sub_mtrl.ColdFormedZSubMaterialReference.left_btm_op_dim4 |
( |
|
args | ) |
|
def sds2.sub_mtrl.ColdFormedZSubMaterialReference.left_btm_op_dim5 |
( |
|
args | ) |
|
def sds2.sub_mtrl.ColdFormedZSubMaterialReference.left_btm_op_dim6 |
( |
|
args | ) |
|
def sds2.sub_mtrl.ColdFormedZSubMaterialReference.left_btm_op_dim7 |
( |
|
args | ) |
|
def sds2.sub_mtrl.ColdFormedZSubMaterialReference.left_btm_op_dim8 |
( |
|
args | ) |
|
def sds2.sub_mtrl.ColdFormedZSubMaterialReference.left_btm_op_type |
( |
|
args | ) |
|
def sds2.sub_mtrl.ColdFormedZSubMaterialReference.left_top_op_dim1 |
( |
|
args | ) |
|
def sds2.sub_mtrl.ColdFormedZSubMaterialReference.left_top_op_dim2 |
( |
|
args | ) |
|
def sds2.sub_mtrl.ColdFormedZSubMaterialReference.left_top_op_dim3 |
( |
|
args | ) |
|
def sds2.sub_mtrl.ColdFormedZSubMaterialReference.left_top_op_dim4 |
( |
|
args | ) |
|
def sds2.sub_mtrl.ColdFormedZSubMaterialReference.left_top_op_dim5 |
( |
|
args | ) |
|
def sds2.sub_mtrl.ColdFormedZSubMaterialReference.left_top_op_dim6 |
( |
|
args | ) |
|
def sds2.sub_mtrl.ColdFormedZSubMaterialReference.left_top_op_dim7 |
( |
|
args | ) |
|
def sds2.sub_mtrl.ColdFormedZSubMaterialReference.left_top_op_dim8 |
( |
|
args | ) |
|
def sds2.sub_mtrl.ColdFormedZSubMaterialReference.left_top_op_type |
( |
|
args | ) |
|
def sds2.sub_mtrl.ColdFormedZSubMaterialReference.leg |
( |
|
args | ) |
|
def sds2.sub_mtrl.ColdFormedZSubMaterialReference.length |
( |
|
args | ) |
|
def sds2.sub_mtrl.ColdFormedZSubMaterialReference.llv |
( |
|
args | ) |
|
def sds2.sub_mtrl.ColdFormedZSubMaterialReference.met_desc |
( |
|
args | ) |
|
def sds2.sub_mtrl.ColdFormedZSubMaterialReference.mtrl_idx |
( |
|
args | ) |
|
def sds2.sub_mtrl.ColdFormedZSubMaterialReference.mtrl_stbk |
( |
|
args | ) |
|
def sds2.sub_mtrl.ColdFormedZSubMaterialReference.mtrl_type |
( |
|
args | ) |
|
def sds2.sub_mtrl.ColdFormedZSubMaterialReference.mtrl_use |
( |
|
args | ) |
|
def sds2.sub_mtrl.ColdFormedZSubMaterialReference.needs_detail |
( |
|
args | ) |
|
def sds2.sub_mtrl.ColdFormedZSubMaterialReference.on_sheet |
( |
|
args | ) |
|
def sds2.sub_mtrl.ColdFormedZSubMaterialReference.origin |
( |
|
args | ) |
|
def sds2.sub_mtrl.ColdFormedZSubMaterialReference.osl |
( |
|
args | ) |
|
def sds2.sub_mtrl.ColdFormedZSubMaterialReference.part_length |
( |
|
args | ) |
|
def sds2.sub_mtrl.ColdFormedZSubMaterialReference.pcmk_hash |
( |
|
args | ) |
|
def sds2.sub_mtrl.ColdFormedZSubMaterialReference.pl_area |
( |
|
args | ) |
|
def sds2.sub_mtrl.ColdFormedZSubMaterialReference.public_pcmk |
( |
|
args | ) |
|
def sds2.sub_mtrl.ColdFormedZSubMaterialReference.quant |
( |
|
args | ) |
|
def sds2.sub_mtrl.ColdFormedZSubMaterialReference.rad |
( |
|
args | ) |
|
def sds2.sub_mtrl.ColdFormedZSubMaterialReference.reent_hole_dist |
( |
|
args | ) |
|
def sds2.sub_mtrl.ColdFormedZSubMaterialReference.ref_x |
( |
|
args | ) |
|
def sds2.sub_mtrl.ColdFormedZSubMaterialReference.ref_y |
( |
|
args | ) |
|
def sds2.sub_mtrl.ColdFormedZSubMaterialReference.rev_date |
( |
|
args | ) |
|
def sds2.sub_mtrl.ColdFormedZSubMaterialReference.rev_level |
( |
|
args | ) |
|
def sds2.sub_mtrl.ColdFormedZSubMaterialReference.right_btm_op_dim1 |
( |
|
args | ) |
|
def sds2.sub_mtrl.ColdFormedZSubMaterialReference.right_btm_op_dim2 |
( |
|
args | ) |
|
def sds2.sub_mtrl.ColdFormedZSubMaterialReference.right_btm_op_dim3 |
( |
|
args | ) |
|
def sds2.sub_mtrl.ColdFormedZSubMaterialReference.right_btm_op_dim4 |
( |
|
args | ) |
|
def sds2.sub_mtrl.ColdFormedZSubMaterialReference.right_btm_op_dim5 |
( |
|
args | ) |
|
def sds2.sub_mtrl.ColdFormedZSubMaterialReference.right_btm_op_dim6 |
( |
|
args | ) |
|
def sds2.sub_mtrl.ColdFormedZSubMaterialReference.right_btm_op_dim7 |
( |
|
args | ) |
|
def sds2.sub_mtrl.ColdFormedZSubMaterialReference.right_btm_op_dim8 |
( |
|
args | ) |
|
def sds2.sub_mtrl.ColdFormedZSubMaterialReference.right_btm_op_type |
( |
|
args | ) |
|
def sds2.sub_mtrl.ColdFormedZSubMaterialReference.right_top_op_dim1 |
( |
|
args | ) |
|
def sds2.sub_mtrl.ColdFormedZSubMaterialReference.right_top_op_dim2 |
( |
|
args | ) |
|
def sds2.sub_mtrl.ColdFormedZSubMaterialReference.right_top_op_dim3 |
( |
|
args | ) |
|
def sds2.sub_mtrl.ColdFormedZSubMaterialReference.right_top_op_dim4 |
( |
|
args | ) |
|
def sds2.sub_mtrl.ColdFormedZSubMaterialReference.right_top_op_dim5 |
( |
|
args | ) |
|
def sds2.sub_mtrl.ColdFormedZSubMaterialReference.right_top_op_dim6 |
( |
|
args | ) |
|
def sds2.sub_mtrl.ColdFormedZSubMaterialReference.right_top_op_dim7 |
( |
|
args | ) |
|
def sds2.sub_mtrl.ColdFormedZSubMaterialReference.right_top_op_dim8 |
( |
|
args | ) |
|
def sds2.sub_mtrl.ColdFormedZSubMaterialReference.right_top_op_type |
( |
|
args | ) |
|
def sds2.sub_mtrl.ColdFormedZSubMaterialReference.roll_type |
( |
|
args | ) |
|
def sds2.sub_mtrl.ColdFormedZSubMaterialReference.rolled_mtrl_ref_pt |
( |
|
args | ) |
|
def sds2.sub_mtrl.ColdFormedZSubMaterialReference.rolled_offset |
( |
|
args | ) |
|
def sds2.sub_mtrl.ColdFormedZSubMaterialReference.sec_hash |
( |
|
args | ) |
|
def sds2.sub_mtrl.ColdFormedZSubMaterialReference.srfc_area |
( |
|
args | ) |
|
def sds2.sub_mtrl.ColdFormedZSubMaterialReference.stair_mtrl_use |
( |
|
args | ) |
|
def sds2.sub_mtrl.ColdFormedZSubMaterialReference.std_mark |
( |
|
args | ) |
|
def sds2.sub_mtrl.ColdFormedZSubMaterialReference.stretched |
( |
|
args | ) |
|
def sds2.sub_mtrl.ColdFormedZSubMaterialReference.sub_mtrl_idx |
( |
|
args | ) |
|
def sds2.sub_mtrl.ColdFormedZSubMaterialReference.taper_rad |
( |
|
args | ) |
|
def sds2.sub_mtrl.ColdFormedZSubMaterialReference.thick |
( |
|
args | ) |
|
def sds2.sub_mtrl.ColdFormedZSubMaterialReference.thread_length |
( |
|
args | ) |
|
def sds2.sub_mtrl.ColdFormedZSubMaterialReference.thread_type |
( |
|
args | ) |
|
def sds2.sub_mtrl.ColdFormedZSubMaterialReference.toe_io |
( |
|
args | ) |
|
def sds2.sub_mtrl.ColdFormedZSubMaterialReference.trans_width |
( |
|
args | ) |
|
def sds2.sub_mtrl.ColdFormedZSubMaterialReference.twist |
( |
|
args | ) |
|
def sds2.sub_mtrl.ColdFormedZSubMaterialReference.usage |
( |
|
args | ) |
|
def sds2.sub_mtrl.ColdFormedZSubMaterialReference.user_description |
( |
|
args | ) |
|
def sds2.sub_mtrl.ColdFormedZSubMaterialReference.web_cut |
( |
|
args | ) |
|
def sds2.sub_mtrl.ColdFormedZSubMaterialReference.web_stbk |
( |
|
args | ) |
|
def sds2.sub_mtrl.ColdFormedZSubMaterialReference.weight |
( |
|
args | ) |
|
def sds2.sub_mtrl.ColdFormedZSubMaterialReference.width |
( |
|
args | ) |
|
def sds2.sub_mtrl.ColdFormedZSubMaterialReference.wkpt_slope |
( |
|
args | ) |
|