No documentation available.
More...
Data and other attributes defined here: |
def | __init__ |
Data and other attributes inherited from Boost.Python.instance: |
def | __new__ |
Additional Inherited Members |
Detailed Description
No documentation available.
Method resolution order
ExpPlateTreadSubMaterialReference
GenMaterialSubMaterialReference
SubMaterialReference
Boost.Python.instance
builtin.object
Constructor & Destructor Documentation
def sds2.sub_mtrl.ExpPlateTreadSubMaterialReference.__init__ |
( |
|
args | ) |
|
Member Function Documentation
def sds2.sub_mtrl.ExpPlateTreadSubMaterialReference.__dict__ |
( |
|
args | ) |
|
def sds2.sub_mtrl.ExpPlateTreadSubMaterialReference.__new__ |
( |
|
args | ) |
|
def sds2.sub_mtrl.ExpPlateTreadSubMaterialReference.__reduce__ |
( |
|
args | ) |
|
def sds2.sub_mtrl.ExpPlateTreadSubMaterialReference.__weakref__ |
( |
|
args | ) |
|
def sds2.sub_mtrl.ExpPlateTreadSubMaterialReference.assm_mark |
( |
|
args | ) |
|
def sds2.sub_mtrl.ExpPlateTreadSubMaterialReference.bar_stock |
( |
|
args | ) |
|
def sds2.sub_mtrl.ExpPlateTreadSubMaterialReference.bend_angle |
( |
|
args | ) |
|
def sds2.sub_mtrl.ExpPlateTreadSubMaterialReference.bend_rad |
( |
|
args | ) |
|
def sds2.sub_mtrl.ExpPlateTreadSubMaterialReference.BuiltinMaterial |
( |
|
arg1 | ) |
|
- Returns
- Instance of type object
Return a BuiltinMaterial with the same properties as the
SubMaterialReference except with the color set to the job's
default color for the material type
C++ signature :
Alloy::Pointer::Pointer<MaterialBase> BuiltinMaterial(Entry<17>)
Return a BuiltinMaterial with the same properties as the
SubMaterialReference except with the option to override the color
C++ signature :
Alloy::Pointer::Pointer<MaterialBase> BuiltinMaterial(Entry<17>,bool)
- Note
- Additional signature: BuiltinMaterial( (SubMaterialReference)self, (bool)set_default_color) -> object
Reimplemented from sds2.sub_mtrl.GenMaterialSubMaterialReference.
def sds2.sub_mtrl.ExpPlateTreadSubMaterialReference.camber |
( |
|
args | ) |
|
def sds2.sub_mtrl.ExpPlateTreadSubMaterialReference.checkered |
( |
|
args | ) |
|
def sds2.sub_mtrl.ExpPlateTreadSubMaterialReference.cnc_dld |
( |
|
args | ) |
|
def sds2.sub_mtrl.ExpPlateTreadSubMaterialReference.control_file_entry_description |
( |
|
args | ) |
|
def sds2.sub_mtrl.ExpPlateTreadSubMaterialReference.dim_weight |
( |
|
args | ) |
|
def sds2.sub_mtrl.ExpPlateTreadSubMaterialReference.do_not_calc_poly_weight |
( |
|
args | ) |
|
def sds2.sub_mtrl.ExpPlateTreadSubMaterialReference.do_not_scribe |
( |
|
args | ) |
|
def sds2.sub_mtrl.ExpPlateTreadSubMaterialReference.dtl_quant |
( |
|
args | ) |
|
def sds2.sub_mtrl.ExpPlateTreadSubMaterialReference.dtl_rev_level |
( |
|
args | ) |
|
def sds2.sub_mtrl.ExpPlateTreadSubMaterialReference.dummy |
( |
|
args | ) |
|
def sds2.sub_mtrl.ExpPlateTreadSubMaterialReference.effective_index |
( |
|
args | ) |
|
def sds2.sub_mtrl.ExpPlateTreadSubMaterialReference.end_prep |
( |
|
args | ) |
|
def sds2.sub_mtrl.ExpPlateTreadSubMaterialReference.existing |
( |
|
args | ) |
|
def sds2.sub_mtrl.ExpPlateTreadSubMaterialReference.f_weld |
( |
|
args | ) |
|
def sds2.sub_mtrl.ExpPlateTreadSubMaterialReference.fitted |
( |
|
args | ) |
|
def sds2.sub_mtrl.ExpPlateTreadSubMaterialReference.flg_cut |
( |
|
args | ) |
|
def sds2.sub_mtrl.ExpPlateTreadSubMaterialReference.flip |
( |
|
args | ) |
|
def sds2.sub_mtrl.ExpPlateTreadSubMaterialReference.graph_comp_date |
( |
|
args | ) |
|
def sds2.sub_mtrl.ExpPlateTreadSubMaterialReference.hash |
( |
|
args | ) |
|
def sds2.sub_mtrl.ExpPlateTreadSubMaterialReference.imp_desc |
( |
|
args | ) |
|
def sds2.sub_mtrl.ExpPlateTreadSubMaterialReference.info_type |
( |
|
args | ) |
|
def sds2.sub_mtrl.ExpPlateTreadSubMaterialReference.last_quant |
( |
|
args | ) |
|
def sds2.sub_mtrl.ExpPlateTreadSubMaterialReference.last_rev_level |
( |
|
args | ) |
|
def sds2.sub_mtrl.ExpPlateTreadSubMaterialReference.left_btm_op_dim1 |
( |
|
args | ) |
|
def sds2.sub_mtrl.ExpPlateTreadSubMaterialReference.left_btm_op_dim2 |
( |
|
args | ) |
|
def sds2.sub_mtrl.ExpPlateTreadSubMaterialReference.left_btm_op_dim3 |
( |
|
args | ) |
|
def sds2.sub_mtrl.ExpPlateTreadSubMaterialReference.left_btm_op_dim4 |
( |
|
args | ) |
|
def sds2.sub_mtrl.ExpPlateTreadSubMaterialReference.left_btm_op_dim5 |
( |
|
args | ) |
|
def sds2.sub_mtrl.ExpPlateTreadSubMaterialReference.left_btm_op_dim6 |
( |
|
args | ) |
|
def sds2.sub_mtrl.ExpPlateTreadSubMaterialReference.left_btm_op_dim7 |
( |
|
args | ) |
|
def sds2.sub_mtrl.ExpPlateTreadSubMaterialReference.left_btm_op_dim8 |
( |
|
args | ) |
|
def sds2.sub_mtrl.ExpPlateTreadSubMaterialReference.left_btm_op_type |
( |
|
args | ) |
|
def sds2.sub_mtrl.ExpPlateTreadSubMaterialReference.left_top_op_dim1 |
( |
|
args | ) |
|
def sds2.sub_mtrl.ExpPlateTreadSubMaterialReference.left_top_op_dim2 |
( |
|
args | ) |
|
def sds2.sub_mtrl.ExpPlateTreadSubMaterialReference.left_top_op_dim3 |
( |
|
args | ) |
|
def sds2.sub_mtrl.ExpPlateTreadSubMaterialReference.left_top_op_dim4 |
( |
|
args | ) |
|
def sds2.sub_mtrl.ExpPlateTreadSubMaterialReference.left_top_op_dim5 |
( |
|
args | ) |
|
def sds2.sub_mtrl.ExpPlateTreadSubMaterialReference.left_top_op_dim6 |
( |
|
args | ) |
|
def sds2.sub_mtrl.ExpPlateTreadSubMaterialReference.left_top_op_dim7 |
( |
|
args | ) |
|
def sds2.sub_mtrl.ExpPlateTreadSubMaterialReference.left_top_op_dim8 |
( |
|
args | ) |
|
def sds2.sub_mtrl.ExpPlateTreadSubMaterialReference.left_top_op_type |
( |
|
args | ) |
|
def sds2.sub_mtrl.ExpPlateTreadSubMaterialReference.leg |
( |
|
args | ) |
|
def sds2.sub_mtrl.ExpPlateTreadSubMaterialReference.length |
( |
|
args | ) |
|
def sds2.sub_mtrl.ExpPlateTreadSubMaterialReference.llv |
( |
|
args | ) |
|
def sds2.sub_mtrl.ExpPlateTreadSubMaterialReference.met_desc |
( |
|
args | ) |
|
def sds2.sub_mtrl.ExpPlateTreadSubMaterialReference.mtrl_idx |
( |
|
args | ) |
|
def sds2.sub_mtrl.ExpPlateTreadSubMaterialReference.mtrl_stbk |
( |
|
args | ) |
|
def sds2.sub_mtrl.ExpPlateTreadSubMaterialReference.mtrl_type |
( |
|
args | ) |
|
def sds2.sub_mtrl.ExpPlateTreadSubMaterialReference.mtrl_use |
( |
|
args | ) |
|
def sds2.sub_mtrl.ExpPlateTreadSubMaterialReference.needs_detail |
( |
|
args | ) |
|
def sds2.sub_mtrl.ExpPlateTreadSubMaterialReference.on_sheet |
( |
|
args | ) |
|
def sds2.sub_mtrl.ExpPlateTreadSubMaterialReference.origin |
( |
|
args | ) |
|
def sds2.sub_mtrl.ExpPlateTreadSubMaterialReference.osl |
( |
|
args | ) |
|
def sds2.sub_mtrl.ExpPlateTreadSubMaterialReference.part_length |
( |
|
args | ) |
|
def sds2.sub_mtrl.ExpPlateTreadSubMaterialReference.pcmk_hash |
( |
|
args | ) |
|
def sds2.sub_mtrl.ExpPlateTreadSubMaterialReference.pl_area |
( |
|
args | ) |
|
def sds2.sub_mtrl.ExpPlateTreadSubMaterialReference.public_pcmk |
( |
|
args | ) |
|
def sds2.sub_mtrl.ExpPlateTreadSubMaterialReference.quant |
( |
|
args | ) |
|
def sds2.sub_mtrl.ExpPlateTreadSubMaterialReference.rad |
( |
|
args | ) |
|
def sds2.sub_mtrl.ExpPlateTreadSubMaterialReference.reent_hole_dist |
( |
|
args | ) |
|
def sds2.sub_mtrl.ExpPlateTreadSubMaterialReference.ref_x |
( |
|
args | ) |
|
def sds2.sub_mtrl.ExpPlateTreadSubMaterialReference.ref_y |
( |
|
args | ) |
|
def sds2.sub_mtrl.ExpPlateTreadSubMaterialReference.rev_date |
( |
|
args | ) |
|
def sds2.sub_mtrl.ExpPlateTreadSubMaterialReference.rev_level |
( |
|
args | ) |
|
def sds2.sub_mtrl.ExpPlateTreadSubMaterialReference.right_btm_op_dim1 |
( |
|
args | ) |
|
def sds2.sub_mtrl.ExpPlateTreadSubMaterialReference.right_btm_op_dim2 |
( |
|
args | ) |
|
def sds2.sub_mtrl.ExpPlateTreadSubMaterialReference.right_btm_op_dim3 |
( |
|
args | ) |
|
def sds2.sub_mtrl.ExpPlateTreadSubMaterialReference.right_btm_op_dim4 |
( |
|
args | ) |
|
def sds2.sub_mtrl.ExpPlateTreadSubMaterialReference.right_btm_op_dim5 |
( |
|
args | ) |
|
def sds2.sub_mtrl.ExpPlateTreadSubMaterialReference.right_btm_op_dim6 |
( |
|
args | ) |
|
def sds2.sub_mtrl.ExpPlateTreadSubMaterialReference.right_btm_op_dim7 |
( |
|
args | ) |
|
def sds2.sub_mtrl.ExpPlateTreadSubMaterialReference.right_btm_op_dim8 |
( |
|
args | ) |
|
def sds2.sub_mtrl.ExpPlateTreadSubMaterialReference.right_btm_op_type |
( |
|
args | ) |
|
def sds2.sub_mtrl.ExpPlateTreadSubMaterialReference.right_top_op_dim1 |
( |
|
args | ) |
|
def sds2.sub_mtrl.ExpPlateTreadSubMaterialReference.right_top_op_dim2 |
( |
|
args | ) |
|
def sds2.sub_mtrl.ExpPlateTreadSubMaterialReference.right_top_op_dim3 |
( |
|
args | ) |
|
def sds2.sub_mtrl.ExpPlateTreadSubMaterialReference.right_top_op_dim4 |
( |
|
args | ) |
|
def sds2.sub_mtrl.ExpPlateTreadSubMaterialReference.right_top_op_dim5 |
( |
|
args | ) |
|
def sds2.sub_mtrl.ExpPlateTreadSubMaterialReference.right_top_op_dim6 |
( |
|
args | ) |
|
def sds2.sub_mtrl.ExpPlateTreadSubMaterialReference.right_top_op_dim7 |
( |
|
args | ) |
|
def sds2.sub_mtrl.ExpPlateTreadSubMaterialReference.right_top_op_dim8 |
( |
|
args | ) |
|
def sds2.sub_mtrl.ExpPlateTreadSubMaterialReference.right_top_op_type |
( |
|
args | ) |
|
def sds2.sub_mtrl.ExpPlateTreadSubMaterialReference.roll_type |
( |
|
args | ) |
|
def sds2.sub_mtrl.ExpPlateTreadSubMaterialReference.rolled_mtrl_ref_pt |
( |
|
args | ) |
|
def sds2.sub_mtrl.ExpPlateTreadSubMaterialReference.rolled_offset |
( |
|
args | ) |
|
def sds2.sub_mtrl.ExpPlateTreadSubMaterialReference.sec_hash |
( |
|
args | ) |
|
def sds2.sub_mtrl.ExpPlateTreadSubMaterialReference.srfc_area |
( |
|
args | ) |
|
def sds2.sub_mtrl.ExpPlateTreadSubMaterialReference.stair_mtrl_use |
( |
|
args | ) |
|
def sds2.sub_mtrl.ExpPlateTreadSubMaterialReference.std_mark |
( |
|
args | ) |
|
def sds2.sub_mtrl.ExpPlateTreadSubMaterialReference.stretched |
( |
|
args | ) |
|
def sds2.sub_mtrl.ExpPlateTreadSubMaterialReference.sub_mtrl_idx |
( |
|
args | ) |
|
def sds2.sub_mtrl.ExpPlateTreadSubMaterialReference.taper_rad |
( |
|
args | ) |
|
def sds2.sub_mtrl.ExpPlateTreadSubMaterialReference.thick |
( |
|
args | ) |
|
def sds2.sub_mtrl.ExpPlateTreadSubMaterialReference.thread_length |
( |
|
args | ) |
|
def sds2.sub_mtrl.ExpPlateTreadSubMaterialReference.thread_type |
( |
|
args | ) |
|
def sds2.sub_mtrl.ExpPlateTreadSubMaterialReference.toe_io |
( |
|
args | ) |
|
def sds2.sub_mtrl.ExpPlateTreadSubMaterialReference.trans_width |
( |
|
args | ) |
|
def sds2.sub_mtrl.ExpPlateTreadSubMaterialReference.twist |
( |
|
args | ) |
|
def sds2.sub_mtrl.ExpPlateTreadSubMaterialReference.usage |
( |
|
args | ) |
|
def sds2.sub_mtrl.ExpPlateTreadSubMaterialReference.user_description |
( |
|
args | ) |
|
def sds2.sub_mtrl.ExpPlateTreadSubMaterialReference.web_cut |
( |
|
args | ) |
|
def sds2.sub_mtrl.ExpPlateTreadSubMaterialReference.web_stbk |
( |
|
args | ) |
|
def sds2.sub_mtrl.ExpPlateTreadSubMaterialReference.weight |
( |
|
args | ) |
|
def sds2.sub_mtrl.ExpPlateTreadSubMaterialReference.width |
( |
|
args | ) |
|
def sds2.sub_mtrl.ExpPlateTreadSubMaterialReference.wkpt_slope |
( |
|
args | ) |
|