No documentation available.
More...
Data and other attributes defined here: |
def | __init__ |
Data and other attributes inherited from Boost.Python.instance: |
def | __new__ |
Additional Inherited Members |
Detailed Description
No documentation available.
Method resolution order
FlatPlateLayoutSubMaterialReference
GenMaterialSubMaterialReference
SubMaterialReference
Boost.Python.instance
builtin.object
Constructor & Destructor Documentation
def sds2.sub_mtrl.FlatPlateLayoutSubMaterialReference.__init__ |
( |
|
args | ) |
|
Member Function Documentation
def sds2.sub_mtrl.FlatPlateLayoutSubMaterialReference.__dict__ |
( |
|
args | ) |
|
def sds2.sub_mtrl.FlatPlateLayoutSubMaterialReference.__new__ |
( |
|
args | ) |
|
def sds2.sub_mtrl.FlatPlateLayoutSubMaterialReference.__reduce__ |
( |
|
args | ) |
|
def sds2.sub_mtrl.FlatPlateLayoutSubMaterialReference.__weakref__ |
( |
|
args | ) |
|
def sds2.sub_mtrl.FlatPlateLayoutSubMaterialReference.assm_mark |
( |
|
args | ) |
|
def sds2.sub_mtrl.FlatPlateLayoutSubMaterialReference.bar_stock |
( |
|
args | ) |
|
def sds2.sub_mtrl.FlatPlateLayoutSubMaterialReference.bend_angle |
( |
|
args | ) |
|
def sds2.sub_mtrl.FlatPlateLayoutSubMaterialReference.bend_rad |
( |
|
args | ) |
|
def sds2.sub_mtrl.FlatPlateLayoutSubMaterialReference.BuiltinMaterial |
( |
|
arg1 | ) |
|
- Returns
- Instance of type object
Return a BuiltinMaterial with the same properties as the
SubMaterialReference except with the color set to the job's
default color for the material type
C++ signature :
Alloy::Pointer::Pointer<MaterialBase> BuiltinMaterial(Entry<17>)
Return a BuiltinMaterial with the same properties as the
SubMaterialReference except with the option to override the color
C++ signature :
Alloy::Pointer::Pointer<MaterialBase> BuiltinMaterial(Entry<17>,bool)
- Note
- Additional signature: BuiltinMaterial( (SubMaterialReference)self, (bool)set_default_color) -> object
Reimplemented from sds2.sub_mtrl.GenMaterialSubMaterialReference.
def sds2.sub_mtrl.FlatPlateLayoutSubMaterialReference.camber |
( |
|
args | ) |
|
def sds2.sub_mtrl.FlatPlateLayoutSubMaterialReference.checkered |
( |
|
args | ) |
|
def sds2.sub_mtrl.FlatPlateLayoutSubMaterialReference.cnc_dld |
( |
|
args | ) |
|
def sds2.sub_mtrl.FlatPlateLayoutSubMaterialReference.control_file_entry_description |
( |
|
args | ) |
|
def sds2.sub_mtrl.FlatPlateLayoutSubMaterialReference.dim_weight |
( |
|
args | ) |
|
def sds2.sub_mtrl.FlatPlateLayoutSubMaterialReference.do_not_calc_poly_weight |
( |
|
args | ) |
|
def sds2.sub_mtrl.FlatPlateLayoutSubMaterialReference.do_not_scribe |
( |
|
args | ) |
|
def sds2.sub_mtrl.FlatPlateLayoutSubMaterialReference.dtl_quant |
( |
|
args | ) |
|
def sds2.sub_mtrl.FlatPlateLayoutSubMaterialReference.dtl_rev_level |
( |
|
args | ) |
|
def sds2.sub_mtrl.FlatPlateLayoutSubMaterialReference.dummy |
( |
|
args | ) |
|
def sds2.sub_mtrl.FlatPlateLayoutSubMaterialReference.effective_index |
( |
|
args | ) |
|
def sds2.sub_mtrl.FlatPlateLayoutSubMaterialReference.end_prep |
( |
|
args | ) |
|
def sds2.sub_mtrl.FlatPlateLayoutSubMaterialReference.existing |
( |
|
args | ) |
|
def sds2.sub_mtrl.FlatPlateLayoutSubMaterialReference.f_weld |
( |
|
args | ) |
|
def sds2.sub_mtrl.FlatPlateLayoutSubMaterialReference.fitted |
( |
|
args | ) |
|
def sds2.sub_mtrl.FlatPlateLayoutSubMaterialReference.flg_cut |
( |
|
args | ) |
|
def sds2.sub_mtrl.FlatPlateLayoutSubMaterialReference.flip |
( |
|
args | ) |
|
def sds2.sub_mtrl.FlatPlateLayoutSubMaterialReference.graph_comp_date |
( |
|
args | ) |
|
def sds2.sub_mtrl.FlatPlateLayoutSubMaterialReference.hash |
( |
|
args | ) |
|
def sds2.sub_mtrl.FlatPlateLayoutSubMaterialReference.imp_desc |
( |
|
args | ) |
|
def sds2.sub_mtrl.FlatPlateLayoutSubMaterialReference.info_type |
( |
|
args | ) |
|
def sds2.sub_mtrl.FlatPlateLayoutSubMaterialReference.last_quant |
( |
|
args | ) |
|
def sds2.sub_mtrl.FlatPlateLayoutSubMaterialReference.last_rev_level |
( |
|
args | ) |
|
def sds2.sub_mtrl.FlatPlateLayoutSubMaterialReference.left_btm_op_dim1 |
( |
|
args | ) |
|
def sds2.sub_mtrl.FlatPlateLayoutSubMaterialReference.left_btm_op_dim2 |
( |
|
args | ) |
|
def sds2.sub_mtrl.FlatPlateLayoutSubMaterialReference.left_btm_op_dim3 |
( |
|
args | ) |
|
def sds2.sub_mtrl.FlatPlateLayoutSubMaterialReference.left_btm_op_dim4 |
( |
|
args | ) |
|
def sds2.sub_mtrl.FlatPlateLayoutSubMaterialReference.left_btm_op_dim5 |
( |
|
args | ) |
|
def sds2.sub_mtrl.FlatPlateLayoutSubMaterialReference.left_btm_op_dim6 |
( |
|
args | ) |
|
def sds2.sub_mtrl.FlatPlateLayoutSubMaterialReference.left_btm_op_dim7 |
( |
|
args | ) |
|
def sds2.sub_mtrl.FlatPlateLayoutSubMaterialReference.left_btm_op_dim8 |
( |
|
args | ) |
|
def sds2.sub_mtrl.FlatPlateLayoutSubMaterialReference.left_btm_op_type |
( |
|
args | ) |
|
def sds2.sub_mtrl.FlatPlateLayoutSubMaterialReference.left_top_op_dim1 |
( |
|
args | ) |
|
def sds2.sub_mtrl.FlatPlateLayoutSubMaterialReference.left_top_op_dim2 |
( |
|
args | ) |
|
def sds2.sub_mtrl.FlatPlateLayoutSubMaterialReference.left_top_op_dim3 |
( |
|
args | ) |
|
def sds2.sub_mtrl.FlatPlateLayoutSubMaterialReference.left_top_op_dim4 |
( |
|
args | ) |
|
def sds2.sub_mtrl.FlatPlateLayoutSubMaterialReference.left_top_op_dim5 |
( |
|
args | ) |
|
def sds2.sub_mtrl.FlatPlateLayoutSubMaterialReference.left_top_op_dim6 |
( |
|
args | ) |
|
def sds2.sub_mtrl.FlatPlateLayoutSubMaterialReference.left_top_op_dim7 |
( |
|
args | ) |
|
def sds2.sub_mtrl.FlatPlateLayoutSubMaterialReference.left_top_op_dim8 |
( |
|
args | ) |
|
def sds2.sub_mtrl.FlatPlateLayoutSubMaterialReference.left_top_op_type |
( |
|
args | ) |
|
def sds2.sub_mtrl.FlatPlateLayoutSubMaterialReference.leg |
( |
|
args | ) |
|
def sds2.sub_mtrl.FlatPlateLayoutSubMaterialReference.length |
( |
|
args | ) |
|
def sds2.sub_mtrl.FlatPlateLayoutSubMaterialReference.llv |
( |
|
args | ) |
|
def sds2.sub_mtrl.FlatPlateLayoutSubMaterialReference.met_desc |
( |
|
args | ) |
|
def sds2.sub_mtrl.FlatPlateLayoutSubMaterialReference.mtrl_idx |
( |
|
args | ) |
|
def sds2.sub_mtrl.FlatPlateLayoutSubMaterialReference.mtrl_stbk |
( |
|
args | ) |
|
def sds2.sub_mtrl.FlatPlateLayoutSubMaterialReference.mtrl_type |
( |
|
args | ) |
|
def sds2.sub_mtrl.FlatPlateLayoutSubMaterialReference.mtrl_use |
( |
|
args | ) |
|
def sds2.sub_mtrl.FlatPlateLayoutSubMaterialReference.needs_detail |
( |
|
args | ) |
|
def sds2.sub_mtrl.FlatPlateLayoutSubMaterialReference.on_sheet |
( |
|
args | ) |
|
def sds2.sub_mtrl.FlatPlateLayoutSubMaterialReference.origin |
( |
|
args | ) |
|
def sds2.sub_mtrl.FlatPlateLayoutSubMaterialReference.osl |
( |
|
args | ) |
|
def sds2.sub_mtrl.FlatPlateLayoutSubMaterialReference.part_length |
( |
|
args | ) |
|
def sds2.sub_mtrl.FlatPlateLayoutSubMaterialReference.pcmk_hash |
( |
|
args | ) |
|
def sds2.sub_mtrl.FlatPlateLayoutSubMaterialReference.pl_area |
( |
|
args | ) |
|
def sds2.sub_mtrl.FlatPlateLayoutSubMaterialReference.public_pcmk |
( |
|
args | ) |
|
def sds2.sub_mtrl.FlatPlateLayoutSubMaterialReference.quant |
( |
|
args | ) |
|
def sds2.sub_mtrl.FlatPlateLayoutSubMaterialReference.rad |
( |
|
args | ) |
|
def sds2.sub_mtrl.FlatPlateLayoutSubMaterialReference.reent_hole_dist |
( |
|
args | ) |
|
def sds2.sub_mtrl.FlatPlateLayoutSubMaterialReference.ref_x |
( |
|
args | ) |
|
def sds2.sub_mtrl.FlatPlateLayoutSubMaterialReference.ref_y |
( |
|
args | ) |
|
def sds2.sub_mtrl.FlatPlateLayoutSubMaterialReference.rev_date |
( |
|
args | ) |
|
def sds2.sub_mtrl.FlatPlateLayoutSubMaterialReference.rev_level |
( |
|
args | ) |
|
def sds2.sub_mtrl.FlatPlateLayoutSubMaterialReference.right_btm_op_dim1 |
( |
|
args | ) |
|
def sds2.sub_mtrl.FlatPlateLayoutSubMaterialReference.right_btm_op_dim2 |
( |
|
args | ) |
|
def sds2.sub_mtrl.FlatPlateLayoutSubMaterialReference.right_btm_op_dim3 |
( |
|
args | ) |
|
def sds2.sub_mtrl.FlatPlateLayoutSubMaterialReference.right_btm_op_dim4 |
( |
|
args | ) |
|
def sds2.sub_mtrl.FlatPlateLayoutSubMaterialReference.right_btm_op_dim5 |
( |
|
args | ) |
|
def sds2.sub_mtrl.FlatPlateLayoutSubMaterialReference.right_btm_op_dim6 |
( |
|
args | ) |
|
def sds2.sub_mtrl.FlatPlateLayoutSubMaterialReference.right_btm_op_dim7 |
( |
|
args | ) |
|
def sds2.sub_mtrl.FlatPlateLayoutSubMaterialReference.right_btm_op_dim8 |
( |
|
args | ) |
|
def sds2.sub_mtrl.FlatPlateLayoutSubMaterialReference.right_btm_op_type |
( |
|
args | ) |
|
def sds2.sub_mtrl.FlatPlateLayoutSubMaterialReference.right_top_op_dim1 |
( |
|
args | ) |
|
def sds2.sub_mtrl.FlatPlateLayoutSubMaterialReference.right_top_op_dim2 |
( |
|
args | ) |
|
def sds2.sub_mtrl.FlatPlateLayoutSubMaterialReference.right_top_op_dim3 |
( |
|
args | ) |
|
def sds2.sub_mtrl.FlatPlateLayoutSubMaterialReference.right_top_op_dim4 |
( |
|
args | ) |
|
def sds2.sub_mtrl.FlatPlateLayoutSubMaterialReference.right_top_op_dim5 |
( |
|
args | ) |
|
def sds2.sub_mtrl.FlatPlateLayoutSubMaterialReference.right_top_op_dim6 |
( |
|
args | ) |
|
def sds2.sub_mtrl.FlatPlateLayoutSubMaterialReference.right_top_op_dim7 |
( |
|
args | ) |
|
def sds2.sub_mtrl.FlatPlateLayoutSubMaterialReference.right_top_op_dim8 |
( |
|
args | ) |
|
def sds2.sub_mtrl.FlatPlateLayoutSubMaterialReference.right_top_op_type |
( |
|
args | ) |
|
def sds2.sub_mtrl.FlatPlateLayoutSubMaterialReference.roll_type |
( |
|
args | ) |
|
def sds2.sub_mtrl.FlatPlateLayoutSubMaterialReference.rolled_mtrl_ref_pt |
( |
|
args | ) |
|
def sds2.sub_mtrl.FlatPlateLayoutSubMaterialReference.rolled_offset |
( |
|
args | ) |
|
def sds2.sub_mtrl.FlatPlateLayoutSubMaterialReference.sec_hash |
( |
|
args | ) |
|
def sds2.sub_mtrl.FlatPlateLayoutSubMaterialReference.srfc_area |
( |
|
args | ) |
|
def sds2.sub_mtrl.FlatPlateLayoutSubMaterialReference.stair_mtrl_use |
( |
|
args | ) |
|
def sds2.sub_mtrl.FlatPlateLayoutSubMaterialReference.std_mark |
( |
|
args | ) |
|
def sds2.sub_mtrl.FlatPlateLayoutSubMaterialReference.stretched |
( |
|
args | ) |
|
def sds2.sub_mtrl.FlatPlateLayoutSubMaterialReference.sub_mtrl_idx |
( |
|
args | ) |
|
def sds2.sub_mtrl.FlatPlateLayoutSubMaterialReference.taper_rad |
( |
|
args | ) |
|
def sds2.sub_mtrl.FlatPlateLayoutSubMaterialReference.thick |
( |
|
args | ) |
|
def sds2.sub_mtrl.FlatPlateLayoutSubMaterialReference.thread_length |
( |
|
args | ) |
|
def sds2.sub_mtrl.FlatPlateLayoutSubMaterialReference.thread_type |
( |
|
args | ) |
|
def sds2.sub_mtrl.FlatPlateLayoutSubMaterialReference.toe_io |
( |
|
args | ) |
|
def sds2.sub_mtrl.FlatPlateLayoutSubMaterialReference.trans_width |
( |
|
args | ) |
|
def sds2.sub_mtrl.FlatPlateLayoutSubMaterialReference.twist |
( |
|
args | ) |
|
def sds2.sub_mtrl.FlatPlateLayoutSubMaterialReference.usage |
( |
|
args | ) |
|
def sds2.sub_mtrl.FlatPlateLayoutSubMaterialReference.user_description |
( |
|
args | ) |
|
def sds2.sub_mtrl.FlatPlateLayoutSubMaterialReference.web_cut |
( |
|
args | ) |
|
def sds2.sub_mtrl.FlatPlateLayoutSubMaterialReference.web_stbk |
( |
|
args | ) |
|
def sds2.sub_mtrl.FlatPlateLayoutSubMaterialReference.weight |
( |
|
args | ) |
|
def sds2.sub_mtrl.FlatPlateLayoutSubMaterialReference.width |
( |
|
args | ) |
|
def sds2.sub_mtrl.FlatPlateLayoutSubMaterialReference.wkpt_slope |
( |
|
args | ) |
|