No documentation available.
More...
Data and other attributes defined here: |
def | __init__ |
Data and other attributes inherited from Boost.Python.instance: |
def | __new__ |
Detailed Description
No documentation available.
Method resolution order
GratingTreadSubMaterialReference
SubMaterialReference
Boost.Python.instance
builtin.object
Constructor & Destructor Documentation
def sds2.sub_mtrl.GratingTreadSubMaterialReference.__init__ |
( |
|
args | ) |
|
Raises an exception
This class cannot be instantiated from Python
__init__ = <built-in function __init__>
Member Function Documentation
def sds2.sub_mtrl.GratingTreadSubMaterialReference.__dict__ |
( |
|
args | ) |
|
def sds2.sub_mtrl.GratingTreadSubMaterialReference.__new__ |
( |
|
args | ) |
|
T.__new__(S, ...) -> a new object with type S, a subtype of T
__new__ = <built-in method __new__ of Boost.Python.class object>
def sds2.sub_mtrl.GratingTreadSubMaterialReference.__reduce__ |
( |
|
args | ) |
|
__reduce__ = <unnamed Boost.Python function>(args)
def sds2.sub_mtrl.GratingTreadSubMaterialReference.__weakref__ |
( |
|
args | ) |
|
def sds2.sub_mtrl.GratingTreadSubMaterialReference.assm_mark |
( |
|
args | ) |
|
def sds2.sub_mtrl.GratingTreadSubMaterialReference.bbar_spa |
( |
|
args | ) |
|
def sds2.sub_mtrl.GratingTreadSubMaterialReference.bbar_thick |
( |
|
args | ) |
|
def sds2.sub_mtrl.GratingTreadSubMaterialReference.bbar_width |
( |
|
args | ) |
|
def sds2.sub_mtrl.GratingTreadSubMaterialReference.bdia |
( |
|
args | ) |
|
def sds2.sub_mtrl.GratingTreadSubMaterialReference.BuiltinMaterial |
( |
|
arg1 | ) |
|
- Returns
- Instance of type object
Return a BuiltinMaterial with the same properties as the
SubMaterialReference except with the color set to the job's
default color for the material type
C++ signature :
Alloy::Pointer::Pointer<MaterialBase> BuiltinMaterial(Entry<17>)
Return a BuiltinMaterial with the same properties as the
SubMaterialReference except with the option to override the color
C++ signature :
Alloy::Pointer::Pointer<MaterialBase> BuiltinMaterial(Entry<17>,bool)
- Note
- Additional signature: BuiltinMaterial( (SubMaterialReference)self, (bool)set_default_color) -> object
def sds2.sub_mtrl.GratingTreadSubMaterialReference.cbar_spa |
( |
|
args | ) |
|
def sds2.sub_mtrl.GratingTreadSubMaterialReference.cbar_thick |
( |
|
args | ) |
|
def sds2.sub_mtrl.GratingTreadSubMaterialReference.cbar_width |
( |
|
args | ) |
|
def sds2.sub_mtrl.GratingTreadSubMaterialReference.cnc_dld |
( |
|
args | ) |
|
def sds2.sub_mtrl.GratingTreadSubMaterialReference.control_file_entry_description |
( |
|
args | ) |
|
def sds2.sub_mtrl.GratingTreadSubMaterialReference.dim_weight |
( |
|
args | ) |
|
def sds2.sub_mtrl.GratingTreadSubMaterialReference.dist_x |
( |
|
args | ) |
|
def sds2.sub_mtrl.GratingTreadSubMaterialReference.dist_y |
( |
|
args | ) |
|
def sds2.sub_mtrl.GratingTreadSubMaterialReference.do_not_calc_poly_weight |
( |
|
args | ) |
|
def sds2.sub_mtrl.GratingTreadSubMaterialReference.do_not_scribe |
( |
|
args | ) |
|
def sds2.sub_mtrl.GratingTreadSubMaterialReference.dtl_quant |
( |
|
args | ) |
|
def sds2.sub_mtrl.GratingTreadSubMaterialReference.dtl_rev_level |
( |
|
args | ) |
|
def sds2.sub_mtrl.GratingTreadSubMaterialReference.dummy |
( |
|
args | ) |
|
def sds2.sub_mtrl.GratingTreadSubMaterialReference.effective_index |
( |
|
args | ) |
|
def sds2.sub_mtrl.GratingTreadSubMaterialReference.end_thick |
( |
|
args | ) |
|
def sds2.sub_mtrl.GratingTreadSubMaterialReference.end_width |
( |
|
args | ) |
|
def sds2.sub_mtrl.GratingTreadSubMaterialReference.existing |
( |
|
args | ) |
|
def sds2.sub_mtrl.GratingTreadSubMaterialReference.fitted |
( |
|
args | ) |
|
def sds2.sub_mtrl.GratingTreadSubMaterialReference.graph_comp_date |
( |
|
args | ) |
|
def sds2.sub_mtrl.GratingTreadSubMaterialReference.hash |
( |
|
args | ) |
|
def sds2.sub_mtrl.GratingTreadSubMaterialReference.imp_desc |
( |
|
args | ) |
|
def sds2.sub_mtrl.GratingTreadSubMaterialReference.info_type |
( |
|
args | ) |
|
def sds2.sub_mtrl.GratingTreadSubMaterialReference.last_quant |
( |
|
args | ) |
|
def sds2.sub_mtrl.GratingTreadSubMaterialReference.last_rev_level |
( |
|
args | ) |
|
def sds2.sub_mtrl.GratingTreadSubMaterialReference.length |
( |
|
args | ) |
|
def sds2.sub_mtrl.GratingTreadSubMaterialReference.met_desc |
( |
|
args | ) |
|
def sds2.sub_mtrl.GratingTreadSubMaterialReference.mtrl_idx |
( |
|
args | ) |
|
def sds2.sub_mtrl.GratingTreadSubMaterialReference.mtrl_type |
( |
|
args | ) |
|
def sds2.sub_mtrl.GratingTreadSubMaterialReference.needs_detail |
( |
|
args | ) |
|
def sds2.sub_mtrl.GratingTreadSubMaterialReference.nosing_width |
( |
|
args | ) |
|
def sds2.sub_mtrl.GratingTreadSubMaterialReference.num_bars |
( |
|
args | ) |
|
def sds2.sub_mtrl.GratingTreadSubMaterialReference.on_sheet |
( |
|
args | ) |
|
def sds2.sub_mtrl.GratingTreadSubMaterialReference.pcmk_hash |
( |
|
args | ) |
|
def sds2.sub_mtrl.GratingTreadSubMaterialReference.public_pcmk |
( |
|
args | ) |
|
def sds2.sub_mtrl.GratingTreadSubMaterialReference.quant |
( |
|
args | ) |
|
def sds2.sub_mtrl.GratingTreadSubMaterialReference.ref_x |
( |
|
args | ) |
|
def sds2.sub_mtrl.GratingTreadSubMaterialReference.ref_y |
( |
|
args | ) |
|
def sds2.sub_mtrl.GratingTreadSubMaterialReference.rev_date |
( |
|
args | ) |
|
def sds2.sub_mtrl.GratingTreadSubMaterialReference.rev_level |
( |
|
args | ) |
|
def sds2.sub_mtrl.GratingTreadSubMaterialReference.sec_hash |
( |
|
args | ) |
|
def sds2.sub_mtrl.GratingTreadSubMaterialReference.spa |
( |
|
args | ) |
|
def sds2.sub_mtrl.GratingTreadSubMaterialReference.srfc_area |
( |
|
args | ) |
|
def sds2.sub_mtrl.GratingTreadSubMaterialReference.std_mark |
( |
|
args | ) |
|
def sds2.sub_mtrl.GratingTreadSubMaterialReference.stretched |
( |
|
args | ) |
|
def sds2.sub_mtrl.GratingTreadSubMaterialReference.sub_mtrl_idx |
( |
|
args | ) |
|
def sds2.sub_mtrl.GratingTreadSubMaterialReference.usage |
( |
|
args | ) |
|
def sds2.sub_mtrl.GratingTreadSubMaterialReference.user_description |
( |
|
args | ) |
|
def sds2.sub_mtrl.GratingTreadSubMaterialReference.weight |
( |
|
args | ) |
|
def sds2.sub_mtrl.GratingTreadSubMaterialReference.width |
( |
|
args | ) |
|