No documentation available.
More...
Data and other attributes defined here: |
def | __init__ |
Data and other attributes inherited from Boost.Python.instance: |
def | __new__ |
Additional Inherited Members |
Detailed Description
No documentation available.
Method resolution order
PlateBoxSectionSubMaterialReference
GenMaterialSubMaterialReference
SubMaterialReference
Boost.Python.instance
builtin.object
Constructor & Destructor Documentation
def sds2.sub_mtrl.PlateBoxSectionSubMaterialReference.__init__ |
( |
|
args | ) |
|
Member Function Documentation
def sds2.sub_mtrl.PlateBoxSectionSubMaterialReference.__dict__ |
( |
|
args | ) |
|
def sds2.sub_mtrl.PlateBoxSectionSubMaterialReference.__new__ |
( |
|
args | ) |
|
def sds2.sub_mtrl.PlateBoxSectionSubMaterialReference.__reduce__ |
( |
|
args | ) |
|
def sds2.sub_mtrl.PlateBoxSectionSubMaterialReference.__weakref__ |
( |
|
args | ) |
|
def sds2.sub_mtrl.PlateBoxSectionSubMaterialReference.assm_mark |
( |
|
args | ) |
|
def sds2.sub_mtrl.PlateBoxSectionSubMaterialReference.bar_stock |
( |
|
args | ) |
|
def sds2.sub_mtrl.PlateBoxSectionSubMaterialReference.bend_angle |
( |
|
args | ) |
|
def sds2.sub_mtrl.PlateBoxSectionSubMaterialReference.bend_rad |
( |
|
args | ) |
|
def sds2.sub_mtrl.PlateBoxSectionSubMaterialReference.BuiltinMaterial |
( |
|
arg1 | ) |
|
- Returns
- Instance of type object
Return a BuiltinMaterial with the same properties as the
SubMaterialReference except with the color set to the job's
default color for the material type
C++ signature :
Alloy::Pointer::Pointer<MaterialBase> BuiltinMaterial(Entry<17>)
Return a BuiltinMaterial with the same properties as the
SubMaterialReference except with the option to override the color
C++ signature :
Alloy::Pointer::Pointer<MaterialBase> BuiltinMaterial(Entry<17>,bool)
- Note
- Additional signature: BuiltinMaterial( (SubMaterialReference)self, (bool)set_default_color) -> object
Reimplemented from sds2.sub_mtrl.GenMaterialSubMaterialReference.
def sds2.sub_mtrl.PlateBoxSectionSubMaterialReference.camber |
( |
|
args | ) |
|
def sds2.sub_mtrl.PlateBoxSectionSubMaterialReference.checkered |
( |
|
args | ) |
|
def sds2.sub_mtrl.PlateBoxSectionSubMaterialReference.cnc_dld |
( |
|
args | ) |
|
def sds2.sub_mtrl.PlateBoxSectionSubMaterialReference.control_file_entry_description |
( |
|
args | ) |
|
def sds2.sub_mtrl.PlateBoxSectionSubMaterialReference.dim_weight |
( |
|
args | ) |
|
def sds2.sub_mtrl.PlateBoxSectionSubMaterialReference.do_not_calc_poly_weight |
( |
|
args | ) |
|
def sds2.sub_mtrl.PlateBoxSectionSubMaterialReference.do_not_scribe |
( |
|
args | ) |
|
def sds2.sub_mtrl.PlateBoxSectionSubMaterialReference.dtl_quant |
( |
|
args | ) |
|
def sds2.sub_mtrl.PlateBoxSectionSubMaterialReference.dtl_rev_level |
( |
|
args | ) |
|
def sds2.sub_mtrl.PlateBoxSectionSubMaterialReference.dummy |
( |
|
args | ) |
|
def sds2.sub_mtrl.PlateBoxSectionSubMaterialReference.effective_index |
( |
|
args | ) |
|
def sds2.sub_mtrl.PlateBoxSectionSubMaterialReference.end_prep |
( |
|
args | ) |
|
def sds2.sub_mtrl.PlateBoxSectionSubMaterialReference.existing |
( |
|
args | ) |
|
def sds2.sub_mtrl.PlateBoxSectionSubMaterialReference.f_weld |
( |
|
args | ) |
|
def sds2.sub_mtrl.PlateBoxSectionSubMaterialReference.fitted |
( |
|
args | ) |
|
def sds2.sub_mtrl.PlateBoxSectionSubMaterialReference.flg_cut |
( |
|
args | ) |
|
def sds2.sub_mtrl.PlateBoxSectionSubMaterialReference.flip |
( |
|
args | ) |
|
def sds2.sub_mtrl.PlateBoxSectionSubMaterialReference.graph_comp_date |
( |
|
args | ) |
|
def sds2.sub_mtrl.PlateBoxSectionSubMaterialReference.hash |
( |
|
args | ) |
|
def sds2.sub_mtrl.PlateBoxSectionSubMaterialReference.imp_desc |
( |
|
args | ) |
|
def sds2.sub_mtrl.PlateBoxSectionSubMaterialReference.info_type |
( |
|
args | ) |
|
def sds2.sub_mtrl.PlateBoxSectionSubMaterialReference.last_quant |
( |
|
args | ) |
|
def sds2.sub_mtrl.PlateBoxSectionSubMaterialReference.last_rev_level |
( |
|
args | ) |
|
def sds2.sub_mtrl.PlateBoxSectionSubMaterialReference.left_btm_op_dim1 |
( |
|
args | ) |
|
def sds2.sub_mtrl.PlateBoxSectionSubMaterialReference.left_btm_op_dim2 |
( |
|
args | ) |
|
def sds2.sub_mtrl.PlateBoxSectionSubMaterialReference.left_btm_op_dim3 |
( |
|
args | ) |
|
def sds2.sub_mtrl.PlateBoxSectionSubMaterialReference.left_btm_op_dim4 |
( |
|
args | ) |
|
def sds2.sub_mtrl.PlateBoxSectionSubMaterialReference.left_btm_op_dim5 |
( |
|
args | ) |
|
def sds2.sub_mtrl.PlateBoxSectionSubMaterialReference.left_btm_op_dim6 |
( |
|
args | ) |
|
def sds2.sub_mtrl.PlateBoxSectionSubMaterialReference.left_btm_op_dim7 |
( |
|
args | ) |
|
def sds2.sub_mtrl.PlateBoxSectionSubMaterialReference.left_btm_op_dim8 |
( |
|
args | ) |
|
def sds2.sub_mtrl.PlateBoxSectionSubMaterialReference.left_btm_op_type |
( |
|
args | ) |
|
def sds2.sub_mtrl.PlateBoxSectionSubMaterialReference.left_top_op_dim1 |
( |
|
args | ) |
|
def sds2.sub_mtrl.PlateBoxSectionSubMaterialReference.left_top_op_dim2 |
( |
|
args | ) |
|
def sds2.sub_mtrl.PlateBoxSectionSubMaterialReference.left_top_op_dim3 |
( |
|
args | ) |
|
def sds2.sub_mtrl.PlateBoxSectionSubMaterialReference.left_top_op_dim4 |
( |
|
args | ) |
|
def sds2.sub_mtrl.PlateBoxSectionSubMaterialReference.left_top_op_dim5 |
( |
|
args | ) |
|
def sds2.sub_mtrl.PlateBoxSectionSubMaterialReference.left_top_op_dim6 |
( |
|
args | ) |
|
def sds2.sub_mtrl.PlateBoxSectionSubMaterialReference.left_top_op_dim7 |
( |
|
args | ) |
|
def sds2.sub_mtrl.PlateBoxSectionSubMaterialReference.left_top_op_dim8 |
( |
|
args | ) |
|
def sds2.sub_mtrl.PlateBoxSectionSubMaterialReference.left_top_op_type |
( |
|
args | ) |
|
def sds2.sub_mtrl.PlateBoxSectionSubMaterialReference.leg |
( |
|
args | ) |
|
def sds2.sub_mtrl.PlateBoxSectionSubMaterialReference.length |
( |
|
args | ) |
|
def sds2.sub_mtrl.PlateBoxSectionSubMaterialReference.llv |
( |
|
args | ) |
|
def sds2.sub_mtrl.PlateBoxSectionSubMaterialReference.met_desc |
( |
|
args | ) |
|
def sds2.sub_mtrl.PlateBoxSectionSubMaterialReference.mtrl_idx |
( |
|
args | ) |
|
def sds2.sub_mtrl.PlateBoxSectionSubMaterialReference.mtrl_stbk |
( |
|
args | ) |
|
def sds2.sub_mtrl.PlateBoxSectionSubMaterialReference.mtrl_type |
( |
|
args | ) |
|
def sds2.sub_mtrl.PlateBoxSectionSubMaterialReference.mtrl_use |
( |
|
args | ) |
|
def sds2.sub_mtrl.PlateBoxSectionSubMaterialReference.needs_detail |
( |
|
args | ) |
|
def sds2.sub_mtrl.PlateBoxSectionSubMaterialReference.on_sheet |
( |
|
args | ) |
|
def sds2.sub_mtrl.PlateBoxSectionSubMaterialReference.origin |
( |
|
args | ) |
|
def sds2.sub_mtrl.PlateBoxSectionSubMaterialReference.osl |
( |
|
args | ) |
|
def sds2.sub_mtrl.PlateBoxSectionSubMaterialReference.part_length |
( |
|
args | ) |
|
def sds2.sub_mtrl.PlateBoxSectionSubMaterialReference.pcmk_hash |
( |
|
args | ) |
|
def sds2.sub_mtrl.PlateBoxSectionSubMaterialReference.pl_area |
( |
|
args | ) |
|
def sds2.sub_mtrl.PlateBoxSectionSubMaterialReference.public_pcmk |
( |
|
args | ) |
|
def sds2.sub_mtrl.PlateBoxSectionSubMaterialReference.quant |
( |
|
args | ) |
|
def sds2.sub_mtrl.PlateBoxSectionSubMaterialReference.rad |
( |
|
args | ) |
|
def sds2.sub_mtrl.PlateBoxSectionSubMaterialReference.reent_hole_dist |
( |
|
args | ) |
|
def sds2.sub_mtrl.PlateBoxSectionSubMaterialReference.ref_x |
( |
|
args | ) |
|
def sds2.sub_mtrl.PlateBoxSectionSubMaterialReference.ref_y |
( |
|
args | ) |
|
def sds2.sub_mtrl.PlateBoxSectionSubMaterialReference.rev_date |
( |
|
args | ) |
|
def sds2.sub_mtrl.PlateBoxSectionSubMaterialReference.rev_level |
( |
|
args | ) |
|
def sds2.sub_mtrl.PlateBoxSectionSubMaterialReference.right_btm_op_dim1 |
( |
|
args | ) |
|
def sds2.sub_mtrl.PlateBoxSectionSubMaterialReference.right_btm_op_dim2 |
( |
|
args | ) |
|
def sds2.sub_mtrl.PlateBoxSectionSubMaterialReference.right_btm_op_dim3 |
( |
|
args | ) |
|
def sds2.sub_mtrl.PlateBoxSectionSubMaterialReference.right_btm_op_dim4 |
( |
|
args | ) |
|
def sds2.sub_mtrl.PlateBoxSectionSubMaterialReference.right_btm_op_dim5 |
( |
|
args | ) |
|
def sds2.sub_mtrl.PlateBoxSectionSubMaterialReference.right_btm_op_dim6 |
( |
|
args | ) |
|
def sds2.sub_mtrl.PlateBoxSectionSubMaterialReference.right_btm_op_dim7 |
( |
|
args | ) |
|
def sds2.sub_mtrl.PlateBoxSectionSubMaterialReference.right_btm_op_dim8 |
( |
|
args | ) |
|
def sds2.sub_mtrl.PlateBoxSectionSubMaterialReference.right_btm_op_type |
( |
|
args | ) |
|
def sds2.sub_mtrl.PlateBoxSectionSubMaterialReference.right_top_op_dim1 |
( |
|
args | ) |
|
def sds2.sub_mtrl.PlateBoxSectionSubMaterialReference.right_top_op_dim2 |
( |
|
args | ) |
|
def sds2.sub_mtrl.PlateBoxSectionSubMaterialReference.right_top_op_dim3 |
( |
|
args | ) |
|
def sds2.sub_mtrl.PlateBoxSectionSubMaterialReference.right_top_op_dim4 |
( |
|
args | ) |
|
def sds2.sub_mtrl.PlateBoxSectionSubMaterialReference.right_top_op_dim5 |
( |
|
args | ) |
|
def sds2.sub_mtrl.PlateBoxSectionSubMaterialReference.right_top_op_dim6 |
( |
|
args | ) |
|
def sds2.sub_mtrl.PlateBoxSectionSubMaterialReference.right_top_op_dim7 |
( |
|
args | ) |
|
def sds2.sub_mtrl.PlateBoxSectionSubMaterialReference.right_top_op_dim8 |
( |
|
args | ) |
|
def sds2.sub_mtrl.PlateBoxSectionSubMaterialReference.right_top_op_type |
( |
|
args | ) |
|
def sds2.sub_mtrl.PlateBoxSectionSubMaterialReference.roll_type |
( |
|
args | ) |
|
def sds2.sub_mtrl.PlateBoxSectionSubMaterialReference.rolled_mtrl_ref_pt |
( |
|
args | ) |
|
def sds2.sub_mtrl.PlateBoxSectionSubMaterialReference.rolled_offset |
( |
|
args | ) |
|
def sds2.sub_mtrl.PlateBoxSectionSubMaterialReference.sec_hash |
( |
|
args | ) |
|
def sds2.sub_mtrl.PlateBoxSectionSubMaterialReference.srfc_area |
( |
|
args | ) |
|
def sds2.sub_mtrl.PlateBoxSectionSubMaterialReference.stair_mtrl_use |
( |
|
args | ) |
|
def sds2.sub_mtrl.PlateBoxSectionSubMaterialReference.std_mark |
( |
|
args | ) |
|
def sds2.sub_mtrl.PlateBoxSectionSubMaterialReference.stretched |
( |
|
args | ) |
|
def sds2.sub_mtrl.PlateBoxSectionSubMaterialReference.sub_mtrl_idx |
( |
|
args | ) |
|
def sds2.sub_mtrl.PlateBoxSectionSubMaterialReference.taper_rad |
( |
|
args | ) |
|
def sds2.sub_mtrl.PlateBoxSectionSubMaterialReference.thick |
( |
|
args | ) |
|
def sds2.sub_mtrl.PlateBoxSectionSubMaterialReference.thread_length |
( |
|
args | ) |
|
def sds2.sub_mtrl.PlateBoxSectionSubMaterialReference.thread_type |
( |
|
args | ) |
|
def sds2.sub_mtrl.PlateBoxSectionSubMaterialReference.toe_io |
( |
|
args | ) |
|
def sds2.sub_mtrl.PlateBoxSectionSubMaterialReference.trans_width |
( |
|
args | ) |
|
def sds2.sub_mtrl.PlateBoxSectionSubMaterialReference.twist |
( |
|
args | ) |
|
def sds2.sub_mtrl.PlateBoxSectionSubMaterialReference.usage |
( |
|
args | ) |
|
def sds2.sub_mtrl.PlateBoxSectionSubMaterialReference.user_description |
( |
|
args | ) |
|
def sds2.sub_mtrl.PlateBoxSectionSubMaterialReference.web_cut |
( |
|
args | ) |
|
def sds2.sub_mtrl.PlateBoxSectionSubMaterialReference.web_stbk |
( |
|
args | ) |
|
def sds2.sub_mtrl.PlateBoxSectionSubMaterialReference.weight |
( |
|
args | ) |
|
def sds2.sub_mtrl.PlateBoxSectionSubMaterialReference.width |
( |
|
args | ) |
|
def sds2.sub_mtrl.PlateBoxSectionSubMaterialReference.wkpt_slope |
( |
|
args | ) |
|