No documentation available.
More...
Data and other attributes defined here: |
def | __init__ |
Data and other attributes inherited from Boost.Python.instance: |
def | __new__ |
Detailed Description
No documentation available.
Method resolution order
ShearStudSubMaterialReference
SubMaterialReference
Boost.Python.instance
builtin.object
Constructor & Destructor Documentation
def sds2.sub_mtrl.ShearStudSubMaterialReference.__init__ |
( |
|
args | ) |
|
Raises an exception
This class cannot be instantiated from Python
__init__ = <built-in function __init__>
Member Function Documentation
def sds2.sub_mtrl.ShearStudSubMaterialReference.__dict__ |
( |
|
args | ) |
|
def sds2.sub_mtrl.ShearStudSubMaterialReference.__new__ |
( |
|
args | ) |
|
T.__new__(S, ...) -> a new object with type S, a subtype of T
__new__ = <built-in method __new__ of Boost.Python.class object>
def sds2.sub_mtrl.ShearStudSubMaterialReference.__reduce__ |
( |
|
args | ) |
|
__reduce__ = <unnamed Boost.Python function>(args)
def sds2.sub_mtrl.ShearStudSubMaterialReference.__weakref__ |
( |
|
args | ) |
|
def sds2.sub_mtrl.ShearStudSubMaterialReference.assm_mark |
( |
|
args | ) |
|
def sds2.sub_mtrl.ShearStudSubMaterialReference.BuiltinMaterial |
( |
|
arg1 | ) |
|
- Returns
- Instance of type object
Return a BuiltinMaterial with the same properties as the
SubMaterialReference except with the color set to the job's
default color for the material type
C++ signature :
Alloy::Pointer::Pointer<MaterialBase> BuiltinMaterial(Entry<17>)
Return a BuiltinMaterial with the same properties as the
SubMaterialReference except with the option to override the color
C++ signature :
Alloy::Pointer::Pointer<MaterialBase> BuiltinMaterial(Entry<17>,bool)
- Note
- Additional signature: BuiltinMaterial( (SubMaterialReference)self, (bool)set_default_color) -> object
def sds2.sub_mtrl.ShearStudSubMaterialReference.cnc_dld |
( |
|
args | ) |
|
def sds2.sub_mtrl.ShearStudSubMaterialReference.control_file_entry_description |
( |
|
args | ) |
|
def sds2.sub_mtrl.ShearStudSubMaterialReference.dia |
( |
|
args | ) |
|
def sds2.sub_mtrl.ShearStudSubMaterialReference.dim_weight |
( |
|
args | ) |
|
def sds2.sub_mtrl.ShearStudSubMaterialReference.do_not_calc_poly_weight |
( |
|
args | ) |
|
def sds2.sub_mtrl.ShearStudSubMaterialReference.do_not_scribe |
( |
|
args | ) |
|
def sds2.sub_mtrl.ShearStudSubMaterialReference.dtl_quant |
( |
|
args | ) |
|
def sds2.sub_mtrl.ShearStudSubMaterialReference.dtl_rev_level |
( |
|
args | ) |
|
def sds2.sub_mtrl.ShearStudSubMaterialReference.dummy |
( |
|
args | ) |
|
def sds2.sub_mtrl.ShearStudSubMaterialReference.effective_index |
( |
|
args | ) |
|
def sds2.sub_mtrl.ShearStudSubMaterialReference.existing |
( |
|
args | ) |
|
def sds2.sub_mtrl.ShearStudSubMaterialReference.fitted |
( |
|
args | ) |
|
def sds2.sub_mtrl.ShearStudSubMaterialReference.graph_comp_date |
( |
|
args | ) |
|
def sds2.sub_mtrl.ShearStudSubMaterialReference.hash |
( |
|
args | ) |
|
def sds2.sub_mtrl.ShearStudSubMaterialReference.head |
( |
|
args | ) |
|
def sds2.sub_mtrl.ShearStudSubMaterialReference.head_dia |
( |
|
args | ) |
|
def sds2.sub_mtrl.ShearStudSubMaterialReference.imp_desc |
( |
|
args | ) |
|
def sds2.sub_mtrl.ShearStudSubMaterialReference.info_type |
( |
|
args | ) |
|
def sds2.sub_mtrl.ShearStudSubMaterialReference.last_quant |
( |
|
args | ) |
|
def sds2.sub_mtrl.ShearStudSubMaterialReference.last_rev_level |
( |
|
args | ) |
|
def sds2.sub_mtrl.ShearStudSubMaterialReference.length |
( |
|
args | ) |
|
def sds2.sub_mtrl.ShearStudSubMaterialReference.met_desc |
( |
|
args | ) |
|
def sds2.sub_mtrl.ShearStudSubMaterialReference.mtrl_idx |
( |
|
args | ) |
|
def sds2.sub_mtrl.ShearStudSubMaterialReference.mtrl_type |
( |
|
args | ) |
|
def sds2.sub_mtrl.ShearStudSubMaterialReference.needs_detail |
( |
|
args | ) |
|
def sds2.sub_mtrl.ShearStudSubMaterialReference.on_sheet |
( |
|
args | ) |
|
def sds2.sub_mtrl.ShearStudSubMaterialReference.pcmk_hash |
( |
|
args | ) |
|
def sds2.sub_mtrl.ShearStudSubMaterialReference.public_pcmk |
( |
|
args | ) |
|
def sds2.sub_mtrl.ShearStudSubMaterialReference.quant |
( |
|
args | ) |
|
def sds2.sub_mtrl.ShearStudSubMaterialReference.ref_x |
( |
|
args | ) |
|
def sds2.sub_mtrl.ShearStudSubMaterialReference.ref_y |
( |
|
args | ) |
|
def sds2.sub_mtrl.ShearStudSubMaterialReference.rev_date |
( |
|
args | ) |
|
def sds2.sub_mtrl.ShearStudSubMaterialReference.rev_level |
( |
|
args | ) |
|
def sds2.sub_mtrl.ShearStudSubMaterialReference.sec_hash |
( |
|
args | ) |
|
def sds2.sub_mtrl.ShearStudSubMaterialReference.srfc_area |
( |
|
args | ) |
|
def sds2.sub_mtrl.ShearStudSubMaterialReference.std_mark |
( |
|
args | ) |
|
def sds2.sub_mtrl.ShearStudSubMaterialReference.stretched |
( |
|
args | ) |
|
def sds2.sub_mtrl.ShearStudSubMaterialReference.sub_mtrl_idx |
( |
|
args | ) |
|
def sds2.sub_mtrl.ShearStudSubMaterialReference.thread_length |
( |
|
args | ) |
|
def sds2.sub_mtrl.ShearStudSubMaterialReference.threaded_stud |
( |
|
args | ) |
|
def sds2.sub_mtrl.ShearStudSubMaterialReference.usage |
( |
|
args | ) |
|
def sds2.sub_mtrl.ShearStudSubMaterialReference.user_description |
( |
|
args | ) |
|
def sds2.sub_mtrl.ShearStudSubMaterialReference.weight |
( |
|
args | ) |
|