No documentation available.
More...
Data and other attributes defined here: |
def | __init__ |
Data and other attributes inherited from Boost.Python.instance: |
def | __new__ |
Additional Inherited Members |
Detailed Description
No documentation available.
Method resolution order
StandardPartSubMaterialReference
GenMaterialSubMaterialReference
SubMaterialReference
Boost.Python.instance
builtin.object
Constructor & Destructor Documentation
def sds2.sub_mtrl.StandardPartSubMaterialReference.__init__ |
( |
|
args | ) |
|
Member Function Documentation
def sds2.sub_mtrl.StandardPartSubMaterialReference.__dict__ |
( |
|
args | ) |
|
def sds2.sub_mtrl.StandardPartSubMaterialReference.__new__ |
( |
|
args | ) |
|
def sds2.sub_mtrl.StandardPartSubMaterialReference.__reduce__ |
( |
|
args | ) |
|
def sds2.sub_mtrl.StandardPartSubMaterialReference.__weakref__ |
( |
|
args | ) |
|
def sds2.sub_mtrl.StandardPartSubMaterialReference.assm_mark |
( |
|
args | ) |
|
def sds2.sub_mtrl.StandardPartSubMaterialReference.bar_stock |
( |
|
args | ) |
|
def sds2.sub_mtrl.StandardPartSubMaterialReference.bend_angle |
( |
|
args | ) |
|
def sds2.sub_mtrl.StandardPartSubMaterialReference.bend_rad |
( |
|
args | ) |
|
def sds2.sub_mtrl.StandardPartSubMaterialReference.BuiltinMaterial |
( |
|
arg1 | ) |
|
- Returns
- Instance of type object
Return a BuiltinMaterial with the same properties as the
SubMaterialReference except with the color set to the job's
default color for the material type
C++ signature :
Alloy::Pointer::Pointer<MaterialBase> BuiltinMaterial(Entry<17>)
Return a BuiltinMaterial with the same properties as the
SubMaterialReference except with the option to override the color
C++ signature :
Alloy::Pointer::Pointer<MaterialBase> BuiltinMaterial(Entry<17>,bool)
- Note
- Additional signature: BuiltinMaterial( (SubMaterialReference)self, (bool)set_default_color) -> object
Reimplemented from sds2.sub_mtrl.GenMaterialSubMaterialReference.
def sds2.sub_mtrl.StandardPartSubMaterialReference.camber |
( |
|
args | ) |
|
def sds2.sub_mtrl.StandardPartSubMaterialReference.checkered |
( |
|
args | ) |
|
def sds2.sub_mtrl.StandardPartSubMaterialReference.cnc_dld |
( |
|
args | ) |
|
def sds2.sub_mtrl.StandardPartSubMaterialReference.control_file_entry_description |
( |
|
args | ) |
|
def sds2.sub_mtrl.StandardPartSubMaterialReference.dim_weight |
( |
|
args | ) |
|
def sds2.sub_mtrl.StandardPartSubMaterialReference.do_not_calc_poly_weight |
( |
|
args | ) |
|
def sds2.sub_mtrl.StandardPartSubMaterialReference.do_not_scribe |
( |
|
args | ) |
|
def sds2.sub_mtrl.StandardPartSubMaterialReference.dtl_quant |
( |
|
args | ) |
|
def sds2.sub_mtrl.StandardPartSubMaterialReference.dtl_rev_level |
( |
|
args | ) |
|
def sds2.sub_mtrl.StandardPartSubMaterialReference.dummy |
( |
|
args | ) |
|
def sds2.sub_mtrl.StandardPartSubMaterialReference.effective_index |
( |
|
args | ) |
|
def sds2.sub_mtrl.StandardPartSubMaterialReference.end_prep |
( |
|
args | ) |
|
def sds2.sub_mtrl.StandardPartSubMaterialReference.existing |
( |
|
args | ) |
|
def sds2.sub_mtrl.StandardPartSubMaterialReference.f_weld |
( |
|
args | ) |
|
def sds2.sub_mtrl.StandardPartSubMaterialReference.fitted |
( |
|
args | ) |
|
def sds2.sub_mtrl.StandardPartSubMaterialReference.flg_cut |
( |
|
args | ) |
|
def sds2.sub_mtrl.StandardPartSubMaterialReference.flip |
( |
|
args | ) |
|
def sds2.sub_mtrl.StandardPartSubMaterialReference.graph_comp_date |
( |
|
args | ) |
|
def sds2.sub_mtrl.StandardPartSubMaterialReference.hash |
( |
|
args | ) |
|
def sds2.sub_mtrl.StandardPartSubMaterialReference.imp_desc |
( |
|
args | ) |
|
def sds2.sub_mtrl.StandardPartSubMaterialReference.info_type |
( |
|
args | ) |
|
def sds2.sub_mtrl.StandardPartSubMaterialReference.last_quant |
( |
|
args | ) |
|
def sds2.sub_mtrl.StandardPartSubMaterialReference.last_rev_level |
( |
|
args | ) |
|
def sds2.sub_mtrl.StandardPartSubMaterialReference.left_btm_op_dim1 |
( |
|
args | ) |
|
def sds2.sub_mtrl.StandardPartSubMaterialReference.left_btm_op_dim2 |
( |
|
args | ) |
|
def sds2.sub_mtrl.StandardPartSubMaterialReference.left_btm_op_dim3 |
( |
|
args | ) |
|
def sds2.sub_mtrl.StandardPartSubMaterialReference.left_btm_op_dim4 |
( |
|
args | ) |
|
def sds2.sub_mtrl.StandardPartSubMaterialReference.left_btm_op_dim5 |
( |
|
args | ) |
|
def sds2.sub_mtrl.StandardPartSubMaterialReference.left_btm_op_dim6 |
( |
|
args | ) |
|
def sds2.sub_mtrl.StandardPartSubMaterialReference.left_btm_op_dim7 |
( |
|
args | ) |
|
def sds2.sub_mtrl.StandardPartSubMaterialReference.left_btm_op_dim8 |
( |
|
args | ) |
|
def sds2.sub_mtrl.StandardPartSubMaterialReference.left_btm_op_type |
( |
|
args | ) |
|
def sds2.sub_mtrl.StandardPartSubMaterialReference.left_top_op_dim1 |
( |
|
args | ) |
|
def sds2.sub_mtrl.StandardPartSubMaterialReference.left_top_op_dim2 |
( |
|
args | ) |
|
def sds2.sub_mtrl.StandardPartSubMaterialReference.left_top_op_dim3 |
( |
|
args | ) |
|
def sds2.sub_mtrl.StandardPartSubMaterialReference.left_top_op_dim4 |
( |
|
args | ) |
|
def sds2.sub_mtrl.StandardPartSubMaterialReference.left_top_op_dim5 |
( |
|
args | ) |
|
def sds2.sub_mtrl.StandardPartSubMaterialReference.left_top_op_dim6 |
( |
|
args | ) |
|
def sds2.sub_mtrl.StandardPartSubMaterialReference.left_top_op_dim7 |
( |
|
args | ) |
|
def sds2.sub_mtrl.StandardPartSubMaterialReference.left_top_op_dim8 |
( |
|
args | ) |
|
def sds2.sub_mtrl.StandardPartSubMaterialReference.left_top_op_type |
( |
|
args | ) |
|
def sds2.sub_mtrl.StandardPartSubMaterialReference.leg |
( |
|
args | ) |
|
def sds2.sub_mtrl.StandardPartSubMaterialReference.length |
( |
|
args | ) |
|
def sds2.sub_mtrl.StandardPartSubMaterialReference.llv |
( |
|
args | ) |
|
def sds2.sub_mtrl.StandardPartSubMaterialReference.met_desc |
( |
|
args | ) |
|
def sds2.sub_mtrl.StandardPartSubMaterialReference.mtrl_idx |
( |
|
args | ) |
|
def sds2.sub_mtrl.StandardPartSubMaterialReference.mtrl_stbk |
( |
|
args | ) |
|
def sds2.sub_mtrl.StandardPartSubMaterialReference.mtrl_type |
( |
|
args | ) |
|
def sds2.sub_mtrl.StandardPartSubMaterialReference.mtrl_use |
( |
|
args | ) |
|
def sds2.sub_mtrl.StandardPartSubMaterialReference.needs_detail |
( |
|
args | ) |
|
def sds2.sub_mtrl.StandardPartSubMaterialReference.on_sheet |
( |
|
args | ) |
|
def sds2.sub_mtrl.StandardPartSubMaterialReference.origin |
( |
|
args | ) |
|
def sds2.sub_mtrl.StandardPartSubMaterialReference.osl |
( |
|
args | ) |
|
def sds2.sub_mtrl.StandardPartSubMaterialReference.part_length |
( |
|
args | ) |
|
def sds2.sub_mtrl.StandardPartSubMaterialReference.pcmk_hash |
( |
|
args | ) |
|
def sds2.sub_mtrl.StandardPartSubMaterialReference.pl_area |
( |
|
args | ) |
|
def sds2.sub_mtrl.StandardPartSubMaterialReference.public_pcmk |
( |
|
args | ) |
|
def sds2.sub_mtrl.StandardPartSubMaterialReference.quant |
( |
|
args | ) |
|
def sds2.sub_mtrl.StandardPartSubMaterialReference.rad |
( |
|
args | ) |
|
def sds2.sub_mtrl.StandardPartSubMaterialReference.reent_hole_dist |
( |
|
args | ) |
|
def sds2.sub_mtrl.StandardPartSubMaterialReference.ref_x |
( |
|
args | ) |
|
def sds2.sub_mtrl.StandardPartSubMaterialReference.ref_y |
( |
|
args | ) |
|
def sds2.sub_mtrl.StandardPartSubMaterialReference.rev_date |
( |
|
args | ) |
|
def sds2.sub_mtrl.StandardPartSubMaterialReference.rev_level |
( |
|
args | ) |
|
def sds2.sub_mtrl.StandardPartSubMaterialReference.right_btm_op_dim1 |
( |
|
args | ) |
|
def sds2.sub_mtrl.StandardPartSubMaterialReference.right_btm_op_dim2 |
( |
|
args | ) |
|
def sds2.sub_mtrl.StandardPartSubMaterialReference.right_btm_op_dim3 |
( |
|
args | ) |
|
def sds2.sub_mtrl.StandardPartSubMaterialReference.right_btm_op_dim4 |
( |
|
args | ) |
|
def sds2.sub_mtrl.StandardPartSubMaterialReference.right_btm_op_dim5 |
( |
|
args | ) |
|
def sds2.sub_mtrl.StandardPartSubMaterialReference.right_btm_op_dim6 |
( |
|
args | ) |
|
def sds2.sub_mtrl.StandardPartSubMaterialReference.right_btm_op_dim7 |
( |
|
args | ) |
|
def sds2.sub_mtrl.StandardPartSubMaterialReference.right_btm_op_dim8 |
( |
|
args | ) |
|
def sds2.sub_mtrl.StandardPartSubMaterialReference.right_btm_op_type |
( |
|
args | ) |
|
def sds2.sub_mtrl.StandardPartSubMaterialReference.right_top_op_dim1 |
( |
|
args | ) |
|
def sds2.sub_mtrl.StandardPartSubMaterialReference.right_top_op_dim2 |
( |
|
args | ) |
|
def sds2.sub_mtrl.StandardPartSubMaterialReference.right_top_op_dim3 |
( |
|
args | ) |
|
def sds2.sub_mtrl.StandardPartSubMaterialReference.right_top_op_dim4 |
( |
|
args | ) |
|
def sds2.sub_mtrl.StandardPartSubMaterialReference.right_top_op_dim5 |
( |
|
args | ) |
|
def sds2.sub_mtrl.StandardPartSubMaterialReference.right_top_op_dim6 |
( |
|
args | ) |
|
def sds2.sub_mtrl.StandardPartSubMaterialReference.right_top_op_dim7 |
( |
|
args | ) |
|
def sds2.sub_mtrl.StandardPartSubMaterialReference.right_top_op_dim8 |
( |
|
args | ) |
|
def sds2.sub_mtrl.StandardPartSubMaterialReference.right_top_op_type |
( |
|
args | ) |
|
def sds2.sub_mtrl.StandardPartSubMaterialReference.roll_type |
( |
|
args | ) |
|
def sds2.sub_mtrl.StandardPartSubMaterialReference.rolled_mtrl_ref_pt |
( |
|
args | ) |
|
def sds2.sub_mtrl.StandardPartSubMaterialReference.rolled_offset |
( |
|
args | ) |
|
def sds2.sub_mtrl.StandardPartSubMaterialReference.sec_hash |
( |
|
args | ) |
|
def sds2.sub_mtrl.StandardPartSubMaterialReference.srfc_area |
( |
|
args | ) |
|
def sds2.sub_mtrl.StandardPartSubMaterialReference.stair_mtrl_use |
( |
|
args | ) |
|
def sds2.sub_mtrl.StandardPartSubMaterialReference.std_mark |
( |
|
args | ) |
|
def sds2.sub_mtrl.StandardPartSubMaterialReference.stretched |
( |
|
args | ) |
|
def sds2.sub_mtrl.StandardPartSubMaterialReference.sub_mtrl_idx |
( |
|
args | ) |
|
def sds2.sub_mtrl.StandardPartSubMaterialReference.taper_rad |
( |
|
args | ) |
|
def sds2.sub_mtrl.StandardPartSubMaterialReference.thick |
( |
|
args | ) |
|
def sds2.sub_mtrl.StandardPartSubMaterialReference.thread_length |
( |
|
args | ) |
|
def sds2.sub_mtrl.StandardPartSubMaterialReference.thread_type |
( |
|
args | ) |
|
def sds2.sub_mtrl.StandardPartSubMaterialReference.toe_io |
( |
|
args | ) |
|
def sds2.sub_mtrl.StandardPartSubMaterialReference.trans_width |
( |
|
args | ) |
|
def sds2.sub_mtrl.StandardPartSubMaterialReference.twist |
( |
|
args | ) |
|
def sds2.sub_mtrl.StandardPartSubMaterialReference.usage |
( |
|
args | ) |
|
def sds2.sub_mtrl.StandardPartSubMaterialReference.user_description |
( |
|
args | ) |
|
def sds2.sub_mtrl.StandardPartSubMaterialReference.web_cut |
( |
|
args | ) |
|
def sds2.sub_mtrl.StandardPartSubMaterialReference.web_stbk |
( |
|
args | ) |
|
def sds2.sub_mtrl.StandardPartSubMaterialReference.weight |
( |
|
args | ) |
|
def sds2.sub_mtrl.StandardPartSubMaterialReference.width |
( |
|
args | ) |
|
def sds2.sub_mtrl.StandardPartSubMaterialReference.wkpt_slope |
( |
|
args | ) |
|