No documentation available.
More...
Data and other attributes defined here: |
def | __init__ |
Data and other attributes inherited from Boost.Python.instance: |
def | __new__ |
Detailed Description
No documentation available.
Method resolution order
WasherSubMaterialReference
SubMaterialReference
Boost.Python.instance
builtin.object
Constructor & Destructor Documentation
def sds2.sub_mtrl.WasherSubMaterialReference.__init__ |
( |
|
args | ) |
|
Raises an exception
This class cannot be instantiated from Python
__init__ = <built-in function __init__>
Member Function Documentation
def sds2.sub_mtrl.WasherSubMaterialReference.__dict__ |
( |
|
args | ) |
|
def sds2.sub_mtrl.WasherSubMaterialReference.__new__ |
( |
|
args | ) |
|
T.__new__(S, ...) -> a new object with type S, a subtype of T
__new__ = <built-in method __new__ of Boost.Python.class object>
def sds2.sub_mtrl.WasherSubMaterialReference.__reduce__ |
( |
|
args | ) |
|
__reduce__ = <unnamed Boost.Python function>(args)
def sds2.sub_mtrl.WasherSubMaterialReference.__weakref__ |
( |
|
args | ) |
|
def sds2.sub_mtrl.WasherSubMaterialReference.assm_mark |
( |
|
args | ) |
|
def sds2.sub_mtrl.WasherSubMaterialReference.BuiltinMaterial |
( |
|
arg1 | ) |
|
- Returns
- Instance of type object
Return a BuiltinMaterial with the same properties as the
SubMaterialReference except with the color set to the job's
default color for the material type
C++ signature :
Alloy::Pointer::Pointer<MaterialBase> BuiltinMaterial(Entry<17>)
Return a BuiltinMaterial with the same properties as the
SubMaterialReference except with the option to override the color
C++ signature :
Alloy::Pointer::Pointer<MaterialBase> BuiltinMaterial(Entry<17>,bool)
- Note
- Additional signature: BuiltinMaterial( (SubMaterialReference)self, (bool)set_default_color) -> object
def sds2.sub_mtrl.WasherSubMaterialReference.cnc_dld |
( |
|
args | ) |
|
def sds2.sub_mtrl.WasherSubMaterialReference.control_file_entry_description |
( |
|
args | ) |
|
def sds2.sub_mtrl.WasherSubMaterialReference.dim_weight |
( |
|
args | ) |
|
def sds2.sub_mtrl.WasherSubMaterialReference.do_not_calc_poly_weight |
( |
|
args | ) |
|
def sds2.sub_mtrl.WasherSubMaterialReference.do_not_scribe |
( |
|
args | ) |
|
def sds2.sub_mtrl.WasherSubMaterialReference.dtl_quant |
( |
|
args | ) |
|
def sds2.sub_mtrl.WasherSubMaterialReference.dtl_rev_level |
( |
|
args | ) |
|
def sds2.sub_mtrl.WasherSubMaterialReference.dummy |
( |
|
args | ) |
|
def sds2.sub_mtrl.WasherSubMaterialReference.effective_index |
( |
|
args | ) |
|
def sds2.sub_mtrl.WasherSubMaterialReference.existing |
( |
|
args | ) |
|
def sds2.sub_mtrl.WasherSubMaterialReference.finish |
( |
|
args | ) |
|
def sds2.sub_mtrl.WasherSubMaterialReference.fitted |
( |
|
args | ) |
|
def sds2.sub_mtrl.WasherSubMaterialReference.graph_comp_date |
( |
|
args | ) |
|
def sds2.sub_mtrl.WasherSubMaterialReference.hash |
( |
|
args | ) |
|
def sds2.sub_mtrl.WasherSubMaterialReference.imp_desc |
( |
|
args | ) |
|
def sds2.sub_mtrl.WasherSubMaterialReference.info_type |
( |
|
args | ) |
|
def sds2.sub_mtrl.WasherSubMaterialReference.last_quant |
( |
|
args | ) |
|
def sds2.sub_mtrl.WasherSubMaterialReference.last_rev_level |
( |
|
args | ) |
|
def sds2.sub_mtrl.WasherSubMaterialReference.met_desc |
( |
|
args | ) |
|
def sds2.sub_mtrl.WasherSubMaterialReference.mtrl_idx |
( |
|
args | ) |
|
def sds2.sub_mtrl.WasherSubMaterialReference.mtrl_type |
( |
|
args | ) |
|
def sds2.sub_mtrl.WasherSubMaterialReference.needs_detail |
( |
|
args | ) |
|
def sds2.sub_mtrl.WasherSubMaterialReference.nominal_size |
( |
|
args | ) |
|
def sds2.sub_mtrl.WasherSubMaterialReference.on_sheet |
( |
|
args | ) |
|
def sds2.sub_mtrl.WasherSubMaterialReference.pcmk_hash |
( |
|
args | ) |
|
def sds2.sub_mtrl.WasherSubMaterialReference.public_pcmk |
( |
|
args | ) |
|
def sds2.sub_mtrl.WasherSubMaterialReference.quant |
( |
|
args | ) |
|
def sds2.sub_mtrl.WasherSubMaterialReference.ref_x |
( |
|
args | ) |
|
def sds2.sub_mtrl.WasherSubMaterialReference.ref_y |
( |
|
args | ) |
|
def sds2.sub_mtrl.WasherSubMaterialReference.rev_date |
( |
|
args | ) |
|
def sds2.sub_mtrl.WasherSubMaterialReference.rev_level |
( |
|
args | ) |
|
def sds2.sub_mtrl.WasherSubMaterialReference.sec_hash |
( |
|
args | ) |
|
def sds2.sub_mtrl.WasherSubMaterialReference.srfc_area |
( |
|
args | ) |
|
def sds2.sub_mtrl.WasherSubMaterialReference.std_mark |
( |
|
args | ) |
|
def sds2.sub_mtrl.WasherSubMaterialReference.stretched |
( |
|
args | ) |
|
def sds2.sub_mtrl.WasherSubMaterialReference.sub_mtrl_idx |
( |
|
args | ) |
|
def sds2.sub_mtrl.WasherSubMaterialReference.usage |
( |
|
args | ) |
|
def sds2.sub_mtrl.WasherSubMaterialReference.user_description |
( |
|
args | ) |
|
def sds2.sub_mtrl.WasherSubMaterialReference.weight |
( |
|
args | ) |
|